]> git.pld-linux.org Git - SPECS.git/blob - ruby-iso8601.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / ruby-iso8601.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname iso8601
6 Summary:        Ruby parser to work with ISO 8601 dateTimes and durations - http://en.wikipedia.org/wiki/ISO_8601
7 Name:           ruby-%{pkgname}
8 Version:        0.9.1
9 Release:        2
10 License:        MIT
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13 # Source0-md5:  c06e3b9f98b233274b5f52f02e970332
14 URL:            https://github.com/arnau/ISO8601
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.656
17 %if %{with tests}
18 BuildRequires:  ruby-pry < 0.11
19 BuildRequires:  ruby-pry >= 0.10.3
20 BuildRequires:  ruby-pry-doc < 0.9
21 BuildRequires:  ruby-pry-doc >= 0.8.0
22 BuildRequires:  ruby-rspec < 4
23 BuildRequires:  ruby-rspec >= 3.4
24 BuildRequires:  ruby-rubocop < 1
25 BuildRequires:  ruby-rubocop >= 0.40
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 ISO8601 is a simple implementation in Ruby of the ISO 8601 (Data
32 elements and interchange formats - Information interchange -
33 Representation of dates and times) standard.
34
35 %prep
36 %setup -q -n %{pkgname}-%{version}
37
38 %build
39 # write .gemspec
40 %__gem_helper spec
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
45 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
46 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %{ruby_vendorlibdir}/%{pkgname}.rb
54 %{ruby_vendorlibdir}/%{pkgname}
55 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.084343 seconds and 3 git commands to generate.