]> git.pld-linux.org Git - SPECS.git/blob - ruby-ftw.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / ruby-ftw.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname ftw
6 Summary:        Ruby FTW - For The Web. Experimentation in web clients and servers
7 Name:           ruby-%{pkgname}
8 Version:        0.0.34
9 Release:        2
10 License:        Apache v2.0
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13 # Source0-md5:  1ad00afe5009fdb887c70e3a107891e2
14 URL:            http://github.com/jordansissel/ruby-ftw
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.665
17 %if %{with tests}
18 BuildRequires:  ruby-minitest
19 %endif
20 Requires:       ruby-addressable
21 Requires:       ruby-backports >= 2.6.2
22 Requires:       ruby-cabin
23 Requires:       ruby-http_parser.rb = 0.5.3
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 For The Web. Trying to build a solid and sane API for client and
29 server web stuff. Client and Server operations for HTTP, WebSockets,
30 SPDY, etc.
31
32 %prep
33 %setup -q -n %{pkgname}-%{version}
34
35 %build
36 %__gem_helper spec
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
41 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
42 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %{ruby_vendorlibdir}/%{pkgname}.rb
50 %{ruby_vendorlibdir}/%{pkgname}
51 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
52
53 # ruby-rack subpackage?
54 %dir %{ruby_vendorlibdir}/rack
55 %dir %{ruby_vendorlibdir}/rack/handler
56 %{ruby_vendorlibdir}/rack/handler/ftw.rb
This page took 0.764844 seconds and 3 git commands to generate.