]> git.pld-linux.org Git - SPECS.git/blob - ruby-chef-config.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / ruby-chef-config.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define pkgname chef-config
6 Summary:        Chef's default configuration and config loading
7 Name:           ruby-%{pkgname}
8 Version:        12.10.24
9 Release:        0.1
10 License:        Apache v2.0
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13 # Source0-md5:  c0515424c9122e4e0c561d6a4b267123
14 URL:            https://github.com/chef/chef
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.656
17 %if %{with tests}
18 BuildRequires:  ruby-rake < 11
19 BuildRequires:  ruby-rake >= 10.0
20 BuildRequires:  ruby-rspec-core < 4
21 BuildRequires:  ruby-rspec-core >= 3.2
22 BuildRequires:  ruby-rspec-expectations < 4
23 BuildRequires:  ruby-rspec-expectations >= 3.2
24 BuildRequires:  ruby-rspec-mocks < 4
25 BuildRequires:  ruby-rspec-mocks >= 3.2
26 %endif
27 Requires:       ruby-fuzzyurl < 0.9
28 Requires:       ruby-fuzzyurl >= 0.8.0
29 Requires:       ruby-mixlib-config < 3
30 Requires:       ruby-mixlib-config >= 2.0
31 Requires:       ruby-mixlib-shellout < 3
32 Requires:       ruby-mixlib-shellout >= 2.0
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Chef's default configuration and config loading.
38
39
40 %prep
41 %setup -q -n %{pkgname}-%{version}
42
43 %build
44 # write .gemspec
45 %__gem_helper spec
46
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
51 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
52 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %{ruby_vendorlibdir}/%{pkgname}.rb
60 %{ruby_vendorlibdir}/%{pkgname}
61 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.826795 seconds and 3 git commands to generate.