]> git.pld-linux.org Git - SPECS.git/blob - ruby-celluloid.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / ruby-celluloid.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname celluloid
6 Summary:        Actor-based concurrent object framework for Ruby
7 Name:           ruby-%{pkgname}
8 Version:        0.15.2
9 Release:        3
10 License:        MIT
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13 # Source0-md5:  ceaf6e864471fa988290bd18b69dc799
14 URL:            https://github.com/celluloid/celluloid
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.665
17 %if %{with tests}
18 BuildRequires:  ruby-benchmark_suite
19 BuildRequires:  ruby-guard-rspec
20 BuildRequires:  ruby-rake
21 BuildRequires:  ruby-rspec
22 %endif
23 Requires:       ruby-rubygems >= 1.3.6
24 Requires:       ruby-timers < 1.2
25 Requires:       ruby-timers >= 1.1.0
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Celluloid enables people to build concurrent programs out of
31 concurrent objects just as easily as they build sequential programs
32 out of sequential objects.
33
34 %prep
35 %setup -q -n %{pkgname}-%{version}
36
37 %build
38 # write .gemspec
39 %__gem_helper spec
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
44 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
45 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %{ruby_vendorlibdir}/celluloid.rb
53 %{ruby_vendorlibdir}/celluloid
54 %{ruby_specdir}/celluloid-%{version}.gemspec
This page took 0.17201 seconds and 3 git commands to generate.