]> git.pld-linux.org Git - SPECS.git/blob - ruby-celluloid-io.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / ruby-celluloid-io.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname celluloid-io
6 Summary:        Celluloid::IO allows you to monitor multiple IO objects within a Celluloid actor
7 Name:           ruby-%{pkgname}
8 Version:        0.15.0
9 Release:        2
10 License:        MIT
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13 # Source0-md5:  39d561d3596c24eb81c1d500f0b82c25
14 URL:            http://github.com/celluloid/celluloid-io
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.656
17 %if %{with tests}
18 BuildRequires:  ruby-benchmark_suite
19 BuildRequires:  ruby-guard-rspec
20 BuildRequires:  ruby-rake
21 BuildRequires:  ruby-rb-fsevent < 0.10
22 BuildRequires:  ruby-rb-fsevent >= 0.9.1
23 BuildRequires:  ruby-rspec
24 %endif
25 Requires:       ruby-celluloid >= 0.15.0
26 Requires:       ruby-nio4r >= 0.5.0
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Evented IO for Celluloid actors
32
33 %prep
34 %setup -q -n %{pkgname}-%{version}
35
36 %build
37 %__gem_helper spec
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
42 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
43 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc README.md CHANGES.md LICENSE.txt
51 %{ruby_vendorlibdir}/celluloid/io.rb
52 %{ruby_vendorlibdir}/celluloid/io
53 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.249295 seconds and 3 git commands to generate.