]> git.pld-linux.org Git - SPECS.git/blob - ruby-arr-pm.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / ruby-arr-pm.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname arr-pm
6 Summary:        RPM reader and writer library
7 Name:           ruby-%{pkgname}
8 Version:        0.0.10
9 Release:        2
10 License:        Apache v2.0
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13 # Source0-md5:  6c23ba073b590440c37042a85e0786d3
14 URL:            https://github.com/jordansissel/ruby-arr-pm
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.665
17 %if %{with tests}
18 BuildRequires:  ruby-flores
19 %endif
20 Requires:       cpio
21 Requires:       ruby-cabin
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This library allows to you to read and write rpm packages. Written in
27 pure ruby because librpm is not available on all systems
28
29 %prep
30 %setup -q -n %{pkgname}-%{version}
31
32 %build
33 %__gem_helper spec
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
38 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
39 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %{ruby_vendorlibdir}/%{pkgname}.rb
47 %{ruby_vendorlibdir}/%{pkgname}
48 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.130142 seconds and 3 git commands to generate.