]> git.pld-linux.org Git - SPECS.git/blob - ruby-app_conf.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / ruby-app_conf.spec
1 %define pkgname app_conf
2 Summary:        Simplest YAML Backed Application Wide Configuration
3 Name:           ruby-%{pkgname}
4 Version:        0.4.2
5 Release:        1
6 License:        MIT
7 Group:          Development/Languages
8 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
9 # Source0-md5:  fc0f790c06355c87ac2717eaa16ca605
10 URL:            https://github.com/PhilT/app_conf
11 BuildRequires:  rpm-rubyprov
12 BuildRequires:  rpmbuild(macros) >= 1.656
13 BuildArch:      noarch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 YAML Backed Application Wide Configuration with a few extras
18 (AppConfig like)
19
20 - Supports nested key/values
21 - Loading and Saving of YAML files
22 - Add further key/value pairs in code
23 - Use dot or bracket notation
24 - AppConf#to_hash outputs a hash map of AppConf key/values
25 - AppConf#from_hash creates nested key/values from a hash
26
27 %prep
28 %setup -q -n %{pkgname}-%{version}
29
30 %install
31 rm -rf $RPM_BUILD_ROOT
32 install -d $RPM_BUILD_ROOT%{ruby_vendorlibdir}
33 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
34
35 %clean
36 rm -rf $RPM_BUILD_ROOT
37
38 %files
39 %defattr(644,root,root,755)
40 %doc README.markdown LICENSE 
41 %{ruby_vendorlibdir}/%{pkgname}.rb
This page took 0.097055 seconds and 3 git commands to generate.