]> git.pld-linux.org Git - packages/ruby-activerecord.git/blob - ruby-activerecord.spec
- up to 1.9.1
[packages/ruby-activerecord.git] / ruby-activerecord.spec
1 #
2 # TODO
3
4 # - rip out vendor libraries: mysql.rb, sqlite.rb, simple.rb
5 #
6 %define ruby_rubylibdir %(ruby -r rbconfig -e 'print Config::CONFIG["rubylibdir"]')
7 %define ruby_ridir      %(ruby -r rbconfig -e 'include Config; print File.join(CONFIG["datadir"], "ri", CONFIG["ruby_version"])')
8 %define ruby_version    %(ruby -r rbconfig -e 'print Config::CONFIG["ruby_version"]')
9 Summary:        Object-Relational mapping library for Ruby
10 Summary(pl):    Biblioteka odwzorowañ obiektowo-relacyjnych dla Ruby
11 Name:           ruby-ActiveRecord
12 %define tarname activerecord
13 Version:        1.9.1
14 Release:        1
15 License:        Ruby-alike
16 Group:          Development/Languages
17 Source0:        http://rubyforge.org/frs/download.php/3681/%{tarname}-%{version}.tgz
18 # Source0-md5:  a8ca8ae1887654abe5cff82362472821
19 uRL:            http://activerecord.rubyonrails.org/
20 BuildRequires:  ruby
21 Requires:       ruby
22 Requires: ruby-ActiveSupport
23 #BuildArch:     noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This pachage contains Object-Relational mapping library for Ruby.
28
29 %description -l pl
30 Ten pakiet zawiera bibliotekê odwzorowañ obiektowo-relacyjnych dla
31 Ruby.
32
33 %prep
34 %setup -q -n %{tarname}-%{version}
35
36 %build
37 rdoc --ri --op ri lib
38 rdoc --op rdoc lib
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 mkdir -p $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{ruby_ridir}}
43 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
44 cp -a ri/ri/* $RPM_BUILD_ROOT%{ruby_ridir}
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %doc rdoc README
52 %{ruby_rubylibdir}/*
53 %{ruby_ridir}/ActiveRecord
This page took 0.033246 seconds and 4 git commands to generate.