]> git.pld-linux.org Git - packages/ruby-activerecord.git/blob - ruby-activerecord.spec
- removed outdated toto
[packages/ruby-activerecord.git] / ruby-activerecord.spec
1 %define pkgname activerecord
2 Summary:        Object-Relational mapping library for Ruby
3 Summary(pl.UTF-8):      Biblioteka odwzorowań obiektowo-relacyjnych dla Ruby
4 Name:           ruby-%{pkgname}
5 Version:        2.3.5
6 Release:        1
7 License:        Ruby-alike
8 Group:          Development/Languages
9 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
10 # Source0-md5:  48a9ab7fbac97478fac9722fb5e14cda
11 Patch0:         %{name}-rubygems.patch
12 URL:            http://rubyforge.org/projects/activerecord/
13 BuildRequires:  rpmbuild(macros) >= 1.277
14 BuildRequires:  ruby >= 1:1.8.6
15 BuildRequires:  ruby-modules
16 %{?ruby_mod_ver_requires_eq}
17 Requires:       ruby-activesupport >= 2.3.5
18 Obsoletes:      ruby-ActiveRecord
19 Provides:       ruby-ActiveRecord
20 #BuildArch:     noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 # nothing to be placed there. we're not noarch only because of ruby packaging
24 %define         _enable_debug_packages  0
25
26 %description
27 This package contains Object-Relational mapping library for Ruby.
28
29 %description -l pl.UTF-8
30 Ten pakiet zawiera bibliotekę odwzorowań obiektowo-relacyjnych dla
31 Ruby.
32
33 %package rdoc
34 Summary:        Documentation files for ActiveRecord
35 Summary(pl.UTF-8):      Dokumentacja do biblioteki ActiveRecord
36 Group:          Documentation
37 Requires:       ruby >= 1:1.8.7-4
38
39 %description rdoc
40 Documentation files for ActiveRecord.
41
42 %description rdoc -l pl.UTF-8
43 Dokumentacja do biblioteki ActiveRecord.
44
45 %package ri
46 Summary:        ri documentation for %{pkgname}
47 Summary(pl.UTF-8):      Dokumentacja w formacie ri dla %{pkgname}
48 Group:          Documentation
49 Requires:       ruby
50
51 %description ri
52 ri documentation for %{pkgname}.
53
54 %description ri -l pl.UTF-8
55 Dokumentacji w formacie ri dla %{pkgname}.
56
57 %prep
58 %setup -q -c
59 %{__tar} xf %{SOURCE0} -O data.tar.gz | %{__tar} xz
60 find -newer README  -o -print | xargs touch --reference %{SOURCE0}
61 %patch0 -p1
62
63 # cleanup backups after patching
64 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
65
66 %build
67 rdoc --ri --op ri lib
68 rdoc --op rdoc lib
69 rm -rf ri/{Fixture*,I18n,MysqlCompat,PGresult,Test,YAML}
70 rm ri/created.rid
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{ruby_ridir},%{ruby_rdocdir}}
75
76 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
77 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
78 cp -a rdoc $RPM_BUILD_ROOT%{ruby_rdocdir}/%{pkgname}-%{version}-%{release}
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc CHANGELOG README examples
86 %{ruby_rubylibdir}/active_record
87 %{ruby_rubylibdir}/active_record.rb
88 %{ruby_rubylibdir}/activerecord.rb
89
90 %files rdoc
91 %defattr(644,root,root,755)
92 %{ruby_rdocdir}/%{pkgname}-%{version}-%{release}
93
94 %files ri
95 %defattr(644,root,root,755)
96 %{ruby_ridir}/ActiveRecord
This page took 0.027716 seconds and 3 git commands to generate.