]> git.pld-linux.org Git - SPECS.git/blob - ruby-ZenTest.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / ruby-ZenTest.spec
1 Summary:        Ruby Testing framework
2 Summary(pl.UTF-8):      Szkielet do testów dla języka Ruby
3 Name:           ruby-ZenTest
4 Version:        3.0.0
5 Release:        1
6 License:        GPL
7 Group:          Development/Languages
8 Source0:        http://rubyforge.org/frs/download.php/9048/ZenTest-%{version}.tar.gz
9 # Source0-md5:  cef297906ffad7e024737727df9ea0fe
10 Patch0: %{name}-nogems.patch
11 URL: http://www.zenspider.com/ZSS/Products/ZenTest/
12 BuildRequires:  rpmbuild(macros) >= 1.277
13 BuildRequires:  ruby-modules
14 BuildRequires:  rake
15 BuildRequires:  sed >= 4.0
16 %{?ruby_mod_ver_requires_eq}
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 ZenTest scans your target and unit-test code and writes your missing
22 code based on simple naming rules, enabling XP at a much quicker pace.
23 ZenTest only works with Ruby and Test::Unit.
24
25 For auditing, ZenTest provides an excellent means of finding methods
26 that have slipped through the testing process. I've run it against my
27 own software and found I missed a lot in a well tested package.
28 Writing those tests found 4 bugs I had no idea existed.
29
30 %description -l pl.UTF-8
31 ZenTest skanuje cel oraz kod testów jednostkowych i pisze brakujący
32 kod w oparciu o proste reguły nazywania, pozwalając na duży szybsze
33 XP. ZenTest działa tylko z Rubym i Test::Unit.
34
35 Dla potrzeb audytu ZenTest dostarcza świetne środki znajdowania metod
36 wyślizgujących się z procesu testowania. Autor uruchamiał je na
37 własnym oprogramowaniu i znalazł, że wiele pominął w dobrze
38 przetestowanym pakiecie. Napisanie tych testów znalazło 4 błędy, o
39 których istnieniu autor nie miał pojęcia.
40
41 %prep
42 %setup -q -n ZenTest-%{version}
43 find . -name '*.rb' | xargs sed -i -e '1s,#!.*local/bin/ruby,#!%{_bindir}/ruby,'
44 find bin -type f | xargs sed -i -e '1s,#!.*local/bin/ruby,#!%{_bindir}/ruby,'
45 %patch0 -p1
46
47 %build
48 rake
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT{%{_bindir},%{ruby_rubylibdir}}
53
54 install bin/* $RPM_BUILD_ROOT%{_bindir}
55 install lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}/
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %attr(755,root,root) %{_bindir}/*
63 %{ruby_rubylibdir}/*
This page took 0.374746 seconds and 3 git commands to generate.