]> git.pld-linux.org Git - SPECS.git/blob - rtmidi.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / rtmidi.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # build without ALSA backend
4 %bcond_without  jack            # build without Jack backend
5 #
6 Summary:        Common API for realtime MIDI input/output
7 Name:           rtmidi
8 Version:        3.0.0
9 Release:        1
10 License:        MIT
11 Group:          Applications
12 Source0:        http://www.music.mcgill.ca/~gary/rtmidi/release/%{name}-%{version}.tar.gz
13 # Source0-md5:  d22e3a5dee972fa0725c420923f1ce65
14 Patch0:         linking.patch
15 URL:            http://music.mcgill.ca/%7Egary/rtmidi/
16 %{?with_alsa:BuildRequires:     alsa-lib-devel}
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
20 BuildRequires:  libtool
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 RtMidi is a set of C++ classes (RtMidiIn, RtMidiOut and API-specific
25 classes) that provides a common API (Application Programming
26 Interface) for realtime MIDI input/output across Linux (ALSA & JACK),
27 Macintosh OS X (CoreMIDI & JACK), and Windows (Multimedia Library)
28 operating systems. RtMidi significantly simplifies the process of
29 interacting with computer MIDI hardware and software. It was designed
30 with the following goals:
31
32 - object oriented C++ design
33 - simple, common API across all supported platforms
34 - only one header and one source file for easy inclusion in
35   programming projects
36 - MIDI device enumeration
37
38 %package devel
39 Summary:        Header files for %{name} library
40 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description devel
45 Header files for %{name} library.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki %{name}.
49
50 %package static
51 Summary:        Static %{name} library
52 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static %{name} library.
58
59 %description static -l pl.UTF-8
60 Statyczna biblioteka %{name}.
61
62 %prep
63 %setup -q
64
65 %patch0 -p1
66
67 %build
68 #%%{__gettextize}
69 %{__libtoolize}
70 %{__aclocal}
71 %{__autoconf}
72 %{__automake}
73
74 %configure \
75         %{__with jack} \
76         %{__with alsa}
77
78 %{__make} V=1
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post   -p /sbin/ldconfig
90 %postun -p /sbin/ldconfig
91
92 %files
93 %defattr(644,root,root,755)
94 %doc README.md doc/html
95 %attr(755,root,root) %{_libdir}/librtmidi.so.4.*
96 %ghost %{_libdir}/librtmidi.so.4
97
98 %files devel
99 %defattr(644,root,root,755)
100 %doc doc/html
101 %{_libdir}/librtmidi.la
102 %{_libdir}/librtmidi.so
103 %{_includedir}/%{name}
104 %{_pkgconfigdir}/%{name}.pc
105
106 %files static
107 %defattr(644,root,root,755)
108 %{_libdir}/librtmidi.a
This page took 0.191871 seconds and 3 git commands to generate.