]> git.pld-linux.org Git - packages/rtl8812au.git/blob - rtl8812au.spec
- fix building with linux 4.0
[packages/rtl8812au.git] / rtl8812au.spec
1 # Conditional build:
2 %bcond_with     verbose         # verbose build (V=1)
3
4 # nothing to be placed to debuginfo package
5 %define         _enable_debug_packages  0
6
7 %define         rel     8
8 %define         snap    20140901
9 %define         pname   rtl8812au
10 Summary:        Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter
11 Name:           %{pname}%{_alt_kernel}
12 Version:        4.3.2_11100.20140411
13 Release:        0.%{snap}.%{rel}%{?_pld_builder:@%{_kernel_ver_str}}
14 License:        GPL
15 Group:          Base/Kernel
16 #Source0:       https://github.com/abperiasamy/rtl8812AU_8821AU_linux/archive/master/%{name}-%{version}-%{snap}.tar.gz
17 Source0:        https://github.com/austinmarton/rtl8812au_linux/archive/master/%{pname}-%{version}-%{snap}.tar.gz
18 # Source0-md5:  693825ab344b68a1217f20ab8dd98b82
19 # good luck finding this chip on Realtek website :/
20 #URL:           http://www.realtek.com.tw/
21 URL:            https://github.com/austinmarton/rtl8812au_linux
22 Patch0:         linux-3.11.patch
23 Patch1:         disable-debug.patch
24 Patch2:         enable-cfg80211-support.patch
25 Patch3:         update-cfg80211-support.patch
26 Patch4:         warnings.patch
27 Patch5:         gcc-4.9.patch
28 Patch6:         linux-3.18.patch
29 Patch7:         linux-4.0.patch
30 BuildRequires:  rpmbuild(macros) >= 1.701
31 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
32 BuildRoot:      %{tmpdir}/%{pname}-%{version}-root-%(id -u -n)
33
34 %description
35 Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter.
36
37 %define kernel_pkg()\
38 %package -n kernel%{_alt_kernel}-net-rtl8812au\
39 Summary:        Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter\
40 Release:        %{rel}@%{_kernel_ver_str}\
41 Group:          Base/Kernel\
42 Requires(post,postun):  /sbin/depmod\
43 %requires_releq_kernel\
44 Requires(postun):       %releq_kernel\
45 \
46 %description -n kernel%{_alt_kernel}-net-rtl8812au\
47 Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter\
48 \
49 %files -n kernel%{_alt_kernel}-net-rtl8812au\
50 %defattr(644,root,root,755)\
51 /lib/modules/%{_kernel_ver}/kernel/drivers/net/wireless/*.ko*\
52 \
53 %post   -n kernel%{_alt_kernel}-net-rtl8812au\
54 %depmod %{_kernel_ver}\
55 \
56 %postun -n kernel%{_alt_kernel}-net-rtl8812au\
57 %depmod %{_kernel_ver}\
58 %{nil}
59
60 %define build_kernel_pkg()\
61 %{__make} clean KVER=%{_kernel_ver} KSRC=%{_kernelsrcdir}\
62 %{__make} modules KVER=%{_kernel_ver} KSRC=%{_kernelsrcdir}\
63 %install_kernel_modules -D installed -m 8812au -d kernel/drivers/net/wireless\
64 %{nil}
65
66 %{expand:%create_kernel_packages}
67
68 %prep
69 #%setup -q -n %{pname}-%{version}
70 %setup -q -n rtl8812au_linux-master
71 %patch0 -p1
72 %patch1 -p1
73 %patch2 -p1
74 %patch3 -p1
75 %patch4 -p1
76 %patch5 -p1
77 %patch6 -p1
78 %patch7 -p1
79
80 %build
81 %{expand:%build_kernel_packages}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT
86
87 cp -a installed/* $RPM_BUILD_ROOT
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
This page took 0.068268 seconds and 4 git commands to generate.