]> git.pld-linux.org Git - SPECS.git/blob - rt2x00.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / rt2x00.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel     # allow non-distribution kernel
4 %bcond_with     verbose         # verbose build (V=1)
5 #
6 %ifarch sparc
7 %undefine       with_smp
8 %endif
9 #
10 %define         _snap   2007032610
11 %define         _rel    0.%{_snap}.1
12 Summary:        Linux driver for WLAN cards based on RT2x00 chipsets
13 Summary(pl.UTF-8):      Sterownik dla Linuksa do kart WLAN opartych na układach RT2x00
14 Name:           rt2x00
15 Version:        2.0.0
16 Release:        %{_rel}@%{_kernel_ver_str}
17 License:        GPL v2
18 Group:          Base/Kernel
19 Source0:        http://rt2x00.serialmonkey.com/%{name}-cvs-daily.tar.gz
20 # Source0-md5:  371557c5f055a596109c235f802524d5
21 Patch0:         %{name}-config.patch
22 Patch1:         %{name}-Makefile.patch
23 URL:            http://rt2x00.serialmonkey.com/
24 %{?with_dist_kernel:BuildRequires:      kernel%{_alt_kernel}-module-build >= 3:2.6.17}
25 BuildRequires:  rpmbuild(macros) >= 1.330
26 Requires(post,postun):  /sbin/depmod
27 %if %{with dist_kernel}
28 %requires_releq_kernel
29 Requires(postun):       %releq_kernel
30 %endif
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define modules 80211,crc-itu-t,eeprom_93cx6,rc80211_simple,rfkill,rt2x00lib,rt2400pci,rt2500pci,rt2500usb,rt61pci,rt73usb,rt2x00debug
34
35 %description
36 A configuartion tool for WLAN cards based on RT2x00 chipsets.
37
38 %description -l pl.UTF-8
39 Narzędzie konfiguracujne do kart WLAN opartych na układach RT2x00.
40
41 %package -n kernel%{_alt_kernel}-net-rt2x00
42 Summary:        Linux kernel driver for WLAN cards based on RT2x00 chipsets
43 Summary(pl.UTF-8):      Sterownik jądra Linuksa dla kart WLAN opartych na układach RT2x00
44 Release:        %{_rel}@%{_kernel_ver_str}
45 Group:          Base/Kernel
46 Requires(post,postun):  /sbin/depmod
47 %if %{with dist_kernel}
48 %requires_releq_kernel
49 Requires(postun):       %releq_kernel
50 %endif
51
52 %description -n kernel%{_alt_kernel}-net-rt2x00
53 This is a Linux driver for WLAN cards based on RT2x00 chipsets.
54
55 %description -n kernel%{_alt_kernel}-net-rt2x00 -l pl.UTF-8
56 Sterownik jądra Linuksa dla kart WLAN opartych na układach RT2x00.
57
58 %prep
59 %setup -q -n %{name}-cvs-%{_snap}
60 %patch0 -p1
61 %patch1 -p1
62
63 %build
64 %{__perl} -nle 'next if /DEBUG/; /^(CONFIG_.+)=([yn])\b/ and print $2 eq "y" ? "#ifndef $1\n#define $1\n#endif\n" : "#undef $1\n"' config >rt2x00_config.h
65 %build_kernel_modules -m %{modules}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %install_kernel_modules -m %{modules} -d kernel/drivers/net/wireless
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post -n kernel%{_alt_kernel}-net-rt2x00
76 %depmod %{_kernel_ver}
77
78 %postun -n kernel%{_alt_kernel}-net-rt2x00
79 %depmod %{_kernel_ver}
80
81 %files -n kernel%{_alt_kernel}-net-rt2x00
82 %defattr(644,root,root,755)
83 /lib/modules/%{_kernel_ver}/kernel/drivers/net/wireless/*.ko*
This page took 1.412139 seconds and 3 git commands to generate.