]> git.pld-linux.org Git - SPECS.git/blob - rss-glx.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / rss-glx.spec
1 # TODO:
2 # - --with-kdessconfigdir
3 # - more detailed desc.
4 #
5 # Conditional build:
6 %bcond_without  sound   # without sound
7 #
8 Summary:        The Really Slick Screensavers
9 Summary(pl.UTF-8):      Naprawdę zgrabne wygaszacze ekranu
10 Name:           rss-glx
11 Version:        0.8.1
12 Release:        1
13 Group:          X11/Applications
14 License:        GPL
15 Source0:        http://dl.sourceforge.net/rss-glx/%{name}_%{version}.tar.bz2
16 # Source0-md5:  a2bdf0e10ee4e89c8975f313c5c0ba6f
17 Source1:        %{name}_install
18 URL:            http://rss-glx.sourceforge.net/
19 BuildRequires:  ImageMagick-devel >= 5.5.7
20 %{?with_sound:BuildRequires:    OpenAL-devel}
21 BuildRequires:  OpenGL-devel
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libtool
26 Requires:       OpenGL
27 Requires:       xscreensaver
28 Obsoletes:      rss_glx
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _noautoreqdep   libGL.so.1 libGLU.so.1 libGLcore.so.1
32 %define         _themedir       /usr/share/applications/screensavers
33
34 %description
35 GLX screensavers for the X11 windowing system.
36
37 %description -l pl.UTF-8
38 Wygaszacze ekranu oparte o GLX dla systemu X11.
39
40 %package -n gnome-screensaver-theme-rss-glx
41 Summary:        GNOME Screensaver themes for the Really Slick Screensavers
42 Summary(pl.UTF-8):      Motywy wygaszacza ekranu GNOME dla naprawdę zgrabnych wygaszaczy ekranu
43 Group:          X11/Applications
44 Requires:       %{name} = %{version}-%{release}
45
46 %description -n gnome-screensaver-theme-rss-glx
47 GLX screensaver themes for GNOME Screensaver.
48
49 %description -n gnome-screensaver-theme-rss-glx -l pl.UTF-8
50 Motywy oparte o GLX dla wygaszacza ekranu GNOME.
51
52 %prep
53 %setup -qn %{name}_%{version}
54
55 %build
56 rm -f missing
57 %{__libtoolize}
58 %{__aclocal}
59 %{__autoconf}
60 %{__automake}
61 %configure \
62         --with-configdir=%{_datadir}/xscreensaver \
63         %{!?with_sound: --disable-sound}
64
65 %{__make} \
66         CFLAGS="%{rpmcflags}" \
67         CXXFLAGS="%{rpmcflags}"
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} install DESTDIR=$RPM_BUILD_ROOT
73
74 install -d $RPM_BUILD_ROOT{%{_libdir}/{xscreensaver,gnome-screensaver},%{_themedir}}
75 mv -f $RPM_BUILD_ROOT%{_bindir}/* $RPM_BUILD_ROOT%{_libdir}/xscreensaver
76
77 install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
78
79 generate_fix_desktop_files_links () {
80         local line name trycmd cmd desc
81         while read line;
82         do
83                 eval $(echo "$line" | awk -F§ '{print "name=\"" $1 "\"; cmd=\"" $2 "\"; desc=\"" $3 "\""}')
84                 trycmd="${cmd%%%% *}"
85                 cat << EOF > $RPM_BUILD_ROOT%{_themedir}/rss-glx-${cmd}.desktop
86
87 [Desktop Entry]
88 Encoding=UTF-8
89 Name=${name}
90 Comment=${desc}
91 TryExec=${trycmd}
92 Exec=${cmd} -r
93 StartupNotify=false
94 Terminal=false
95 Type=Application
96 Categories=Screensaver
97 EOF
98                 ln -sf "%{_libdir}/xscreensaver/${trycmd}" "$RPM_BUILD_ROOT%{_libdir}/gnome-screensaver/${trycmd}"
99         done
100 }
101 cat << EOF | generate_fix_desktop_files_links
102 BioF§biof§This is an attempt to recreate some of the work of William Latham.
103 Busy Spheres§busyspheres§Spheres made of dancing particles.
104 Colorfire§colorfire§Burning colors.
105 Cyclone§cyclone§A cyclone made of particles.
106 Euphoria§euphoria§Psychedelic shapes.
107 Fieldlines§fieldlines§A simulation of the electric field lines between charged particles.
108 Flocks§flocks§Flocks of birds.
109 Flux§flux§If you know anything about strange attractors, you might recognize the patterns created by this screensaver.
110 Helios§helios§Throw together some attraction/repulsion particle effects and some smooth implicit surfaces and this is what you get.
111 Hufo's Smoke§hufo_smoke§Smoke effect.
112 Hufo's Tunnel§hufo_tunnel§Inside a tunnel.
113 Hyperspace§hyperspace§Hyperspace.
114 Lattice§lattice§Fly through an endless world of linked rings.
115 MatrixView§matrixview§The Matrix.
116 Plasma§plasma§Probably the second most psychedelic screensaver in existence.
117 Skyrocket (silent)§skyrocket -v 0§The most full-blown fireworks screensaver ever. It has bright lights, smoke trails, clouds that are illuminated by the explosions, sound effects, and plenty of other eye candy. Silent version.
118 Skyrocket§skyrocket§The most full-blown fireworks screensaver ever. It has bright lights, smoke trails, clouds that are illuminated by the explosions, sound effects, and plenty of other eye candy. With sound.
119 Solarwinds§solarwinds§This is a very mesmerizing particle effects saver.
120 SpirographX§spirographx§Spirograph-like screensaver.
121 Sundancer2§sundancer2§Rotating stack of quads.
122 EOF
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post
128 echo
129 echo " To use these savers with xscreensaver, just run"
130 echo " -> /usr/bin/rss_glx_install <-"
131 echo
132
133 %files
134 %defattr(644,root,root,755)
135 %doc README
136 %attr(755,root,root) %{_bindir}/*
137 %attr(755,root,root) %{_libdir}/xscreensaver/*
138 %attr(755,root,root) %{_datadir}/xscreensaver/*.xml
139 %{_mandir}/man1/*
140
141 %files -n gnome-screensaver-theme-rss-glx
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_libdir}/gnome-screensaver/*
144 %{_themedir}/*.desktop
This page took 0.853399 seconds and 3 git commands to generate.