]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- removed second Release :-)
[packages/rpm.git] / rpm.spec
1 Summary:        Red Hat (and now also PLD) Package Manager
2 Summary(de):    Red Hat (und jetzt auch PLD) Packet-Manager
3 Summary(pl):    Aplikacja do zarz±dzania pakietami
4 Name:           rpm
5 Version:        4.0.2
6 Release:        48
7 License:        GPL
8 Group:          Base
9 Group(de):      Gründsätzlich
10 Group(es):      Base
11 Group(pl):      Podstawowe
12 Group(pt_BR):   Base
13 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
14 Source1:        %{name}.groups
15 Source2:        %{name}.macros
16 Source3:        %{name}-install-tree
17 Source4:        %{name}-find-rpm-provides
18 Source5:        %{name}-macros.perl
19 Source6:        %{name}-find-perl-provides
20 Source7:        %{name}-find-perl-requires
21 Source8:        %{name}-find-spec-bcond
22 Source9:        %{name}-find-lang
23 Source10:       %{name}-find-provides
24 Source11:       %{name}-find-requires
25 Source12:       %{name}-non-english-man-pages.tar.bz2
26 Source13:       %{name}-macros.python
27 Patch0:         %{name}-rpmrc.patch
28 Patch1:         %{name}-macros.patch
29 Patch2:         %{name}-arch.patch
30 Patch3:         %{name}-rpmpopt.patch
31 Patch4:         %{name}-perl-macros.patch
32 Patch5:         %{name}-db3.patch
33 Patch6:         %{name}-segv.patch
34 Patch7:         %{name}-am_fix.patch
35 Patch8:         %{name}-perl-req-perlfile.patch
36 Patch9:         %{name}-installplatform.patch
37 Patch10:        %{name}-cache.patch
38 Patch11:        %{name}-suggestions.patch
39 Patch12:        %{name}-rh-lame.patch
40 Patch13:        %{name}-glob.patch
41 Patch14:        %{name}-header_h.patch
42 Patch15:        %{name}-fast-alAddPackage.patch
43 Patch16:        %{name}-byKey.patch
44 Patch17:        %{name}-perlprov.patch
45 Patch18:        %{name}-noperldir.patch
46 Patch19:        popt-cvs20010530.patch
47 Patch20:        %{name}-noexpand.patch
48 Patch21:        %{name}-scripts-closefds.patch
49 Patch22:        %{name}-python-amfix.patch
50 Patch23:        %{name}-non-english-man-pages.patch
51 Patch24:        %{name}-progress-nontty.patch
52 Patch25:        %{name}-am_ac.patch
53 Patch26:        %{name}-python-macros.patch
54 Patch27:        %{name}-hardlink-fixes.patch
55 Patch28:        %{name}-perlprov-regonly.patch
56 Patch29:        %{name}-cxx.patch
57 Patch37:        %{name}-short_circuit.patch
58 Patch38:        %{name}-section_test.patch
59 URL:            http://www.rpm.org/
60 Icon:           rpm.gif
61 BuildRequires:  autoconf >= 2.50
62 BuildRequires:  automake
63 BuildRequires:  db3-devel >= 3.1.17-9
64 BuildRequires:  db1-devel >= 1.85
65 BuildRequires:  db3-devel >= 3.1.17-9
66 BuildRequires:  gettext-devel >= 0.10.38-3
67 BuildRequires:  python-devel
68 BuildRequires:  zlib-devel
69 BuildRequires:  python-modules >= 2.2.1
70 BuildRequires:  zlib-devel >= 1.1.4
71 %if %{!?_without_static:1}%{?_without_static:0}
72 # Require static library only for static build
73 BuildRequires:  db3-static >= 3.1.17-9
74 BuildRequires:  db1-static >= 1.85
75 BuildRequires:  zlib-static
76 BuildRequires:  zlib-static >= 1.1.4
77 Obsoletes:      rpm-libs
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79 Obsoletes:      rpm-libs
80 Conflicts:      glibc < 2.2
81
82 %define         __find_provides %{SOURCE4}
83 %define         _binary_payload w9.gzdio
84
85 %define         py_ver          %(echo `python -c "import sys; print sys.version[:3]"`)
86 %define         py_prefix       %(echo `python -c "import sys; print sys.prefix"`)
87 %define         py_libdir       %{py_prefix}/lib/python%{py_ver}
88 %define         py_dyndir       %{py_libdir}/lib-dynload
89 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
90
91 %description
92 RPM is a powerful package manager, which can be used to build,
93 install, query, verify, update, and uninstall individual software
94 packages. A package consists of an archive of files, and package
95 information, including name, version, and description.
96
97 %description -l de
98 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
99 Installation, Anfrage, Verifizierung, Aktualisierung und
100 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
101 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
102 nombre, versión y descripción.
103
104 %description -l pl
105 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
106 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
107 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
108 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
109 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
110 do pacote, permissões dos arquivos, etc.
111
112 %package devel
113 Summary(de):    Header-Dateien uns Libraries
114 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
115 Group(de):      Entwicklung/Libraries
116 Group(es):      Desarrollo/Bibliotecas
117 Group(fr):      Development/Librairies
118 Group(pl):      Programowanie/Biblioteki
119 Group(pt_BR):   Desenvolvimento/Bibliotecas
120 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
121 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
122 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
123 Group:          Development/Libraries
124 Requires:       %{name} = %{version}
125 Requires:       popt-devel
126
127 %description devel
128 The RPM packaging system includes a C library that makes it easy to
129 manipulate RPM packages and databases. It is intended to ease the
130 creation of graphical package managers and other tools that need
131 intimate knowledge of RPM packages.
132
133 %description devel -l de
134 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
135 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
136 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
137 herramientas que necesiten un conocimiento profundo de paquetes RPM.
138
139 %description devel -l pl
140 System RPM zawiera bibliotekê C, która u³atwia manipulowanie pakietami
141 RPM oraz bazami danych. W zamiarze ma to upro¶ciæ tworzenie
142 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
143 ferramentas que precisem de conhecimento profundo de pacotes RPM.
144
145 %package static
146 Summary:        RPM static libraries
147 Summary(pl):    Biblioteki statyczne RPM-a
148 Group(de):      Entwicklung/Libraries
149 Group(es):      Desarrollo/Bibliotecas
150 Group(fr):      Development/Librairies
151 Group(pl):      Programowanie/Biblioteki
152 Group(pt_BR):   Desenvolvimento/Bibliotecas
153 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
154 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
155 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
156 Group:          Development/Libraries
157 Requires:       %{name}-devel = %{version}
158
159 %description static
160 RPM static libraries.
161
162 %description static -l de
163 RPMs statische Libraries.
164
165 %description static -l pl
166 Bibliotecas estáticas para desenvolvimento.
167
168 %package utils
169 Summary:        Additional utilities for managing rpm packages and database
170 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
171 Group(de):      Applikationen/Datei
172 Group(pl):      Aplikacje/Pliki
173 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
174 Group:          Applications/File
175 Requires:       %{name} = %{version}
176
177 %description utils
178 Additional utilities for managing rpm packages and database.
179
180 %description utils -l de
181 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
182
183 %description utils -l pl
184 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
185
186 %package perlprov
187 Summary:        Additional utilities for checking perl provides/requires in rpm packages
188 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
189 Group(de):      Applikationen/Datei
190 Group(pl):      Aplikacje/Pliki
191 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
192 Group:          Applications/File
193 Requires:       perl-modules
194 Requires:       findutils
195
196 %description perlprov
197 Additional utilities for checking perl provides/requires in rpm
198 packages.
199
200 %description perlprov -l de
201 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
202
203 %description perlprov -l pl
204 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
205 pakietach rpm.
206
207 %package pythonprov
208 Summary:        Python macros, which simplifies creation of rpm packages with Python software
209 Group(de):      Applikationen/Datei
210 Group(pl):      Aplikacje/Pliki
211 Summary(pl):    Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
212 Requires:       python
213 Requires:       %{name} = %{version}
214 Requires:       python-modules
215
216 %description pythonprov
217 Python macros, which simplifies creation of rpm packages with Python
218 software.
219 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi
220 w Pythonie.
221 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
222 %package python
223
224 %package -n python-rpm
225 Group:          Development/Languages/Python
226 Group(de):      Entwicklung/Sprachen/Python
227 Group(pl):      Programowanie/Jêzyki/Python
228 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
229 %pyrequires_eq  python
230 %description python
231
232 %description -n python-rpm
233 The rpm-python package contains a module which permits applications
234 written in the Python programming language to use the interface
235 supplied by RPM (RPM Package Manager) libraries.
236
237 This package should be installed if you want to develop Python
238 %description python -l pl
239 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym
240 w Pythonie na u¿ywanie interfejsu dostarczanego przez biblioteki RPM-a.
241 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym w
242 Pakiet ten powinien zostaæ zainstalowany, je¶li chcesz pisaæ
243 w Pythonie programy manipuluj±ce pakietami i bazami danych rpm.
244 Esse pacote deve ser instalado se você quiser desenvolver programas em
245 Python para manipular pacotes e bancos de dados RPM.
246
247 %package build
248 Summary:        Scripts for building binary RPM packages
249 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
250 Group(de):      Applikationen/Datei
251 Group(pl):      Aplikacje/Pliki
252 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
253 Group:          Applications/File
254 Requires:       /bin/id
255 Requires:       awk
256 Requires:       binutils
257 Requires:       diffutils
258 Requires:       file >= 3.31
259 Requires:       gcc >= 3.0.3
260 Requires:       gcc
261 Requires:       glibc-devel
262 Requires:       grep
263 Requires:       gzip
264 Requires:       make
265 Requires:       patch
266 Requires:       popt >= 1.6.2-2
267 Requires:       sed
268 Requires:       tar
269 Requires:       textutils
270
271 %description build
272 Scripts for building binary RPM packages.
273
274 %description build -l de
275 Scripts fürs Bauen binärer RPM-Pakete.
276
277 %description build -l pl
278 construir pacotes usando o RPM.
279
280 %prep
281 %setup -q -a12
282 %patch0 -p1
283 %patch1 -p1
284 %patch2 -p1
285 %patch3 -p1
286 %patch4 -p1
287 %patch5 -p1
288 %patch6 -p1
289 %patch7 -p1
290 %patch8 -p1
291 %patch11 -p0
292 %patch12 -p0
293 %patch11 -p0
294 %patch12 -p0
295 %patch15 -p0
296 %patch16 -p0
297 %patch15 -p0
298 %patch16 -p0
299 %patch17 -p1
300 %patch18 -p1
301 %patch19 -p1
302 %patch22 -p1
303 %patch23 -p1
304 %patch24 -p1
305 %patch25 -p1
306 %patch26 -p0
307 %patch27 -p1
308 %patch28 -p1
309 %patch29 -p1
310 %patch31 -p1
311 %patch36 -p1
312 %patch37 -p1
313 %patch38 -p1
314
315 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
316 cp -f platform.in macros.pld.in
317 install %{SOURCE9} scripts/find-lang.sh
318 install %{SOURCE13} macros.python.in
319 install %{SOURCE6} scripts/find-perl-provides
320 install %{SOURCE7} scripts/find-perl-requires
321 install %{SOURCE9} scripts/find-lang.sh
322
323 (cd scripts;
324 mv -f perl.req perl.req.in
325 mv -f perl.prov perl.prov.in)
326 %build
327 # generate Group translations to *.po
328 awk -f %{SOURCE14} %{SOURCE1}
329
330 cd popt
331 autoconf
332 automake -a -c
333 aclocal
334 autoheader
335 automake -a -c -f
336 %{__automake}
337 cd ..
338
339 rm -f missing
340 libtoolize --force --copy
341 autoconf
342 # ugly workaround for automake
343 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
344         lib/Makefile.am > lib/Makefile.am.new
345 mv -f lib/Makefile.am.new lib/Makefile.am
346 automake -a -c
347 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
348         lib/Makefile.in > lib/Makefile.in.new
349 mv -f lib/Makefile.in.new lib/Makefile.in
350
351 sed -e 's#python1.5#python%{py_ver}#g' \
352         python/Makefile.in > python/Makefile.in.new
353 mv -f python/Makefile.in.new python/Makefile.in
354
355 sed -e 's#python1.5#python%{py_ver}#g' \
356         python/Makefile.in > python/Makefile.in.new
357 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
358         sed 's|@host_cpu@|%{_target_cpu}|' | \
359 # config.guess doesn't handle athlon, so we have to change it by hand.
360 # rpm checks for CPU type at runtime, but it looks better
361 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
362         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
363         --enable-v1-packages \
364         --with-python
365 %configure \
366         --enable-shared \
367         --enable-v1-packages \
368         --with-python
369
370
371 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
372
373 %install
374 rm -rf $RPM_BUILD_ROOT
375
376 %{__make} install \
377         DESTDIR=$RPM_BUILD_ROOT \
378         pkgbindir="%{_bindir}"
379
380 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
381 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
382
383 install %{SOURCE1} doc/manual/groups
384 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
385 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
386 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
387 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
388 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
389
390 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
391
392 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
393 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
394 # customized rpm macros - global for host
395 #
396 #%%_install_langs pl_PL:en_US
397 %%distribution PLD
398 EOF
399
400 %find_lang %{name}
401
402 # DON'T BREAK BUILD TREE!!!
403 # rm -f doc/manual/Makefile*
404
405 gzip -9nf RPM-PGP-KEY CHANGES doc/manual/*
406
407 %clean
408 rm -rf $RPM_BUILD_ROOT
409
410 %post   -p /sbin/ldconfig
411 %postun -p /sbin/ldconfig
412
413 %attr(755,root,root) %{_libdir}/rpm/rpmdb
414 %attr(755,root,root) %{_libdir}/rpm/rpmq
415 %attr(755,root,root) %{_libdir}/rpm/rpmk
416 %attr(755,root,root) %{_libdir}/rpm/rpmv
417 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
418 %attr(755,root,root) %{_libdir}/rpm/rpmdb
419 %attr(755,root,root) %{_libdir}/rpm/rpmq
420 %attr(755,root,root) %{_libdir}/rpm/rpmk
421 %attr(755,root,root) %{_libdir}/rpm/rpmv
422 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
423
424 %dir %{_sysconfdir}/rpm
425 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
426
427 %{_mandir}/man8/rpm.8*
428 %lang(fr) %{_mandir}/fr/man8/rpm.8*
429 %lang(ja) %{_mandir}/ja/man8/rpm.8*
430 %lang(ko) %{_mandir}/ko/man8/rpm.8*
431 %lang(pl) %{_mandir}/pl/man8/rpm.8*
432 %lang(ru) %{_mandir}/ru/man8/rpm.8*
433 %lang(sk) %{_mandir}/sk/man8/rpm.8*
434
435 %dir /var/lib/rpm
436 %dir %{_libdir}/rpm
437
438 %{_libdir}/rpm/macros.python
439 %{_libdir}/rpm/noarch-linux
440 %{_libdir}/rpm/noarch-pld-linux
441 %ifarch i386 i486 i586 i686
442 %{_libdir}/rpm/rpmpopt*
443 %{_libdir}/rpm/noarch-linux
444 %{_libdir}/rpm/noarch-pld-linux
445 %ifarch i386 i486 i586 i686 athlon
446 %{_libdir}/rpm/i?86*
447 %{_libdir}/rpm/athlon*
448 %endif
449 %ifarch sparc sparc64
450 %{_libdir}/rpm/sparc*
451 %endif
452 %ifarch alpha
453 %{_libdir}/rpm/alpha*
454 %endif
455 %ifarch ppc
456 %{_libdir}/rpm/ppc*
457 %defattr(644,root,root,755)
458 %attr(755,root,root) %{_bindir}/rpmbuild
459 %attr(755,root,root) %{_bindir}/rpme
460 %attr(755,root,root) %{_bindir}/rpmi
461 %attr(755,root,root) %{_bindir}/rpmu
462 %attr(755,root,root) %{_libdir}/rpm/find-requires
463 %attr(755,root,root) %{_libdir}/rpm/find-provides
464 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
465 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
466 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
467 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
468 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
469 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
470 %attr(755,root,root) %{_libdir}/rpm/brp-*
471 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
472 %attr(755,root,root) %{_libdir}/rpm/compress-doc
473 %attr(755,root,root) %{_libdir}/rpm/cpanflute
474 %attr(755,root,root) %{_libdir}/rpm/http.req
475 %attr(755,root,root) %{_libdir}/rpm/magic.*
476 %attr(755,root,root) %{_libdir}/rpm/rpmi
477 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
478 %attr(755,root,root) %{_libdir}/rpm/rpme
479 %attr(755,root,root) %{_libdir}/rpm/rpmu
480 %attr(755,root,root) %{_libdir}/rpm/rpmb
481 %attr(755,root,root) %{_libdir}/rpm/rpmi
482 %attr(755,root,root) %{_libdir}/rpm/rpmt
483 %attr(755,root,root) %{_libdir}/rpm/rpme
484 %attr(755,root,root) %{_libdir}/librpm*.la
485 %attr(755,root,root) %{_libdir}/librpm*.so
486 %files devel
487 %defattr(644,root,root,755)
488 %{_includedir}/rpm
489 %attr(755,root,root) %{_libdir}/librpm*.la
490 %attr(755,root,root) %{_libdir}/librpm*.so
491
492 %files static
493 %attr(755,root,root) %{_bindir}/*
494 %files utils
495 %defattr(644,root,root,755)
496 %{_mandir}/man1/*
497 %attr(755,root,root) %{_bindir}/javadeps
498 %attr(755,root,root) %{_bindir}/rpm2cpio
499
500 %{_mandir}/man8/rpm2cpio.8*
501 %{_mandir}/man1/*
502 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
503 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
504 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
505 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
506
507 %files perlprov
508 %defattr(644,root,root,755)
509 %attr(755,root,root) %{_libdir}/rpm/perl*
510 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
511 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
512 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
513 %attr(755,root,root) %{_libdir}/rpm/find-req.pl
514 %attr(755,root,root) %{_libdir}/rpm/get_magic.pl
515
516 %{_libdir}/rpm/macros.perl
517 %files python
518 %defattr(644,root,root,755)
519 %{py_sitedir}/*.so
520 %{_libdir}/rpm/macros.python
521
522 %files -n python-rpm
523 %defattr(755,root,root,755)
524 %{py_sitedir}/*.so
This page took 0.076493 seconds and 4 git commands to generate.