]> git.pld-linux.org Git - SPECS.git/blob - robin-map.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / robin-map.spec
1 Summary:        A C++ implementation of a fast hash map and hash set using robin hood hashing
2 Summary(pl.UTF-8):      Implementacja C++ szybkiej tablicy asocjacyjnej i zbioru wykorzytujących haszowanie robin hood
3 Name:           robin-map
4 Version:        1.3.0
5 Release:        1
6 License:        MIT
7 Group:          Libraries
8 #Source0Download: https://github.com/Tessil/robin-map/releases
9 Source0:        https://github.com/Tessil/robin-map/archive/v%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  2e451e84be031b99f10faec9a7d70246
11 URL:            https://github.com/Tessil/robin-map
12 BuildRequires:  cmake >= 3.3
13 BuildArch:      noarch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 The robin-map library is a C++ implementation of a fast hash map and
18 hash set using open-addressing and linear robin hood hashing with
19 backward shift deletion to resolve collisions.
20
21 %description -l pl.UTF-8
22 Biblioteka robin-map to implementacja C++ szybkiej tablicy
23 asocjacyjnej (mapy) i zbioru wykorzystujących adresowanie otwarte i
24 haszowanie robin hood z usuwaniem przez przesunięcie wstecz przy
25 rozwiązywaniu kolizji.
26
27 %package devel
28 Summary:        Header files for robin-map library
29 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki robin-map
30 Group:          Development/Libraries
31 Requires:       libstdc++-devel >= 6:4.8
32
33 %description devel
34 Header files for robin-map library.
35
36 The robin-map library is a C++ implementation of a fast hash map and
37 hash set using open-addressing and linear robin hood hashing with
38 backward shift deletion to resolve collisions.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe biblioteki robin-map.
42
43 Biblioteka robin-map to implementacja C++ szybkiej tablicy
44 asocjacyjnej (mapy) i zbioru wykorzystujących adresowanie otwarte i
45 haszowanie robin hood z usuwaniem przez przesunięcie wstecz przy
46 rozwiązywaniu kolizji.
47
48 %prep
49 %setup -q
50
51 %build
52 mkdir -p build
53 cd build
54 %cmake ..
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} -C build install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files devel
67 %defattr(644,root,root,755)
68 %doc LICENSE README.md
69 %dir %{_includedir}/tsl
70 %{_includedir}/tsl/robin*.h
71 %{_datadir}/cmake/tsl-robin-map
This page took 0.251933 seconds and 3 git commands to generate.