]> git.pld-linux.org Git - packages/rhythmbox.git/blob - rhythmbox.spec
- merged 0.7.2 from DEVEL
[packages/rhythmbox.git] / rhythmbox.spec
1
2 %bcond_with xine                # build with xine-lib instead of gstreamer
3
4 %define         min_ver 0.8.0
5
6 Summary:        Music Management Application
7 Summary(pl):    Aplikacja do zarz±dzania muzyk±
8 Name:           rhythmbox
9 Version:        0.7.2
10 Release:        1
11 License:        GPL
12 Group:          Applications
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/0.7/%{name}-%{version}.tar.bz2
14 # Source0-md5:  23b20924515386a60a0eb6beff13318a
15 Patch0:         %{name}-locale-names.patch
16 Patch1:         %{name}-vorbis.patch
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 %if %{without xine}
20 BuildRequires:  gstreamer-GConf-devel >= %{min_ver}
21 BuildRequires:  gstreamer-devel >= %{min_ver}
22 BuildRequires:  gstreamer-plugins-devel >= %{min_ver}
23 %else
24 BuildRequires:  flac-devel
25 BuildRequires:  libid3tag-devel >= 0.15.0b
26 BuildRequires:  libmad-devel
27 BuildRequires:  libogg-devel
28 BuildRequires:  libvorbis-devel
29 BuildRequires:  xine-lib-devel >= 1.0.0
30 %endif
31 BuildRequires:  gnome-vfs2-devel >= 2.4.0
32 BuildRequires:  gtk+2-devel >= 2:2.4.0
33 BuildRequires:  libbonobo-devel >= 2.4.0
34 BuildRequires:  libglade2-devel >= 2.0.1
35 BuildRequires:  libgnomeui-devel >= 2.4.0
36 BuildRequires:  libmusicbrainz-devel >= 2.0.1
37 BuildRequires:  libtool
38 BuildRequires:  pkgconfig
39 BuildRequires:  zlib-devel
40 Requires(post,postun):  /sbin/ldconfig
41 Requires(post,postun):  /usr/bin/scrollkeeper-update
42 Requires(post): GConf2
43 %if %{without xine}
44 Requires:       gstreamer-audio-effects >= %{min_ver}
45 Requires:       gstreamer-audio-formats >= %{min_ver}
46 Requires:       gstreamer-audiosink
47 Requires:       gstreamer-gnomevfs >= %{min_ver}
48 %endif
49 Requires:       gtk+2 >= 2:2.4.0
50 Obsoletes:      net-rhythmbox
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 Rhythmbox is your one-stop multimedia application, supporting a music
55 library, multiple "music groups", internet radio, and more.
56
57 %description -l pl
58 Rhythmbox to kompletna aplikacja multimedialna, obs³uguj±ca bibliotekê
59 muzyczn±, wiele "grup muzyki", radio internetowe itp.
60
61 %prep
62 %setup -q
63 %patch0 -p1
64 %patch1 -p1
65
66 mv po/{no,nb}.po
67
68 %build
69 %{__libtoolize}
70 %{__aclocal}
71 %{__autoconf}
72 %{__automake}
73 %configure \
74         --disable-schemas-install \
75         %{?_with_xine:--with-player=xine}
76         
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT \
84         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
85
86 %find_lang %{name} --with-gnome --all-name
87
88 rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/lib*.{la,a}
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post
94 /sbin/ldconfig
95 %gconf_schema_install
96 /usr/bin/scrollkeeper-update
97 %if %{without xine}
98 echo "Remember to install appropriate gstreamer plugins for files"
99 echo "you want to play:"
100 echo "- gstreamer-mad (for mp3s)"
101 echo "- gstreamer-vorbis (for Ogg Vorbis)"
102 echo "- gstreamer-flac (for FLAC)"
103 %endif
104
105 %postun 
106 /sbin/ldconfig
107 /usr/bin/scrollkeeper-update
108
109 %files -f rhythmbox.lang
110 %defattr(644,root,root,755)
111 %doc AUTHORS ChangeLog README NEWS
112 %attr(755,root,root) %{_bindir}/*
113 %{_datadir}/application-registry/*
114 %{_datadir}/gnome-2.0/ui/*.xml
115 %{_datadir}/idl/*
116 %{_datadir}/mime-info/*.keys
117 %{_datadir}/%{name}
118 %{_desktopdir}/*
119 %{_libdir}/bonobo/servers/*
120 %{_libdir}/bonobo/*.so
121 %{_omf_dest_dir}/%{name}
122 %{_pixmapsdir}/*
123 %{_pkgconfigdir}/*
124 %{_sysconfdir}/gconf/schemas/*
This page took 0.048001 seconds and 4 git commands to generate.