]> git.pld-linux.org Git - packages/rhythmbox.git/blob - rhythmbox.spec
- BR: check, rel.3
[packages/rhythmbox.git] / rhythmbox.spec
1 #
2 # Conditional build:
3 %bcond_without  ipod    # build without iPod support
4 #
5 Summary:        Music Management Application
6 Summary(pl):    Aplikacja do zarz±dzania muzyk±
7 Name:           rhythmbox
8 Version:        0.9.5
9 Release:        3
10 License:        GPL v2+
11 Group:          Applications
12 Source0:        http://ftp.gnome.org/pub/gnome/sources/rhythmbox/0.9/%{name}-%{version}.tar.bz2
13 # Source0-md5:  ff55e1db114321b7bdd6e21df1879367
14 Patch0:         %{name}-desktop.patch
15 Patch1:         %{name}-broken_locale.patch
16 Patch2:         %{name}-gtk2.8-crash.patch
17 Patch3:         %{name}-pyc.patch
18 Patch4:         %{name}-use-icon-name.patch
19 URL:            http://www.rhythmbox.org/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  avahi-glib-devel >= 0.6.11
23 BuildRequires:  check >= 0.9.3
24 BuildRequires:  dbus-glib-devel >= 0.62
25 BuildRequires:  gnome-vfs2-devel >= 2.15.3
26 BuildRequires:  gstreamer-devel >= 0.10.8
27 BuildRequires:  gstreamer-GConf >= 0.10
28 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.7
29 BuildRequires:  gtk+2-devel >= 2:2.10.0
30 BuildRequires:  hal-devel >= 0.5.7
31 BuildRequires:  intltool
32 BuildRequires:  libglade2-devel >= 1:2.6.0
33 BuildRequires:  libgnomeui-devel >= 2.15.2
34 %{?with_ipod:BuildRequires:     libgpod-devel >= 0.3.3}
35 BuildRequires:  libmusicbrainz-devel >= 2.0.1
36 BuildRequires:  libnotify-devel >= 0.4.2
37 BuildRequires:  libsexy-devel >= 0.1.8
38 BuildRequires:  libsoup-devel >= 2.2.95.1
39 BuildRequires:  libtool
40 BuildRequires:  nautilus-cd-burner-devel >= 2.15.4
41 BuildRequires:  pkgconfig
42 BuildRequires:  python-pygtk-devel >= 2.9.3
43 BuildRequires:  rpmbuild(macros) >= 1.176
44 BuildRequires:  scrollkeeper
45 BuildRequires:  totem-devel >= 1.5.4
46 BuildRequires:  zlib-devel
47 %pyrequires_eq  python-modules
48 Requires(post,preun):   GConf2 >= 2.14.0
49 Requires(post,postun):  desktop-file-utils
50 Requires(post,postun):  scrollkeeper
51 Requires:       dbus >= 0.62
52 Requires:       gstreamer-audio-effects-base >= 0.10.7
53 Requires:       gstreamer-audio-formats >= 0.10.3
54 Requires:       gstreamer-audiosink
55 Requires:       gstreamer-gnomevfs >= 0.10.7
56 Requires:       gstreamer-plugins-good >= 0.10.3
57 Requires:       gtk+2 >= 2:2.10.0
58 Requires:       libgnomeui >= 2.15.2
59 Obsoletes:      net-rhythmbox
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %description
63 Rhythmbox is your one-stop multimedia application, supporting a music
64 library, multiple "music groups", internet radio, and more.
65
66 %description -l pl
67 Rhythmbox to kompletna aplikacja multimedialna, obs³uguj±ca bibliotekê
68 muzyczn±, wiele "grup muzyki", radio internetowe itp.
69
70 %prep
71 %setup -q
72 %patch0 -p1
73 %patch1 -p1
74 %patch2 -p1
75 %patch3 -p1
76 %patch4 -p1
77
78 # broken
79 rm po/{ar,mn}.po
80
81 %build
82 # for snapshots
83 gnome-doc-prepare --copy
84 %{__gtkdocize}
85 %{__gnome_doc_common}
86 %{__glib_gettextize}
87 %{__intltoolize}
88 %{__libtoolize}
89 %{__aclocal} -I macros
90 %{__autoheader}
91 %{__automake}
92 %{__autoconf}
93 LDFLAGS="%{rpmldflags} -Wl,--as-needed"
94 %configure \
95         --disable-schemas-install \
96         --disable-scrollkeeper \
97         --with-bonobo \
98         --with-cd-burner \
99         --with-dbus \
100         %{!?with_ipod:--without-ipod} \
101         --with-mds=avahi \
102         --with-internal-libsexy=no
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT \
110         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
111
112 #rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
113
114 # there is no -devel subpackage, so we don't need APIdocs
115 rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc
116
117 %find_lang %{name} --with-gnome --all-name
118
119 rm -f  $RPM_BUILD_ROOT%{_libdir}/bonobo/lib*.{la,a}
120 rm -f  $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la,py}
121 rm -f  $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/artdisplay/*.py
122 rm -rf $RPM_BUILD_ROOT%{_datadir}/application-registry
123 rm -rf $RPM_BUILD_ROOT%{_datadir}/mime-info
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post
129 %gconf_schema_install rhythmbox.schemas
130 %scrollkeeper_update_post
131 %update_desktop_database_post
132 gtk-update-icon-cache -qf %{_datadir}/icons/hicolor
133 %banner %{name} -e << EOF
134 Remember to install appropriate GStreamer plugins for files
135 you want to play:
136 - gstreamer-flac (for FLAC)
137 - gstreamer-mad (for MP3s)
138 - gstreamer-vorbis (for Ogg Vorbis)
139 - gstreamer-neon (for HTTP streams)
140 EOF
141
142 %preun
143 %gconf_schema_uninstall rhythmbox.schemas
144
145 %postun 
146 %scrollkeeper_update_postun
147 %update_desktop_database_postun
148 gtk-update-icon-cache -qf %{_datadir}/icons/hicolor
149
150 %files -f rhythmbox.lang
151 %defattr(644,root,root,755)
152 %doc AUTHORS ChangeLog README NEWS
153 %attr(755,root,root) %{_bindir}/*
154 %attr(755,root,root) %{_libdir}/rhythmbox-metadata
155
156 %dir %{_libdir}/rhythmbox
157 %dir %{_libdir}/rhythmbox/plugins
158 %dir %{_libdir}/rhythmbox/plugins/artdisplay
159 %attr(755,root,root) %{_libdir}/rhythmbox/plugins/*.so
160 %{_libdir}/rhythmbox/plugins/artdisplay/*.py[co]
161 %{_libdir}/rhythmbox/plugins/*-plugin
162 %{_libdir}/rhythmbox/plugins/*.py[co]
163
164 %{_datadir}/%{name}
165 %{_datadir}/dbus-1/services/*.service
166 %{_desktopdir}/*
167 %{_iconsdir}/hicolor/*/*/rhythmbox.png
168 %{_omf_dest_dir}/%{name}
169 %{_sysconfdir}/gconf/schemas/rhythmbox.schemas
This page took 0.049243 seconds and 4 git commands to generate.