]> git.pld-linux.org Git - packages/rhythmbox.git/blob - rhythmbox.spec
- rebuild with howl 0.9.10, release 2
[packages/rhythmbox.git] / rhythmbox.spec
1 #
2 # Conditional build:
3 %bcond_with     xine    # build with xine-lib instead of gstreamer
4 #
5 %define         min_ver 0.8.1
6
7 Summary:        Music Management Application
8 Summary(pl):    Aplikacja do zarz±dzania muzyk±
9 Name:           rhythmbox
10 Version:        0.8.8
11 Release:        2
12 License:        GPL
13 Group:          Applications
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/0.8/%{name}-%{version}.tar.bz2
15 # Source0-md5:  46cd84b3b67f85009aa48e0e301124fe
16 Patch0:         %{name}-vorbis.patch
17 Patch1:         %{name}-desktop.patch
18 URL:            http://www.rhythmbox.org/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 %if %{without xine}
22 BuildRequires:  gstreamer-GConf-devel >= %{min_ver}
23 BuildRequires:  gstreamer-devel >= %{min_ver}
24 BuildRequires:  gstreamer-plugins-devel >= %{min_ver}
25 %else
26 BuildRequires:  flac-devel
27 BuildRequires:  libid3tag-devel >= 0.15.0b
28 BuildRequires:  libmad-devel
29 BuildRequires:  libogg-devel
30 BuildRequires:  libvorbis-devel
31 BuildRequires:  xine-lib-devel >= 1.0.0
32 %endif
33 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
34 BuildRequires:  gtk+2-devel >= 2:2.4.0
35 BuildRequires:  libbonobo-devel >= 2.4.0
36 BuildRequires:  libglade2-devel >= 2.0.1
37 BuildRequires:  libgnomeui-devel >= 2.10.0-2
38 BuildRequires:  libmusicbrainz-devel >= 2.0.1
39 BuildRequires:  libtool
40 BuildRequires:  pkgconfig
41 BuildRequires:  zlib-devel
42 Requires(post,postun):  /sbin/ldconfig
43 Requires(post,postun):  /usr/bin/scrollkeeper-update
44 Requires(post): GConf2
45 %if %{without xine}
46 Requires:       gstreamer-audio-effects >= %{min_ver}
47 Requires:       gstreamer-audio-formats >= %{min_ver}
48 Requires:       gstreamer-audiosink
49 Requires:       gstreamer-gnomevfs >= %{min_ver}
50 %else
51 Requires:       xine-plugin-audio
52 %endif
53 Requires:       gtk+2 >= 2:2.4.0
54 Obsoletes:      net-rhythmbox
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 Rhythmbox is your one-stop multimedia application, supporting a music
59 library, multiple "music groups", internet radio, and more.
60
61 %description -l pl
62 Rhythmbox to kompletna aplikacja multimedialna, obs³uguj±ca bibliotekê
63 muzyczn±, wiele "grup muzyki", radio internetowe itp.
64
65 %prep
66 %setup -q
67 %patch0 -p1
68 %patch1 -p1
69
70 %build
71 %{__libtoolize}
72 %{__aclocal}
73 %{__autoconf}
74 %{__automake}
75 %configure \
76         --disable-schemas-install \
77         --enable-ipod \
78         --enable-nautilus-menu \
79         %{?_with_xine:--with-player=xine}
80         
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT \
88         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
89
90 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
91
92 %find_lang %{name} --with-gnome --all-name
93
94 rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/lib*.{la,a}
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post
100 /sbin/ldconfig
101 %gconf_schema_install
102 /usr/bin/scrollkeeper-update
103 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
104 %if %{without xine}
105 echo
106 echo "Remember to install appropriate gstreamer plugins for files"
107 echo "you want to play:"
108 echo "- gstreamer-flac (for FLAC)"
109 echo "- gstreamer-mad (for MP3s)"
110 echo "- gstreamer-vorbis (for Ogg Vorbis)"
111 echo
112 %else
113 echo
114 echo "Remember to install appropriate xine-decode plugins for files"
115 echo "you want to play:"
116 echo "- xine-decode-flac (for FLAC)"
117 echo "- xine-decode-ogg (for Ogg Vorbis)"
118 echo
119 %endif
120
121 %postun 
122 /sbin/ldconfig
123 /usr/bin/scrollkeeper-update
124 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
125
126 %files -f rhythmbox.lang
127 %defattr(644,root,root,755)
128 %doc AUTHORS ChangeLog README NEWS
129 %attr(755,root,root) %{_bindir}/*
130 %{_datadir}/application-registry/*
131 %{_datadir}/gnome-2.0/ui/*.xml
132 %{_datadir}/idl/*
133 %{_datadir}/mime-info/*.keys
134 %{_datadir}/%{name}
135 %{_desktopdir}/*
136 %{_libdir}/bonobo/servers/*
137 %attr(755,root,root) %{_libdir}/bonobo/*.so
138 %{_omf_dest_dir}/%{name}
139 %{_pixmapsdir}/*
140 %{_pkgconfigdir}/*
141 %{_sysconfdir}/gconf/schemas/*
This page took 0.055943 seconds and 4 git commands to generate.