]> git.pld-linux.org Git - SPECS.git/blob - recode.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / recode.spec
1 # TODO: package python extension
2 #
3 # Conditional build:
4 %bcond_without  tests   # unit tests
5 #
6 Summary:        Utility for converting text between multiple character sets
7 Summary(pl.UTF-8):      Uniwersalny konwerter między zestawami znaków
8 Name:           recode
9 Version:        3.7.14
10 Release:        1
11 License:        LGPL v2+ (library), GPL v2+ (utility)
12 Group:          Applications/Text
13 Source0:        https://github.com/rrthomas/recode/releases/download/v%{version}/recode-%{version}.tar.gz
14 # Source0-md5:  d88b41fd27549123a0822e5a3fae98a8
15 Patch0:         %{name}-info.patch
16 Patch1:         %{name}-pl.po-update.patch
17 URL:            https://github.com/rrthomas/recode
18 BuildRequires:  autoconf >= 2.71
19 BuildRequires:  automake
20 BuildRequires:  flex
21 BuildRequires:  gettext-tools >= 0.19
22 BuildRequires:  help2man
23 BuildRequires:  libtool >= 2:2
24 BuildRequires:  texinfo
25 BuildRequires:  python3 >= 1:3.5
26 BuildRequires:  python3-Cython
27 BuildRequires:  python3-modules >= 1:3.5
28 Requires(post,postun):  /sbin/ldconfig
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Free `recode' converts files between various character sets and
33 surfaces. It supports more than 200 different character sets and
34 surfaces, including well known ISO-8859, CP-XXXX and Unicode.
35
36 %description -l pl.UTF-8
37 Program `recode' konwertuje pliki pomiędzy różnymi zestawami znaków i
38 kodowaniami. Obsługuje ponad 200 różnych zestawów znaków oraz sposobów
39 kodowania, włącznie z popularnymi ISO-8859, CP-XXXX oraz Unicode.
40
41 %package devel
42 Summary:        Header files and documentations for librecode
43 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do librecode
44 License:        LGPL v2+
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47
48 %description devel
49 Header files and documentations for librecode.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe i dokumentacja do librecode.
53
54 %package static
55 Summary:        Static librecode library
56 Summary(pl.UTF-8):      Biblioteka statyczna librecode
57 License:        LGPL v2+
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 Static librecode library.
63
64 %description static -l pl.UTF-8
65 Biblioteka statyczna librecode.
66
67 %prep
68 %setup -q
69 %patch0 -p1
70 %patch1 -p1
71
72 %{__sed} -i '1 i @documentencoding ISO-8859-1' doc/recode.texi
73
74 %{__rm} po/stamp-po
75
76 %build
77 %{__libtoolize}
78 %{__aclocal} -I m4
79 %{__autoconf}
80 %{__automake}
81 %configure
82 %{__make}
83
84 %if %{with tests}
85 %{__make} check
86 %endif
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 %find_lang %{name}
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post
100 /sbin/ldconfig
101 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
102
103 %postun
104 /sbin/ldconfig
105 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
106
107 %files -f %{name}.lang
108 %defattr(644,root,root,755)
109 %doc AUTHORS NEWS README THANKS TODO
110 %attr(755,root,root) %{_bindir}/recode
111 %attr(755,root,root) %{_libdir}/librecode.so.*.*.*
112 %attr(755,root,root) %ghost %{_libdir}/librecode.so.3
113 %{_infodir}/recode.info*
114 %{_mandir}/man1/recode.1*
115
116 %files devel
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_libdir}/librecode.so
119 %{_libdir}/librecode.la
120 %{_includedir}/recode.h
121 %{_includedir}/recodext.h
122
123 %files static
124 %defattr(644,root,root,755)
125 %{_libdir}/librecode.a
This page took 0.316508 seconds and 3 git commands to generate.