]> git.pld-linux.org Git - projects/rc-scripts.git/blob - rc-scripts.spec
synced with 0.0.5
[projects/rc-scripts.git] / rc-scripts.spec
1 Summary:        inittab and /etc/rc.d scripts
2 Summary(de):    inittab und /etc/rc.d Scripts
3 Summary(fr):    inittab et scripts /etc/rc.d
4 Summary(pl):    inittab i skrypty startowe z katalogu /etc/rc.d
5 Summary(tr):    inittab ve /etc/rc.d dosyalarý
6 Name:           rc-scripts
7 Version:        0.0.4
8 Copyright:      GPL
9 Group:          Base
10 Group(pl):      Bazowe  
11 Release:        1
12 Source:         %{name}-%{version}.tar.gz
13 Buildroot:      /tmp/buildroot-%{name}-%{version}
14 Requires:       mingetty
15 Requires:       mktemp
16 Requires:       modutils >= 2.1.121
17 Prereq:         /sbin/chkconfig
18 Obsoletes:      initscripts
19
20 %description
21 This package contains the scripts use to boot a system, change run
22 levels, and shut the system down cleanly.
23
24 %description -l de
25 Dieses Paket enthält die Scripts, die zum Hochfahren des Systems, Ändern
26 der Betriebsebene und sauberem Herunterfahren des Systems erforderlich sind.
27 Außerdem enthält es die Scripts, die Netzwerkschnittstellen aktivieren und
28 deaktivieren.
29
30 %description -l fr
31 Ce package contient les scripts utilisés pour démarrer le systéme,
32 changer les niveaux d'exécution, et arréter le systéme proprement.
33 Il contient aussi les scripts qui activent et désactivent la plupart
34 des inetrfaces réseau.
35
36 %description -l pl
37 Pakiet zawiera skrypty uruchamiane przy starcie i zamykaniu systemu, a
38 tak¿e przy zmianie poziomu uruchomienia. 
39
40 %description -l tr
41 Bu paket, sistem açmak, çalýþma düzeylerini deðiþtirmek ve sistemi düzgün bir
42 þekilde kapatmak için gereken dosyalarý içerir. Ayrýca pek çok bilgisayar aðý
43 arayüzlerini etkinleþtiren ya da edilginleþtiren programcýklar içerir.
44
45 %package -n net-scripts
46 Summary:        network startup scripts
47 Summary(pl):    skrypty startowe sieci
48 Group:          Base
49 Group(pl):      Bazowe  
50 Requires:       rc-scripts = %{version}
51 Requires:       modutils >= 2.1.121
52 Provides:       initscripts
53 Prereq:         /sbin/chkconfig
54
55 %description -n net-scripts
56 Scripts that activate and deactivate most network interfaces.
57
58 %description -l pl -n net-scripts
59 Skrypty s³u¿±ce do aktywacji i deaktywacji interfejsów sieciowych
60
61 %package -n ipchains-setup
62 Summary:        firewall chains setup script
63 Summary(pl):    skrypty konfiguruj±cy regu³y filtrowania pakietów IP
64 Group:          Base
65 Group(pl):      Bazowe  
66 Requires:       rc-scripts = %{version}
67 Requires:       ipchains
68 Prereq:         /sbin/chkconfig
69
70 %description -n ipchains-setup
71 Script making IP firewall rules setup easier 
72
73 %description -l pl -n ipchains-setup
74 Skrypt u³atwiaj±cy konfigurowanie regu³ filtracji pakietów IP
75
76 %prep
77 %setup -q
78
79 %build
80 CFLAGS="$RPM_OPT_FLAGS -w" make
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
85
86 make ROOT=$RPM_BUILD_ROOT install 
87
88 gzip -9nf $RPM_BUILD_ROOT/usr/man/man*/* \
89         sysconfig.txt net-scripts.txt
90
91 %post
92 for i in  halt nfsfs random reboot single  
93         do /sbin/chkconfig --add $i
94 done 
95 if [ -f /etc/inittab.rpmsave ]; then
96         echo "**** Found old /etc/inittab.rpmsave ****"
97         echo "/etc/inittab renamed to /etc/inittab.rpmnew"
98         mv /etc/inittab /etc/inittab.rpmnew
99         echo "/etc/inittab.rpmsave renamed to /etc/inittab."
100         mv /etc/inittab.rpmsave /etc/inittab
101 fi
102
103 %preun
104 if [ "$1" = "0" ]; then
105         /sbin/chkconfig --del random
106         /sbin/chkconfig --del nfsfs
107 fi
108
109 %post -n net-scripts
110 /sbin/chkconfig --add network
111 for l in /etc/sysconfig/network-scripts/ifcfg-* ; do 
112   if [ -f "$l" ] ; then
113     NEWNAME=`basename $l | sed -e 's /^ifcfg-//'`
114     [ -f /etc/sysconfig/interfaces/$NEWNAME ] || cp $l /etc/sysconfig/interfaces/$NEWNAME
115   fi
116 done
117
118 %preun -n net-scripts
119 if [ "$1" = "0" ]; then
120         /sbin/chkconfig --del network
121 fi
122
123 %post -n ipchains-setup
124 /sbin/chkconfig --add ipchains
125
126 %preun -n ipchains-setup
127 if [ "$1" = "0" ]; then
128         /sbin/chkconfig --del ipchains
129 fi
130
131 %files
132 %defattr(644,root,root,754)
133 %doc sysconfig.txt.gz
134
135 %config(noreplace) %verify(not md5 mtime size) /etc/adjtime
136 %config(noreplace) %verify(not md5 mtime size) /etc/inittab
137
138 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/system
139
140 %attr(644,root,root) /etc/rc.d/init.d/functions
141 %attr(754,root,root) /etc/rc.d/init.d/halt
142 %attr(754,root,root) /etc/rc.d/init.d/killall
143 %attr(754,root,root) /etc/rc.d/init.d/nfsfs
144 %attr(754,root,root) /etc/rc.d/init.d/random
145 %attr(754,root,root) /etc/rc.d/init.d/reboot
146 %attr(754,root,root) /etc/rc.d/init.d/shutdwn
147 %attr(754,root,root) /etc/rc.d/init.d/single
148
149 %attr(754,root,root) /etc/rc.d/rc.sysinit
150 %attr(754,root,root) /etc/rc.d/rc.serial
151 %attr(754,root,root) /etc/rc.d/rc
152 %attr(754,root,root) /etc/rc.d/rc.local
153 %attr(755,root,root) /etc/profile.d/lang.sh
154 %attr(755,root,root) /bin/doexec
155 %attr(755,root,root) /bin/usleep
156 %attr(755,root,root) /sbin/setsysfont
157
158 /usr/man/man1/usleep.1.gz
159 /usr/man/man1/doexec.1.gz
160
161 %files -n net-scripts
162 %defattr(644,root,root,754)
163 %doc /etc/sysconfig/interfaces/*-template!
164 %doc /etc/sysconfig/interfaces/data/chat-ppp*
165 %doc net-scripts.txt.gz
166 %attr(754,root,root) /etc/rc.d/init.d/network
167 %attr(750,root,root) %dir /var/run/netreport
168 %attr(755,root,root) %dir /etc/sysconfig/interfaces
169 %attr(755,root,root) %dir /etc/sysconfig/interfaces/data
170 %attr(755,root,root,755) /etc/ppp
171
172 %attr(755,root,root) %dir /sbin/network-scripts
173 %attr(755,root,root) /sbin/network-scripts/if*
174 %attr(644,root,root) /sbin/network-scripts/network-functions
175 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/interfaces/lo
176
177 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/network
178 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/static-routes
179
180 %attr(755,root,root) /usr/sbin/usernetctl
181 %attr(755,root,root) /bin/ipcalc
182 %attr(755,root,root) /sbin/netreport
183 %attr(755,root,root) /sbin/ifup
184 %attr(755,root,root) /sbin/ifdown
185
186 /usr/man/man1/netreport.1.gz
187 /usr/man/man1/usernetctl.1.gz
188 /usr/man/man1/ipcalc.1.gz
189
190 %files -n ipchains-setup
191 %defattr(644,root,root,754)
192 %doc ipchains-setup.txt.gz
193 %attr(754,root,root) /etc/rc.d/init.d/ipchains
194 %attr(755,root,root) %dir /etc/sysconfig/ipchains.d/
195 %attr(755,root,root) %dir /etc/sysconfig/interfaces/data
196 %attr(755,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/ipchains.d/*
197 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/ipchains
198
199 %changelog
200 * Wed Apr 28 1999 Jacek Konieczny <jajcus@zeus.polsl.gliwice.pl>
201   [0.0.4-1]
202 - added ipchains-setup  
203
204 * Thu Apr 22 1999 Jacek Konieczny <jajcus@zeus.polsl.gliwice.pl>
205   [0.0.3-1]
206 - split into two packages: rc-scripts & net-scripts  
207 - directory structure changed - only config in /etc
208
209 * Tue Mar 23 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
210   [0.0.2-1]
211 - be more verbose while upgrading when /etc/inittab.rpmsave is found,
212 - added seting NETWORK="no" variable to when /etc/sysconfig/network is not present
213   or when NETWORK in this file is not defined.
214
215 * Sun Mar 21 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
216   [0.0.1-1]
217 - added /etc/sysconfig/system,
218 - removed man group from man pages,
219 - added in %post not replacing /etc/inittab on upgrade from initscripts,
220 - removed %config from scripts.
221
222 * Fri Mar 19 1999 PLD Team <bugs@pld.org.pl>
223 - Full changelog in PLD's CVS.
224 - First Release.
225 - Package based on RedHat's initscripts-3.78.
This page took 0.065972 seconds and 3 git commands to generate.