]> git.pld-linux.org Git - packages/rabbitmq-c.git/blob - rabbitmq-c.spec
- updated to 0.6.0 (note: new soname)
[packages/rabbitmq-c.git] / rabbitmq-c.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        RabbitMQ C AMQP client library
6 Summary(pl.UTF-8):      Biblioteka kliencka C RabbitMQ AMQP
7 Name:           rabbitmq-c
8 Version:        0.6.0
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 #Source0Download: https://github.com/alanxz/rabbitmq-c
13 Source0:        https://github.com/alanxz/rabbitmq-c/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  2940281e7386f579ef2ecb47e5ed7508
15 URL:            https://github.com/alanxz/rabbitmq-c
16 BuildRequires:  autoconf >= 2.59
17 BuildRequires:  automake >= 1:1.9
18 BuildRequires:  libtool >= 2:2.2
19 BuildRequires:  openssl-devel >= 0.9.8
20 BuildRequires:  popt-devel
21 BuildRequires:  pkgconfig >= 1:0.17
22 BuildRequires:  xmlto
23 Requires:       openssl >= 0.9.8
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This is a C-language AMQP client library for use with AMQP servers
28 speaking protocol versions 0-9-1.
29
30 %description -l pl.UTF-8
31 Ten pakiet zawiera bibliotekę kliencką AMQP dla języka C, przeznaczoną
32 do użycia z serwerami AMQP obsługującymi protokół w wersjach 0-9-1.
33
34 %package devel
35 Summary:        Header files for rabbitmq-c library
36 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki rabbitmq-c
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       openssl-devel >= 0.9.8
40
41 %description devel
42 Header files for rabbitmq-c library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe biblioteki rabbitmq-c.
46
47 %package static
48 Summary:        Static rabbitmq-c library
49 Summary(pl.UTF-8):      Statyczna biblioteka rabbitmq-c
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static rabbitmq-c library.
55
56 %description static -l pl.UTF-8
57 Statyczna biblioteka rabbitmq-c.
58
59 %package tools
60 Summary:        Example tools utilizing the rabbitmq-c library
61 Summary(pl.UTF-8):      Przykładowe narzędzia wykorzystujące bibliotekę rabbitmq-c
62 Group:          Applications
63 Requires:       %{name} = %{version}-%{release}
64
65 %description tools
66 Example tools utilizing the rabbitmq-c library.
67
68 %description tools -l pl.UTF-8
69 Przykładowe narzędzia wykorzystujące bibliotekę rabbitmq-c.
70
71 %prep
72 %setup -q
73
74 %build
75 %{__libtoolize}
76 %{__aclocal} -I m4
77 %{__autoconf}
78 %{__autoheader}
79 %{__automake}
80 %configure \
81         --disable-silent-rules \
82         %{?with_static_libs:--enable-static}
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 # obsoleted by pkg-config
92 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc AUTHORS CONTRIBUTING.md LICENSE-MIT README.md THANKS TODO
103 %attr(755,root,root) %{_libdir}/librabbitmq.so.*.*.*
104 %attr(755,root,root) %ghost %{_libdir}/librabbitmq.so.4
105
106 %files devel
107 %defattr(644,root,root,755)
108 %attr(755,root,root) %{_libdir}/librabbitmq.so
109 %{_includedir}/amqp.h
110 %{_includedir}/amqp_framing.h
111 %{_includedir}/amqp_ssl_socket.h
112 %{_includedir}/amqp_tcp_socket.h
113 %{_pkgconfigdir}/librabbitmq.pc
114
115 %if %{with static_libs}
116 %files static
117 %defattr(644,root,root,755)
118 %{_libdir}/librabbitmq.a
119 %endif
120
121 %files tools
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_bindir}/amqp-consume
124 %attr(755,root,root) %{_bindir}/amqp-declare-queue
125 %attr(755,root,root) %{_bindir}/amqp-delete-queue
126 %attr(755,root,root) %{_bindir}/amqp-get
127 %attr(755,root,root) %{_bindir}/amqp-publish
128 %{_mandir}/man1/amqp-consume.1*
129 %{_mandir}/man1/amqp-declare-queue.1*
130 %{_mandir}/man1/amqp-delete-queue.1*
131 %{_mandir}/man1/amqp-get.1*
132 %{_mandir}/man1/amqp-publish.1*
133 %{_mandir}/man7/librabbitmq-tools.7*
This page took 0.084232 seconds and 4 git commands to generate.