]> git.pld-linux.org Git - packages/rabbitmq-c.git/blob - rabbitmq-c.spec
rebuild with openssl 3.0.0
[packages/rabbitmq-c.git] / rabbitmq-c.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 %bcond_without  tests           # don't build tests
5 #
6 %if %{without static_libs}
7 # tests require static libs
8 %undefine       with_tests
9 %endif
10 Summary:        RabbitMQ C AMQP client library
11 Summary(pl.UTF-8):      Biblioteka kliencka C RabbitMQ AMQP
12 Name:           rabbitmq-c
13 Version:        0.11.0
14 Release:        2
15 License:        MIT
16 Group:          Libraries
17 #Source0Download: https://github.com/alanxz/rabbitmq-c/releases
18 Source0:        https://github.com/alanxz/rabbitmq-c/archive/v%{version}/%{name}-%{version}.tar.gz
19 # Source0-md5:  e7d9896577aea6351811d7c1d7f0a68a
20 URL:            https://github.com/alanxz/rabbitmq-c
21 BuildRequires:  cmake >= 2.8.12
22 BuildRequires:  openssl-devel >= 0.9.8
23 BuildRequires:  popt-devel
24 BuildRequires:  pkgconfig >= 1:0.17
25 BuildRequires:  xmlto
26 Requires:       openssl >= 0.9.8
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This is a C-language AMQP client library for use with AMQP servers
31 speaking protocol versions 0-9-1.
32
33 %description -l pl.UTF-8
34 Ten pakiet zawiera bibliotekę kliencką AMQP dla języka C, przeznaczoną
35 do użycia z serwerami AMQP obsługującymi protokół w wersjach 0-9-1.
36
37 %package devel
38 Summary:        Header files for rabbitmq-c library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki rabbitmq-c
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42 Requires:       openssl-devel >= 0.9.8
43
44 %description devel
45 Header files for rabbitmq-c library.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki rabbitmq-c.
49
50 %package static
51 Summary:        Static rabbitmq-c library
52 Summary(pl.UTF-8):      Statyczna biblioteka rabbitmq-c
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static rabbitmq-c library.
58
59 %description static -l pl.UTF-8
60 Statyczna biblioteka rabbitmq-c.
61
62 %package tools
63 Summary:        Example tools utilizing the rabbitmq-c library
64 Summary(pl.UTF-8):      Przykładowe narzędzia wykorzystujące bibliotekę rabbitmq-c
65 Group:          Applications
66 Requires:       %{name} = %{version}-%{release}
67
68 %description tools
69 Example tools utilizing the rabbitmq-c library.
70
71 %description tools -l pl.UTF-8
72 Przykładowe narzędzia wykorzystujące bibliotekę rabbitmq-c.
73
74 %prep
75 %setup -q
76
77 %build
78 install -d build
79 cd build
80 %cmake .. \
81         %{!?with_static_libs:-DBUILD_STATIC_LIBS=OFF} \
82         %{!?with_tests:-DBUILD_TESTS=OFF} \
83         -DBUILD_TOOLS_DOCS=ON \
84         -DCMAKE_INSTALL_INCLUDEDIR:PATH=include \
85         -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib}
86
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 %{__make} -C build install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post   -p /sbin/ldconfig
99 %postun -p /sbin/ldconfig
100
101 %files
102 %defattr(644,root,root,755)
103 %doc AUTHORS CONTRIBUTING.md LICENSE-MIT README.md THANKS TODO
104 %attr(755,root,root) %{_libdir}/librabbitmq.so.*.*.*
105 %attr(755,root,root) %ghost %{_libdir}/librabbitmq.so.4
106
107 %files devel
108 %defattr(644,root,root,755)
109 %attr(755,root,root) %{_libdir}/librabbitmq.so
110 %{_includedir}/amqp.h
111 %{_includedir}/amqp_framing.h
112 %{_includedir}/amqp_ssl_socket.h
113 %{_includedir}/amqp_tcp_socket.h
114 %{_pkgconfigdir}/librabbitmq.pc
115 %{_libdir}/cmake/rabbitmq-c
116
117 %if %{with static_libs}
118 %files static
119 %defattr(644,root,root,755)
120 %{_libdir}/librabbitmq.a
121 %endif
122
123 %files tools
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_bindir}/amqp-consume
126 %attr(755,root,root) %{_bindir}/amqp-declare-queue
127 %attr(755,root,root) %{_bindir}/amqp-delete-queue
128 %attr(755,root,root) %{_bindir}/amqp-get
129 %attr(755,root,root) %{_bindir}/amqp-publish
130 %{_mandir}/man1/amqp-consume.1*
131 %{_mandir}/man1/amqp-declare-queue.1*
132 %{_mandir}/man1/amqp-delete-queue.1*
133 %{_mandir}/man1/amqp-get.1*
134 %{_mandir}/man1/amqp-publish.1*
135 %{_mandir}/man7/librabbitmq-tools.7*
This page took 0.403824 seconds and 4 git commands to generate.