]> git.pld-linux.org Git - packages/rabbitmq-c.git/blob - rabbitmq-c.spec
3a6ea908c9e2365784d3d56ac8acd5f9b410fea6
[packages/rabbitmq-c.git] / rabbitmq-c.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        RabbitMQ C AMQP client library
6 Summary(pl.UTF-8):      Biblioteka kliencka C RabbitMQ AMQP
7 Name:           rabbitmq-c
8 Version:        0.10.0
9 Release:        2
10 License:        MIT
11 Group:          Libraries
12 #Source0Download: https://github.com/alanxz/rabbitmq-c/releases
13 Source0:        https://github.com/alanxz/rabbitmq-c/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  6f09f0cb07cea221657a768bd9c7dff7
15 URL:            https://github.com/alanxz/rabbitmq-c
16 BuildRequires:  cmake >= 2.8.12
17 BuildRequires:  openssl-devel >= 0.9.8
18 BuildRequires:  popt-devel
19 BuildRequires:  pkgconfig >= 1:0.17
20 BuildRequires:  xmlto
21 Requires:       openssl >= 0.9.8
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This is a C-language AMQP client library for use with AMQP servers
26 speaking protocol versions 0-9-1.
27
28 %description -l pl.UTF-8
29 Ten pakiet zawiera bibliotekę kliencką AMQP dla języka C, przeznaczoną
30 do użycia z serwerami AMQP obsługującymi protokół w wersjach 0-9-1.
31
32 %package devel
33 Summary:        Header files for rabbitmq-c library
34 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki rabbitmq-c
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       openssl-devel >= 0.9.8
38
39 %description devel
40 Header files for rabbitmq-c library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki rabbitmq-c.
44
45 %package static
46 Summary:        Static rabbitmq-c library
47 Summary(pl.UTF-8):      Statyczna biblioteka rabbitmq-c
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static rabbitmq-c library.
53
54 %description static -l pl.UTF-8
55 Statyczna biblioteka rabbitmq-c.
56
57 %package tools
58 Summary:        Example tools utilizing the rabbitmq-c library
59 Summary(pl.UTF-8):      Przykładowe narzędzia wykorzystujące bibliotekę rabbitmq-c
60 Group:          Applications
61 Requires:       %{name} = %{version}-%{release}
62
63 %description tools
64 Example tools utilizing the rabbitmq-c library.
65
66 %description tools -l pl.UTF-8
67 Przykładowe narzędzia wykorzystujące bibliotekę rabbitmq-c.
68
69 %prep
70 %setup -q
71
72 %build
73 install -d build
74 cd build
75 %cmake .. \
76         %{!?with_static_libs:-DBUILD_STATIC_LIBS=OFF} \
77         -DBUILD_TOOLS_DOCS=ON \
78         -DCMAKE_INSTALL_INCLUDEDIR:PATH=include \
79         -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib}
80
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} -C build install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %doc AUTHORS CONTRIBUTING.md LICENSE-MIT README.md THANKS TODO
98 %attr(755,root,root) %{_libdir}/librabbitmq.so.*.*.*
99 %attr(755,root,root) %ghost %{_libdir}/librabbitmq.so.4
100
101 %files devel
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_libdir}/librabbitmq.so
104 %{_includedir}/amqp.h
105 %{_includedir}/amqp_framing.h
106 %{_includedir}/amqp_ssl_socket.h
107 %{_includedir}/amqp_tcp_socket.h
108 %{_pkgconfigdir}/librabbitmq.pc
109
110 %if %{with static_libs}
111 %files static
112 %defattr(644,root,root,755)
113 %{_libdir}/librabbitmq.a
114 %endif
115
116 %files tools
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_bindir}/amqp-consume
119 %attr(755,root,root) %{_bindir}/amqp-declare-queue
120 %attr(755,root,root) %{_bindir}/amqp-delete-queue
121 %attr(755,root,root) %{_bindir}/amqp-get
122 %attr(755,root,root) %{_bindir}/amqp-publish
123 %{_mandir}/man1/amqp-consume.1*
124 %{_mandir}/man1/amqp-declare-queue.1*
125 %{_mandir}/man1/amqp-delete-queue.1*
126 %{_mandir}/man1/amqp-get.1*
127 %{_mandir}/man1/amqp-publish.1*
128 %{_mandir}/man7/librabbitmq-tools.7*
This page took 0.095137 seconds and 3 git commands to generate.