]> git.pld-linux.org Git - SPECS.git/blob - qt5-qtx11extras.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / qt5-qtx11extras.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Documentation
4
5 %define         orgname         qtx11extras
6 %define         qtbase_ver      %{version}
7 %define         qttools_ver     %{version}
8 Summary:        The Qt5 X11 Extras library
9 Summary(pl.UTF-8):      Biblioteka Qt5 X11 Extras
10 Name:           qt5-%{orgname}
11 Version:        5.15.2
12 Release:        2
13 License:        LGPL v3 or GPL v2 or GPL v3 or commercial
14 Group:          X11/Libraries
15 Source0:        http://download.qt.io/official_releases/qt/5.15/%{version}/submodules/%{orgname}-everywhere-src-%{version}.tar.xz
16 # Source0-md5:  92cf72015788bb4dcab14494f2835b32
17 URL:            https://www.qt.io/
18 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
19 BuildRequires:  Qt5Gui-devel >= %{qtbase_ver}
20 %if %{with doc}
21 BuildRequires:  qt5-assistant >= %{qttools_ver}
22 %endif
23 BuildRequires:  qt5-build >= %{qtbase_ver}
24 BuildRequires:  qt5-qmake >= %{qtbase_ver}
25 BuildRequires:  rpmbuild(macros) >= 1.752
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         specflags       -fno-strict-aliasing
31 %define         qt5dir          %{_libdir}/qt5
32
33 %description
34 Qt is a cross-platform application and UI framework. Using Qt, you can
35 write web-enabled applications once and deploy them across desktop,
36 mobile and embedded systems without rewriting the source code.
37
38 This package contains Qt5 X11 Extras library.
39
40 %description -l pl.UTF-8
41 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
42 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
43 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
44 źródłowego.
45
46 Ten pakiet zawiera bibliotekę Qt5 X11 Extras.
47
48 %package -n Qt5X11Extras
49 Summary:        The Qt5 X11 Extras library
50 Summary(pl.UTF-8):      Biblioteka Qt5 X11 Extras
51 Group:          Libraries
52 Requires:       Qt5Core >= %{qtbase_ver}
53 Requires:       Qt5Gui >= %{qtbase_ver}
54 Obsoletes:      qt5-qtx11extras < 5.2.0-1
55
56 %description -n Qt5X11Extras
57 Qt5 X11 Extras library provides classes for developing for the X11
58 platform.
59
60 %description -n Qt5X11Extras -l pl.UTF-8
61 Biblioteka Qt5 X11 Extras dostarcza klasy do tworzenia oprogramowania
62 dla platformy X11.
63
64 %package -n Qt5X11Extras-devel
65 Summary:        Qt5 X11 Extras - development files
66 Summary(pl.UTF-8):      Biblioteka Qt5 X11 Extras - pliki programistyczne
67 Group:          X11/Development/Libraries
68 Requires:       Qt5Core-devel >= %{qtbase_ver}
69 Requires:       Qt5Gui-devel >= %{qtbase_ver}
70 Requires:       Qt5X11Extras = %{version}-%{release}
71 Obsoletes:      qt5-qtx11extras-devel < 5.2.0-1
72
73 %description -n Qt5X11Extras-devel
74 Qt5 X11 Extras - development files.
75
76 %description -n Qt5X11Extras-devel -l pl.UTF-8
77 Biblioteka Qt5 X11 Extras - pliki programistyczne.
78
79 %package doc
80 Summary:        Qt5 X11 Extras documentation in HTML format
81 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 X11 Extras w formacie HTML
82 Group:          Documentation
83 Requires:       qt5-doc-common >= %{qtbase_ver}
84 BuildArch:      noarch
85
86 %description doc
87 Qt5 X11 Extras documentation in HTML format.
88
89 %description doc -l pl.UTF-8
90 Dokumentacja do biblioteki Qt5 X11 Extras w formacie HTML.
91
92 %package doc-qch
93 Summary:        Qt5 X11 Extras documentation in QCH format
94 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 X11 Extras w formacie QCH
95 Group:          Documentation
96 Requires:       qt5-doc-common >= %{qtbase_ver}
97 BuildArch:      noarch
98
99 %description doc-qch
100 Qt5 X11 Extras documentation in QCH format.
101
102 %description doc-qch -l pl.UTF-8
103 Dokumentacja do biblioteki Qt5 X11 Extras w formacie QCH.
104
105 %prep
106 %setup -q -n %{orgname}-everywhere-src-%{version}
107
108 %build
109 qmake-qt5
110 %{__make}
111 %{?with_doc:%{__make} docs}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         INSTALL_ROOT=$RPM_BUILD_ROOT
118
119 %if %{with doc}
120 %{__make} install_docs \
121         INSTALL_ROOT=$RPM_BUILD_ROOT
122 %endif
123
124 # useless symlinks
125 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
126 # actually drop *.la, follow policy of not packaging them when *.pc exist
127 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -n Qt5X11Extras -p /sbin/ldconfig
133 %postun -n Qt5X11Extras -p /sbin/ldconfig
134
135 %files -n Qt5X11Extras
136 %defattr(644,root,root,755)
137 %doc LICENSE.GPL3-EXCEPT dist/changes-*
138 %attr(755,root,root) %{_libdir}/libQt5X11Extras.so.*.*.*
139 %attr(755,root,root) %ghost %{_libdir}/libQt5X11Extras.so.5
140
141 %files -n Qt5X11Extras-devel
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_libdir}/libQt5X11Extras.so
144 %{_libdir}/libQt5X11Extras.prl
145 %{_includedir}/qt5/QtX11Extras
146 %{_pkgconfigdir}/Qt5X11Extras.pc
147 %{_libdir}/cmake/Qt5X11Extras
148 %{qt5dir}/mkspecs/modules/qt_lib_x11extras.pri
149 %{qt5dir}/mkspecs/modules/qt_lib_x11extras_private.pri
150
151 %if %{with doc}
152 %files doc
153 %defattr(644,root,root,755)
154 %{_docdir}/qt5-doc/qtx11extras
155
156 %files doc-qch
157 %defattr(644,root,root,755)
158 %{_docdir}/qt5-doc/qtx11extras.qch
159 %endif
This page took 0.273934 seconds and 3 git commands to generate.