]> git.pld-linux.org Git - SPECS.git/blob - qt5-qtwebview.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / qt5-qtwebview.spec
1 #
2 # Conditional build:
3 %bcond_without  doc             # Documentation
4 %bcond_without  webengine       # WebEngine plugin
5
6 %ifarch x32
7 %undefine       with_webengine
8 %endif
9
10 %define         orgname         qtwebview
11 %define         qtbase_ver              %{version}
12 %define         qtdeclarative_ver       %{version}
13 %define         qttools_ver             %{version}
14 %define         qtwebengine_ver         %{version}
15 Summary:        The Qt5 WebView library
16 Summary(pl.UTF-8):      Biblioteka Qt5 WebView
17 Name:           qt5-%{orgname}
18 Version:        5.15.2
19 Release:        1
20 License:        LGPL v3 or GPL v2+ or commercial
21 Group:          X11/Libraries
22 Source0:        https://download.qt.io/official_releases/qt/5.15/%{version}/submodules/%{orgname}-everywhere-src-%{version}.tar.xz
23 # Source0-md5:  5ed6778d83cf7a49128af201eb0ebf64
24 URL:            https://www.qt.io/
25 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
26 BuildRequires:  Qt5Gui-devel >= %{qtbase_ver}
27 BuildRequires:  Qt5Qml-devel >= %{qtdeclarative_ver}
28 BuildRequires:  Qt5Quick-devel >= %{qtdeclarative_ver}
29 %{?with_webengine:BuildRequires:        Qt5WebEngine-devel >= %{qtwebengine_ver}}
30 %if %{with doc}
31 BuildRequires:  qt5-assistant >= %{qttools_ver}
32 BuildRequires:  qt5-doc-common >= %{qttools_ver}
33 %endif
34 BuildRequires:  qt5-build >= %{qtbase_ver}
35 BuildRequires:  qt5-qmake >= %{qtbase_ver}
36 BuildRequires:  rpm-build >= 4.6
37 BuildRequires:  rpmbuild(macros) >= 1.752
38 BuildRequires:  tar >= 1:1.22
39 BuildRequires:  xz
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         specflags       -fno-strict-aliasing
43 %define         qt5dir          %{_libdir}/qt5
44
45 %description
46 Qt is a cross-platform application and UI framework. Using Qt, you can
47 write web-enabled applications once and deploy them across desktop,
48 mobile and embedded systems without rewriting the source code.
49
50 This package contains Qt5 WebView library.
51
52 %description -l pl.UTF-8
53 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
54 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
55 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
56 źródłowego.
57
58 Ten pakiet zawiera bibliotekę Qt5 WebView.
59
60 %package -n Qt5WebView
61 Summary:        The Qt5 WebView library
62 Summary(pl.UTF-8):      Biblioteka Qt5 WebView
63 Group:          X11/Libraries
64 Requires:       Qt5Core >= %{qtbase_ver}
65 Requires:       Qt5Gui >= %{qtbase_ver}
66 Requires:       Qt5Qml >= %{qtdeclarative_ver}
67 Requires:       Qt5Quick >= %{qtdeclarative_ver}
68
69 %description -n Qt5WebView
70 Qt5 WebView library.
71
72 %description -n Qt5WebView -l pl.UTF-8
73 Biblioteka Qt5 WebView.
74
75 %package -n Qt5WebView-devel
76 Summary:        Qt5 WebView - development files
77 Summary(pl.UTF-8):      Biblioteka Qt5 WebView - pliki programistyczne
78 Group:          X11/Development/Libraries
79 Requires:       Qt5Core-devel >= %{qtbase_ver}
80 Requires:       Qt5Gui-devel >= %{qtbase_ver}
81 Requires:       Qt5WebView = %{version}-%{release}
82
83 %description -n Qt5WebView-devel
84 Qt5 WebView - development files.
85
86 %description -n Qt5WebView-devel -l pl.UTF-8
87 Biblioteka Qt5 WebView - pliki programistyczne.
88
89 %package -n Qt5WebView-plugin-webengine
90 Summary:        Qt5 WebView library WebEngine plugin
91 Summary(pl.UTF-8):      Wtyczka WebEngine do biblioteki Qt5 WebView
92 Group:          X11/Libraries
93 Requires:       Qt5WebEngine >= %{qtwebengine_ver}
94 Requires:       Qt5WebView = %{version}-%{release}
95
96 %description -n Qt5WebView-plugin-webengine
97 Qt5 WebView library WebEngine plugin.
98
99 %description -n Qt5WebView-plugin-webengine -l pl.UTF-8
100 Wtyczka WebEngine do biblioteki Qt5 WebView.
101
102 %package doc
103 Summary:        Qt5 WebView documentation in HTML format
104 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 WebView w formacie HTML
105 Group:          Documentation
106 Requires:       qt5-doc-common >= %{qtbase_ver}
107 BuildArch:      noarch
108
109 %description doc
110 Qt5 WebView documentation in HTML format.
111
112 %description doc -l pl.UTF-8
113 Dokumentacja do biblioteki Qt5 WebView w formacie HTML.
114
115 %package doc-qch
116 Summary:        Qt5 WebView documentation in QCH format
117 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 WebView w formacie QCH
118 Group:          Documentation
119 Requires:       qt5-doc-common >= %{qtbase_ver}
120 BuildArch:      noarch
121
122 %description doc-qch
123 Qt5 WebView documentation in QCH format.
124
125 %description doc-qch -l pl.UTF-8
126 Dokumentacja do biblioteki Qt5 WebView w formacie QCH.
127
128 %package examples
129 Summary:        Qt5 WebView examples
130 Summary(pl.UTF-8):      Przykłady do biblioteki Qt5 WebView
131 Group:          X11/Development/Libraries
132 BuildArch:      noarch
133
134 %description examples
135 Qt5 WebView examples.
136
137 %description examples -l pl.UTF-8
138 Przykłady do biblioteki Qt5 WebView.
139
140 %prep
141 %setup -q -n %{orgname}-everywhere-src-%{version}
142
143 %build
144 qmake-qt5
145 %{__make}
146 %{?with_doc:%{__make} docs}
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150
151 %{__make} install \
152         INSTALL_ROOT=$RPM_BUILD_ROOT
153
154 %if %{without webengine}
155 install -d $RPM_BUILD_ROOT%{qt5dir}/plugins/webview
156 %endif
157
158 %if %{with doc}
159 %{__make} install_docs \
160         INSTALL_ROOT=$RPM_BUILD_ROOT
161 %endif
162
163 # useless symlinks
164 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
165 # obsoleted by pkg-config
166 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
167
168 # remove compiled examples (package only sources)
169 for d in $RPM_BUILD_ROOT%{_examplesdir}/qt5/webview/* ; do
170         [ -d "$d" ] && %{__rm} "$d/$(basename $d)"
171 done
172
173 %clean
174 rm -rf $RPM_BUILD_ROOT
175
176 %post   -n Qt5WebView -p /sbin/ldconfig
177 %postun -n Qt5WebView -p /sbin/ldconfig
178
179 %files -n Qt5WebView
180 %defattr(644,root,root,755)
181 %doc dist/changes-*
182 # R: Qt5Core Qt5Qml
183 %attr(755,root,root) %{_libdir}/libQt5WebView.so.*.*.*
184 %attr(755,root,root) %ghost %{_libdir}/libQt5WebView.so.5
185 %dir %{qt5dir}/plugins/webview
186 %dir %{qt5dir}/qml/QtWebView
187 # R: Qt5Core Qt5Qml Qt5Quick Qt5WebView
188 %attr(755,root,root) %{qt5dir}/qml/QtWebView/libdeclarative_webview.so
189 %{qt5dir}/qml/QtWebView/plugins.qmltypes
190 %{qt5dir}/qml/QtWebView/qmldir
191
192 %files -n Qt5WebView-devel
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_libdir}/libQt5WebView.so
195 %{_libdir}/libQt5WebView.prl
196 %{_includedir}/qt5/QtWebView
197 %{_pkgconfigdir}/Qt5WebView.pc
198 %dir %{_libdir}/cmake/Qt5WebView
199 %{_libdir}/cmake/Qt5WebView/Qt5WebViewConfig*.cmake
200 %{qt5dir}/mkspecs/modules/qt_lib_webview.pri
201 %{qt5dir}/mkspecs/modules/qt_lib_webview_private.pri
202
203 %if %{with webengine}
204 %files -n Qt5WebView-plugin-webengine
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{qt5dir}/plugins/webview/libqtwebview_webengine.so
207 %{_libdir}/cmake/Qt5WebView/Qt5WebView_QWebEngineWebViewPlugin.cmake
208 %endif
209
210 %if %{with doc}
211 %files doc
212 %defattr(644,root,root,755)
213 %{_docdir}/qt5-doc/qtwebview
214
215 %files doc-qch
216 %defattr(644,root,root,755)
217 %{_docdir}/qt5-doc/qtwebview.qch
218 %endif
219
220 %files examples
221 %defattr(644,root,root,755)
222 # XXX: dir shared with qt5-qtbase-examples
223 %dir %{_examplesdir}/qt5
224 %{_examplesdir}/qt5/webview
This page took 1.058465 seconds and 3 git commands to generate.