]> git.pld-linux.org Git - packages/qt5-qtscxml.git/blob - qt5-qtscxml.spec
19490f1565940402f5182d1ad4b24f5c4a910351
[packages/qt5-qtscxml.git] / qt5-qtscxml.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Documentation
4
5 %define         orgname         qtscxml
6 %define         qtbase_ver              %{version}
7 %define         qtdeclarative_ver       %{version}
8 %define         qttools_ver             %{version}
9 Summary:        The Qt5 Scxml library
10 Summary(pl.UTF-8):      Biblioteka Qt5 Scxml
11 Name:           qt5-%{orgname}
12 Version:        5.15.2
13 Release:        2
14 License:        LGPL v3 or GPL v2+ or commercial
15 Group:          X11/Libraries
16 Source0:        https://download.qt.io/official_releases/qt/5.15/%{version}/submodules/%{orgname}-everywhere-src-%{version}.tar.xz
17 # Source0-md5:  5c52fd3e39707e46c6a37b4e13636ceb
18 URL:            https://www.qt.io/
19 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
20 BuildRequires:  Qt5Qml-devel >= %{qtdeclarative_ver}
21 %if %{with doc}
22 BuildRequires:  qt5-assistant >= %{qttools_ver}
23 BuildRequires:  qt5-doc-common >= %{qttools_ver}
24 %endif
25 BuildRequires:  qt5-build >= %{qtbase_ver}
26 BuildRequires:  qt5-qmake >= %{qtbase_ver}
27 BuildRequires:  rpm-build >= 4.6
28 BuildRequires:  rpmbuild(macros) >= 1.752
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         specflags       -fno-strict-aliasing
34 %define         qt5dir          %{_libdir}/qt5
35
36 %description
37 Qt is a cross-platform application and UI framework. Using Qt, you can
38 write web-enabled applications once and deploy them across desktop,
39 mobile and embedded systems without rewriting the source code.
40
41 This package contains Qt5 Scxml library.
42
43 %description -l pl.UTF-8
44 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
45 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
46 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
47 źródłowego.
48
49 Ten pakiet zawiera bibliotekę Qt5 Scxml.
50
51 %package -n Qt5Scxml
52 Summary:        The Qt5 Scxml library
53 Summary(pl.UTF-8):      Biblioteka Qt5 Scxml
54 Group:          X11/Libraries
55 Requires:       Qt5Core >= %{qtbase_ver}
56 Requires:       Qt5Qml >= %{qtdeclarative_ver}
57
58 %description -n Qt5Scxml
59 Qt5 Scxml library.
60
61 %description -n Qt5Scxml -l pl.UTF-8
62 Biblioteka Qt5 Scxml.
63
64 %package -n Qt5Scxml-devel
65 Summary:        Qt5 Scxml - development files
66 Summary(pl.UTF-8):      Biblioteka Qt5 Scxml - pliki programistyczne
67 Group:          X11/Development/Libraries
68 Requires:       Qt5Core-devel >= %{qtbase_ver}
69 Requires:       Qt5Qml-devel >= %{qtdeclarative_ver}
70
71 %description -n Qt5Scxml-devel
72 Qt5 Scxml - development files.
73
74 %description -n Qt5Scxml-devel -l pl.UTF-8
75 Biblioteka Qt5 Scxml - pliki programistyczne.
76
77 %package doc
78 Summary:        Qt5 Scxml documentation in HTML format
79 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Scxml w formacie HTML
80 Group:          Documentation
81 Requires:       qt5-doc-common >= %{qtbase_ver}
82 BuildArch:      noarch
83
84 %description doc
85 Qt5 Scxml documentation in HTML format.
86
87 %description doc -l pl.UTF-8
88 Dokumentacja do biblioteki Qt5 Scxml w formacie HTML.
89
90 %package doc-qch
91 Summary:        Qt5 Scxml documentation in QCH format
92 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Scxml w formacie QCH
93 Group:          Documentation
94 Requires:       qt5-doc-common >= %{qtbase_ver}
95 BuildArch:      noarch
96
97 %description doc-qch
98 Qt5 Scxml documentation in QCH format.
99
100 %description doc-qch -l pl.UTF-8
101 Dokumentacja do biblioteki Qt5 Scxml w formacie QCH.
102
103 %package examples
104 Summary:        Qt5 Scxml examples
105 Summary(pl.UTF-8):      Przykłady do biblioteki Qt5 Scxml
106 Group:          X11/Development/Libraries
107 BuildArch:      noarch
108
109 %description examples
110 Qt5 Scxml examples.
111
112 %description examples -l pl.UTF-8
113 Przykłady do biblioteki Qt5 Scxml.
114
115 %prep
116 %setup -q -n %{orgname}-everywhere-src-%{version}
117
118 %build
119 qmake-qt5
120 %{__make}
121 %{?with_doc:%{__make} docs}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %{__make} install \
127         INSTALL_ROOT=$RPM_BUILD_ROOT
128
129 %if %{with doc}
130 %{__make} install_docs \
131         INSTALL_ROOT=$RPM_BUILD_ROOT
132 %endif
133
134 # useless symlinks
135 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
136 # obsoleted by pkg-config
137 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
138
139 # remove compiled examples (package only sources)
140 for d in $RPM_BUILD_ROOT%{_examplesdir}/qt5/scxml/* ; do
141         [ -d "$d" ] && %{__rm} "$d/$(basename $d)"
142 done
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   -n Qt5Scxml -p /sbin/ldconfig
148 %postun -n Qt5Scxml -p /sbin/ldconfig
149
150 %files -n Qt5Scxml
151 %defattr(644,root,root,755)
152 %doc LICENSE.GPL3-EXCEPT dist/changes-*
153 # R: Qt5Core Qt5Qml
154 %attr(755,root,root) %{_libdir}/libQt5Scxml.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libQt5Scxml.so.5
156 # R: Qt5Core
157 %attr(755,root,root) %{qt5dir}/bin/qscxmlc
158 %dir %{qt5dir}/qml/QtScxml
159 # R: Qt5Core Qt5Qml Qt5Scxml
160 %attr(755,root,root) %{qt5dir}/qml/QtScxml/libdeclarative_scxml.so
161 %{qt5dir}/qml/QtScxml/plugins.qmltypes
162 %{qt5dir}/qml/QtScxml/qmldir
163
164 %files -n Qt5Scxml-devel
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/libQt5Scxml.so
167 %{_libdir}/libQt5Scxml.prl
168 %{_includedir}/qt5/QtScxml
169 %{_pkgconfigdir}/Qt5Scxml.pc
170 %{_libdir}/cmake/Qt5Scxml
171 %{qt5dir}/mkspecs/features/qscxmlc.prf
172 %{qt5dir}/mkspecs/modules/qt_lib_scxml.pri
173 %{qt5dir}/mkspecs/modules/qt_lib_scxml_private.pri
174
175 %if %{with doc}
176 %files doc
177 %defattr(644,root,root,755)
178 %{_docdir}/qt5-doc/qtscxml
179
180 %files doc-qch
181 %defattr(644,root,root,755)
182 %{_docdir}/qt5-doc/qtscxml.qch
183 %endif
184
185 %files examples
186 %defattr(644,root,root,755)
187 # XXX: dir shared with qt5-qtbase-examples
188 %dir %{_examplesdir}/qt5
189 %{_examplesdir}/qt5/scxml
This page took 0.054363 seconds and 2 git commands to generate.