]> git.pld-linux.org Git - SPECS.git/blob - qt5-qtcoap.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / qt5-qtcoap.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Documentation
4
5 %define         orgname         qtcoap
6 %define         qtbase_ver      %{version}
7 %define         qttools_ver     %{version}
8 Summary:        The Qt5 Coap library
9 Summary(pl.UTF-8):      Biblioteka Qt5 Coap
10 Name:           qt5-%{orgname}
11 Version:        5.15.13
12 Release:        1
13 License:        GPL v3+ or commercial
14 Group:          Libraries
15 Source0:        https://download.qt.io/official_releases/qt/5.15/%{version}/submodules/%{orgname}-everywhere-opensource-src-%{version}.tar.xz
16 # Source0-md5:  e060fd510df07e31b9bdc38010a44a8c
17 URL:            https://www.qt.io/
18 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
19 BuildRequires:  Qt5Network-devel >= %{qtbase_ver}
20 %if %{with doc}
21 BuildRequires:  qt5-assistant >= %{qttools_ver}
22 %endif
23 BuildRequires:  qt5-build >= %{qtbase_ver}
24 BuildRequires:  qt5-qmake >= %{qtbase_ver}
25 BuildRequires:  rpm-build >= 4.6
26 BuildRequires:  rpmbuild(macros) >= 2.016
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         specflags       -fno-strict-aliasing
32 %define         qt5dir          %{_libdir}/qt5
33
34 %description
35 Qt is a cross-platform application and UI framework. Using Qt, you can
36 write web-enabled applications once and deploy them across desktop,
37 mobile and embedded systems without rewriting the source code.
38
39 This package contains Qt5 Coap library.
40
41 %description -l pl.UTF-8
42 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
43 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
44 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
45 źródłowego.
46
47 Ten pakiet zawiera bibliotekę Qt5 Coap.
48
49 %package -n Qt5Coap
50 Summary:        The Qt5 Coap library
51 Summary(pl.UTF-8):      Biblioteka Qt5 Coap
52 Group:          Libraries
53 %requires_eq_to Qt5Core Qt5Core-devel
54 Requires:       Qt5Network >= %{qtbase_ver}
55
56 %description -n Qt5Coap
57 Qt Coap module contains a library that supports the CoAP protocol.
58 CoAP is a protocol for IoT devices and machine to machine
59 communication.
60
61 %description -n Qt5Coap -l pl.UTF-8
62 Moduł Qt Coap zawiera bibliotekę obsługującą protokół CoAP. Jest to
63 protokół dla urządzeń IoT oraz do komunikacji między maszynami.
64
65 %package -n Qt5Coap-devel
66 Summary:        Qt5 Coap library - development files
67 Summary(pl.UTF-8):      Biblioteka Qt5 Coap - pliki programistyczne
68 Group:          Development/Libraries
69 Requires:       Qt5Coap = %{version}-%{release}
70 Requires:       Qt5Core-devel >= %{qtbase_ver}
71 Requires:       Qt5Network-devel >= %{qtbase_ver}
72
73 %description -n Qt5Coap-devel
74 Qt5 Coap library - development files.
75
76 %description -n Qt5Coap-devel -l pl.UTF-8
77 Biblioteka Qt5 Coap - pliki programistyczne.
78
79 %package doc
80 Summary:        Qt5 Coap documentation in HTML format
81 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Coap w formacie HTML
82 License:        FDL v1.3
83 Group:          Documentation
84 Requires:       qt5-doc-common >= %{qtbase_ver}
85 BuildArch:      noarch
86
87 %description doc
88 Qt5 Coap documentation in HTML format.
89
90 %description doc -l pl.UTF-8
91 Dokumentacja do biblioteki Qt5 Coap w formacie HTML.
92
93 %package doc-qch
94 Summary:        Qt5 Coap documentation in QCH format
95 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Coap w formacie QCH
96 License:        FDL v1.3
97 Group:          Documentation
98 Requires:       qt5-doc-common >= %{qtbase_ver}
99 BuildArch:      noarch
100
101 %description doc-qch
102 Qt5 Coap documentation in QCH format.
103
104 %description doc-qch -l pl.UTF-8
105 Dokumentacja do biblioteki Qt5 Coap w formacie QCH.
106
107 %package examples
108 Summary:        Qt5 Coap examples
109 Summary(pl.UTF-8):      Przykłady do biblioteki Qt5 Coap
110 License:        BSD or commercial
111 Group:          Development/Libraries
112 BuildArch:      noarch
113
114 %description examples
115 Qt5 Coap examples.
116
117 %description examples -l pl.UTF-8
118 Przykłady do biblioteki Qt5 Coap.
119
120 %prep
121 %setup -q -n %{orgname}-everywhere-src-%{version}
122
123 %build
124 %{qmake_qt5}
125 %{__make}
126 %{?with_doc:%{__make} docs}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 %{__make} install \
132         INSTALL_ROOT=$RPM_BUILD_ROOT
133
134 %if %{with doc}
135 %{__make} install_docs \
136         INSTALL_ROOT=$RPM_BUILD_ROOT
137 %endif
138
139 # useless symlinks
140 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
141 # actually drop *.la, follow policy of not packaging them when *.pc exist
142 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
143
144 # Prepare some files list
145 ifecho() {
146         r="$RPM_BUILD_ROOT$2"
147         if [ -d "$r" ]; then
148                 echo "%%dir $2" >> $1.files
149         elif [ -x "$r" ] ; then
150                 echo "%%attr(755,root,root) $2" >> $1.files
151         elif [ -f "$r" ]; then
152                 echo "$2" >> $1.files
153         else
154                 echo "Error generation $1 files list!"
155                 echo "$r: no such file or directory!"
156                 return 1
157         fi
158 }
159 ifecho_tree() {
160         ifecho $1 $2
161         for f in `find $RPM_BUILD_ROOT$2 -printf "%%P "`; do
162                 ifecho $1 $2/$f
163         done
164 }
165
166 echo "%defattr(644,root,root,755)" > examples.files
167 ifecho_tree examples %{_examplesdir}/qt5/coap
168
169 %clean
170 rm -rf $RPM_BUILD_ROOT
171
172 %post   -n Qt5Coap -p /sbin/ldconfig
173 %postun -n Qt5Coap -p /sbin/ldconfig
174
175 %files -n Qt5Coap
176 %defattr(644,root,root,755)
177 %doc README.md dist/changes-*
178 # R: Qt5Core Qt5Network
179 %attr(755,root,root) %{_libdir}/libQt5Coap.so.*.*.*
180 %attr(755,root,root) %ghost %{_libdir}/libQt5Coap.so.5
181
182 %files -n Qt5Coap-devel
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/libQt5Coap.so
185 %{_libdir}/libQt5Coap.prl
186 %{_includedir}/qt5/QtCoap
187 %{_pkgconfigdir}/Qt5Coap.pc
188 %{_libdir}/cmake/Qt5Coap
189 %{qt5dir}/mkspecs/modules/qt_lib_coap.pri
190 %{qt5dir}/mkspecs/modules/qt_lib_coap_private.pri
191
192 %if %{with doc}
193 %files doc
194 %defattr(644,root,root,755)
195 %{_docdir}/qt5-doc/qtcoap
196
197 %files doc-qch
198 %defattr(644,root,root,755)
199 %{_docdir}/qt5-doc/qtcoap.qch
200 %endif
201
202 %files examples -f examples.files
203 %defattr(644,root,root,755)
204 # XXX: dir shared with qt5-qtbase-examples
205 %dir %{_examplesdir}/qt5
This page took 1.556871 seconds and 3 git commands to generate.