]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- more options to configure, nostatic patch
[packages/qemu.git] / qemu.spec
1 Summary:        QEMU CPU Emulator
2 Name:           qemu
3 Version:        0.5.2
4 Release:        0.1
5 Source0:        http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
6 Patch0:         %{name}-nostatic.patch
7 #Patch0:                qemu-0.5.0-cvsupdates.patch.bz2
8 #Patch1:                qemu-0.1.6-glibc23-ldscripts.patch.bz2
9 #Patch2:                qemu-0.5.0-sdl-static-libs.patch.bz2
10 #Patch3:                qemu-0.5.0-DESTDIR.patch.bz2
11 #Patch4:                qemu-0.5.0-lib64.patch.bz2
12 #Patch5:                qemu-0.5.0-amd64.patch.bz2
13 #Patch6:                qemu-0.5.0-vl-amd64.patch.bz2
14 License:        GPL
15 URL:            http://fabrice.bellard.free.fr/qemu/
16 Group:          Applications/Emulators
17 BuildRequires:  SDL-devel
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 QEMU is a FAST! processor emulator. By using dynamic translation it
22 achieves a reasonnable speed while being easy to port on new host
23 CPUs. QEMU has two operating modes:
24
25 - User mode emulation. In this mode, QEMU can launch Linux processes
26   compiled for one CPU on another CPU. Linux system calls are converted
27   because of endianness and 32/64 bit mismatches. Wine (Windows
28   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
29
30 - Full system emulation. In this mode, QEMU emulates a full system,
31   including a processor and various peripherials. Currently, it is only
32   used to launch an x86 Linux kernel on an x86 Linux system. It enables
33   easier testing and debugging of system code. It can also be used to
34   provide virtual hosting of several virtual PC on a single server.
35
36 %prep
37 %setup -q
38 %patch0 -p1
39 #%patch0 -p1 -b .cvsupdates
40 #%patch1 -p1 -b .glibc23-ldscripts
41 #%patch2 -p1 -b .sdl-static-libs
42 #%patch3 -p1 -b .DESTDIR
43 #%patch4 -p1 -b .lib64
44 #%patch5 -p1 -b .amd64
45 # needs to 64-bit clean softmmu code or MAP_32BIT physical_ram_base
46 # but other problems remain.
47 #%patch6 -p1 -b .vl-amd64
48
49 %build
50 ./configure \
51         --prefix=%{_prefix} \
52         --cc=%{__cc} \
53         --make=%{__make} \
54         --interp-prefix=%{_libdir}/gnemul/qemu-%M
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc README qemu-doc.html
68 %ifarch %{ix86}
69 %attr(755,root,root) %{_bindir}/qemu-fast
70 %endif
71 %ifarch %{ix86} ppc
72 %{_bindir}/qemu
73 %endif
74 %{_bindir}/qemu-mkcow
75 %{_bindir}/qemu-arm
76 %{_bindir}/qemu-i386
77 %{_bindir}/qemu-sparc
78 %{_mandir}/man1/qemu.1*
79 %dir %{_datadir}/qemu
80 %{_datadir}/qemu/bios.bin
81 %{_datadir}/qemu/vgabios.bin
This page took 0.069705 seconds and 4 git commands to generate.