]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- use x8664 macro
[packages/qemu.git] / qemu.spec
1 #
2 # Conditional build:
3 %bcond_with     kqemu                   # with QEMU accelerator module
4 #
5 Summary:        QEMU CPU Emulator
6 Summary(pl):    QEMU - emulator procesora
7 Name:           qemu
8 Version:        0.7.0
9 Release:        1
10 License:        GPL
11 Group:          Applications/Emulators
12 #Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
13 Source0:        http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
14 # Source0-md5:  234e9ace03b00259bb57dc5a9c633056
15 %if %{with kqemu}
16 Source1:        http://fabrice.bellard.free.fr/qemu/kqemu-0.6.2-1.tar.gz
17 # NoSource1-md5:        c6bb3b40fb3d526d731eb0f1f9dee7ee
18 NoSource:       1
19 %endif
20 Patch0:         %{name}-nostatic.patch
21 Patch1:         %{name}-DESTDIR.patch
22 Patch2:         %{name}-longjmp.patch
23 Patch3:         %{name}-dot.patch
24 URL:            http://fabrice.bellard.free.fr/qemu/
25 BuildRequires:  SDL-devel >= 1.2.1
26 BuildRequires:  sed >= 4.0
27 ExclusiveArch:  %{ix86} %{x8664} ppc
28 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 # some SPARC boot image in ELF format
32 %define         _noautostrip    .*%{_datadir}/qemu/proll.elf
33
34 %description
35 QEMU is a FAST! processor emulator. By using dynamic translation it
36 achieves a reasonnable speed while being easy to port on new host
37 CPUs. QEMU has two operating modes:
38
39 - User mode emulation. In this mode, QEMU can launch Linux processes
40   compiled for one CPU on another CPU. Linux system calls are converted
41   because of endianness and 32/64 bit mismatches. Wine (Windows
42   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
43
44 - Full system emulation. In this mode, QEMU emulates a full system,
45   including a processor and various peripherials. 
46   It can also be used to provide virtual hosting of several 
47   virtual PC on a single server.
48
49 %description -l pl
50 QEMU to szybki(!) emulator procesora. Poprzez u¿ycie dynamicznego
51 t³umaczenia osi±ga rozs±dn± szybko¶æ i jest ³atwy do przeportowania,
52 aby dzia³a³ na kolejnych procesorach. QEMU ma dwa tryby pracy:
53
54 - Emulacja trybu u¿ytkownika. W tym trybie QEMU mo¿e uruchamiaæ
55   procesy linuksowe skompilowane dla jednego procesora na innym
56   procesorze. Linuksowe wywo³ania systemowe s± t³umaczone ze wzglêdu
57   na niezgodno¶æ kolejno¶ci bajtów w s³owie i 32/64-bitowego rozmiaru
58   s³owa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to g³ówne
59   cele QEMU.
60
61 - Pe³na emulacja systemu. W tym trybie QEMU emuluje ca³y system,
62   w³±czaj±c w to procesor i ró¿ne urz±dzenia peryferyjne.
63   Mo¿e byæ tak¿e u¿ywane do wirtualnego hostowania kilku wirtualnych 
64   pecetów na pojedynczym serwerze.
65
66 %prep
67 %setup -q %{?with_kqemu:-a1}
68 %patch0 -p1
69 %patch1 -p1
70 %patch2 -p1
71 %patch3 -p1
72
73 sed -i -e 's/sdl_static=yes/sdl_static=no/' configure
74 # cannot use optflags on x86 - they cause "no register to spill" errors
75 #sed -i -e 's/-Wall -O2 -g/-Wall %{rpmcflags}/' Makefile Makefile.target
76
77 %{?with_kqemu:echo -n > kqemu/install.sh}
78
79 %build
80 # --extra-cflags don't work (overridden by CFLAGS in Makefile*)
81 ./configure \
82         --prefix=%{_prefix} \
83         --cc="%{__cc}" \
84         --make="%{__make}"
85
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files
98 %defattr(644,root,root,755)
99 %doc README qemu-doc.html qemu-tech.html
100 %attr(755,root,root) %{_bindir}/*
101 %{_datadir}/qemu
102 %{_mandir}/man1/qemu.1*
103 %{_mandir}/man1/qemu-img.1*
This page took 0.085223 seconds and 4 git commands to generate.