]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
6a8ee9e4b8c32917995a2b53ba46bdbe6efd991d
[packages/qemu.git] / qemu.spec
1 #
2 # TODO:
3 # - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4 # - kqemu could be distributable if somebody bothers to contact qemu
5 #   author http://fabrice.bellard.free.fr/qemu/qemu-accel.html
6 #
7 # Conditional build:
8 %bcond_without  kqemu                   # disable QEMU accelerator support
9 %bcond_with     cflags_passing          # with passing rpmcflags to Makefiles
10 %bcond_with     nosdlgui                # do not use SDL gui (use X11 instead)
11 %bcond_with     gcc4                    # use gcc4 patches (broke build on gcc33)
12 %bcond_without  dist_kernel             # without distribution kernel
13 %bcond_with     kernel                  # build kqemu kernel modules
14 %bcond_without  smp                     # don't build SMP module
15 %bcond_without  userspace               # don't build userspace utilities
16 #
17 %define _kqemu_version  1.3.0pre9
18 %define         _rel    0.4
19 Summary:        QEMU CPU Emulator
20 Summary(pl):    QEMU - emulator procesora
21 Name:           qemu
22 Version:        0.8.2
23 Release:        %{_rel}%{?with_kqemu:k}
24 License:        GPL
25 Group:          Applications/Emulators
26 #Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
27 Source0:        http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
28 # Source0-md5:  5b3a89eb2f256a8a6f3bb07f7b3f1b07
29 Source1:        http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
30 # Source1-md5:  27888c3220844ad360a6a23345fa1bcb
31 Patch0:         %{name}-nostatic.patch
32 Patch1:         %{name}-cc.patch
33 Patch2:         %{name}-longjmp.patch
34 Patch3:         %{name}-dot.patch
35 Patch4:         %{name}-gcc4_x86.patch
36 Patch5:         %{name}-gcc4_ppc.patch
37 Patch6:         %{name}-nosdlgui.patch
38 Patch7:         %{name}-ifup.patch
39 URL:            http://fabrice.bellard.free.fr/qemu/
40 BuildRequires:  SDL-devel >= 1.2.1
41 BuildRequires:  alsa-lib-devel
42 %{!?with_gcc4:BuildRequires:    gcc < 5:4.0}
43 %if %{with kqemu} && %{with dist_kernel}
44 BuildRequires:  kernel%{_alt_kernel}-module-build >= 3:2.6.7
45 %endif
46 BuildRequires:  perl-tools-pod
47 BuildRequires:  rpmbuild(macros) >= 1.326
48 BuildRequires:  tetex
49 BuildRequires:  sed >= 4.0
50 Requires:       SDL >= 1.2.1
51 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
52 ExclusiveArch:  %{ix86} %{x8664} %{!?with_kqemu:ppc}
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 # some SPARC boot image in ELF format
56 %define         _noautostrip    .*%{_datadir}/qemu/openbios-sparc32
57
58 %description
59 QEMU is a FAST! processor emulator. By using dynamic translation it
60 achieves a reasonnable speed while being easy to port on new host
61 CPUs. QEMU has two operating modes:
62
63 - User mode emulation. In this mode, QEMU can launch Linux processes
64   compiled for one CPU on another CPU. Linux system calls are converted
65   because of endianness and 32/64 bit mismatches. Wine (Windows
66   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
67
68 - Full system emulation. In this mode, QEMU emulates a full system,
69   including a processor and various peripherials. It can also be used to
70   provide virtual hosting of several virtual PC on a single server.
71
72 %description -l pl
73 QEMU to szybki(!) emulator procesora. Poprzez u¿ycie dynamicznego
74 t³umaczenia osi±ga rozs±dn± szybko¶æ i jest ³atwy do przeportowania,
75 aby dzia³a³ na kolejnych procesorach. QEMU ma dwa tryby pracy:
76
77 - Emulacja trybu u¿ytkownika. W tym trybie QEMU mo¿e uruchamiaæ
78   procesy linuksowe skompilowane dla jednego procesora na innym
79   procesorze. Linuksowe wywo³ania systemowe s± t³umaczone ze wzglêdu na
80   niezgodno¶æ kolejno¶ci bajtów w s³owie i 32/64-bitowego rozmiaru
81   s³owa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to g³ówne
82   cele QEMU.
83
84 - Pe³na emulacja systemu. W tym trybie QEMU emuluje ca³y system,
85   w³±czaj±c w to procesor i ró¿ne urz±dzenia peryferyjne. Mo¿e byæ tak¿e
86   u¿ywane do wirtualnego hostowania kilku wirtualnych pecetów na
87   pojedynczym serwerze.
88
89 %package -n kernel%{_alt_kernel}-misc-kqemu
90 Summary:        kqemu - kernel module
91 Summary(pl):    kqemu - modu³ j±dra
92 Version:        %{_kqemu_version}
93 Release:        %{_rel}@%{_kernel_ver_str}
94 Group:          Base/Kernel
95 %{?with_dist_kernel:%requires_releq_kernel_up}
96 License:        Free to use, non-distributable
97 Requires(post,postun):  /sbin/depmod
98 Requires:       module-init-tools >= 3.2.2-2
99
100 %description -n kernel%{_alt_kernel}-misc-kqemu
101 kqemu - kernel module.
102
103 %description -n kernel%{_alt_kernel}-misc-kqemu -l pl
104 kqemu - modu³ j±dra.
105
106 %package -n kernel%{_alt_kernel}-smp-misc-kqemu
107 Summary:        kqemu - SMP kernel module
108 Summary(pl):    kqemu - modu³ j±dra SMP
109 Version:        %{_kqemu_version}
110 Release:        %{_rel}@%{_kernel_ver_str}
111 Group:          Base/Kernel
112 %{?with_dist_kernel:%requires_releq_kernel_smp}
113 License:        Free to use, non-distributable
114 Requires(post,postun):  /sbin/depmod
115 Requires:       module-init-tools >= 3.2.2-2
116
117 %description -n kernel%{_alt_kernel}-smp-misc-kqemu
118 kqemu - SMP kernel module.
119
120 %description -n kernel%{_alt_kernel}-smp-misc-kqemu -l pl
121 kqemu - modu³ j±dra SMP.
122
123 %prep
124 %setup -q %{?with_kernel:-a1}
125 %patch0 -p1
126 %patch1 -p1
127 %patch2 -p1
128 %patch3 -p1
129 %if %{with gcc4}
130 %patch4 -p0
131 %patch5 -p1
132 %endif
133 %{?with_nosdlgui:%patch6 -p1}
134 %patch7 -p1
135
136 %{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
137 %{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
138
139 # cannot use optflags on x86 - they cause "no register to spill" errors
140 %if %{with cflags_passing}
141 %{__sed} -i -e 's/-Wall -O2 -g/-Wall %{rpmcflags}/' Makefile Makefile.target
142 %else
143 %{__sed} -i 's/-Wall -O2 -g/-Wall -O2/' Makefile Makefile.target
144 %endif
145
146 %if %{with kernel}
147 echo -n > kqemu-%{_kqemu_version}/install.sh
148
149 cat <<'EOF' > modprobe.conf
150 # enable dynamic major
151 options kqemu major=0
152 # for autoloading from static dev
153 #alias char-major-250 kqemu
154 EOF
155
156 cat <<'EOF' > udev.conf
157 KERNEL=="kqemu", NAME="%k", MODE="0666"
158 EOF
159 %endif
160
161 %build
162 %if %{with kernel}
163 cd kqemu-%{_kqemu_version}
164
165 mv -f kqemu-mod-i386.o{,.bin}
166 mv -f kqemu-mod-x86_64.o{,.bin}
167 mv -f kqemu-linux.c{,.orig}
168 cat > Makefile <<'EOF'
169 obj-m := kqemu.o
170 kqemu-objs:= kqemu-linux.o kqemu-mod.o
171
172 $(obj)/kqemu-mod.o: $(src)/kqemu-mod-$(ARCH).o.bin
173         cp $< $@
174 EOF
175
176 %build_kernel_modules -m kqemu <<'EOF'
177 if grep -q "CONFIG_PREEMPT_RT" o/.config; then
178         sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
179                 kqemu-linux.c.orig > kqemu-linux.c
180 else
181         cat kqemu-linux.c.orig > kqemu-linux.c
182 fi
183 EOF
184 cd -
185 %endif
186
187 %if %{with userspace}
188 # --extra-cflags don't work (overridden by CFLAGS in Makefile*)
189 # they can be passed if the cflags_passing bcond is used
190 ./configure \
191         --prefix=%{_prefix} \
192         --cc="%{__cc}" \
193         --host-cc="%{__cc}" \
194         --make="%{__make}" \
195 %if %{with kqemu}
196         --kernel-path=%{_kernelsrcdir} \
197 %else
198         --disable-kqemu \
199 %endif
200         %{?with_gcc4:--disable-gcc-check} \
201         --enable-alsa \
202         --interp-prefix=%{_libdir}/%{name}
203 %{__make}
204 %endif
205
206 %install
207 rm -rf $RPM_BUILD_ROOT
208
209 %if %{with userspace}
210 %{__make} install \
211         DESTDIR=$RPM_BUILD_ROOT
212
213 install -d $RPM_BUILD_ROOT/sbin
214 cat <<'EOF' > $RPM_BUILD_ROOT/sbin/qemu-ifup
215 #!/bin/sh
216 if [ -f /etc/sysconfig/qemu ]; then
217         . /etc/sysconfig/qemu
218 fi
219 # of course this will work only for one interface. a lot possible to involve
220 sudo /sbin/ifconfig $1 ${INTERFACE_ADDR:-172.20.0.1}
221 EOF
222 %endif
223
224 %if %{with kernel}
225 %install_kernel_modules -m kqemu-%{_kqemu_version}/kqemu -d misc
226 install -d $RPM_BUILD_ROOT/etc/{modprobe.d/%{_kernel_ver}{,smp},udev/rules.d}
227 install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}/kqemu.conf
228 %if %{with smp} && %{with dist_kernel}
229 install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}smp/kqemu.conf
230 %endif
231 install udev.conf $RPM_BUILD_ROOT/etc/udev/rules.d/kqemu.rules
232 %endif
233
234 # already packaged
235 rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
236
237 %clean
238 rm -rf $RPM_BUILD_ROOT
239
240 %if %{with kernel}
241 %post
242 %banner %{name} -e <<EOF
243 To enable qemu accelerator (kqemu), the kqemu kernel module must be loaded:
244 modprobe kqemu
245 EOF
246 %endif
247
248 %post   -n kernel%{_alt_kernel}-misc-kqemu
249 %depmod %{_kernel_ver}
250
251 %postun -n kernel%{_alt_kernel}-misc-kqemu
252 %depmod %{_kernel_ver}
253
254 %post   -n kernel%{_alt_kernel}-smp-misc-kqemu
255 %depmod %{_kernel_ver}smp
256
257 %postun -n kernel%{_alt_kernel}-smp-misc-kqemu
258 %depmod %{_kernel_ver}smp
259
260 %if %{with userspace}
261 %files
262 %defattr(644,root,root,755)
263 %doc README qemu-doc.html qemu-tech.html
264 %attr(755,root,root) /sbin/qemu-ifup
265 %attr(755,root,root) %{_bindir}/*
266 %{_datadir}/qemu
267 %{_mandir}/man1/qemu.1*
268 %{_mandir}/man1/qemu-img.1*
269 %endif
270
271 %if %{with kernel}
272 %files -n kernel%{_alt_kernel}-misc-kqemu
273 %defattr(644,root,root,755)
274 %doc kqemu-%{_kqemu_version}/LICENSE
275 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
276 %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}/kqemu.conf
277 /lib/modules/%{_kernel_ver}/misc/kqemu.ko*
278
279 %if %{with smp} && %{with dist_kernel}
280 %files -n kernel%{_alt_kernel}-smp-misc-kqemu
281 %defattr(644,root,root,755)
282 %doc kqemu-%{_kqemu_version}/LICENSE
283 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
284 %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}smp/kqemu.conf
285 /lib/modules/%{_kernel_ver}smp/misc/kqemu.ko*
286 %endif
287 %endif
This page took 0.073871 seconds and 2 git commands to generate.