]> git.pld-linux.org Git - SPECS.git/blob - qedje.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / qedje.spec
1
2 %define         qtver   4.5.0
3
4 Summary:        qedje
5 Summary(pl.UTF-8):      qedje
6 Name:           qedje
7 Version:        0.4.0
8 Release:        0.git.5
9 License:        GPL v2
10 Group:          X11/Libraries
11 #Source0:       http://dev.openbossa.org/%{name}/downloads/source/%{name}/%{name}-%{version}.tar.gz
12 Source0:        %{name}-%{version}-git.tar.gz
13 # Source0-md5:  062a73e4ce76ae4513aa772504db572d
14 URL:            http://dev.openbossa.org/trac/qedje
15 Patch0:         %{name}-pc.patch
16 BuildRequires:  QtCore-devel >= %{qtver}
17 BuildRequires:  QtGui-devel >= %{qtver}
18 BuildRequires:  cmake
19 BuildRequires:  eet-devel
20 BuildRequires:  pkgconfig
21 BuildRequires:  qt4-build
22 BuildRequires:  qt4-qmake >= %{qtver}
23 BuildRequires:  qzion-devel >= 0.4.0
24 BuildRequires:  rpmbuild(macros) >= 1.164
25 BuildRequires:  sip-PyQt4
26 Requires(post,postun):  /sbin/ldconfig
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 qedje
31
32 %description -l pl.UTF-8
33 qedje
34
35 %package devel
36 Summary:        Header files for qedje library
37 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki qedje
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 Header files for qedje library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe biblioteki qedje.
46
47 %prep
48 %setup -q -n %{name}-%{version}-git
49 %patch0 -p0
50
51 %build
52 install -d build
53 cd build
54 %cmake \
55         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
56         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
57 %if "%{_lib}" == "lib64"
58         -DLIB_SUFFIX=64 \
59 %endif
60         ../
61
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} -C build install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post   -p /sbin/ldconfig
74 %postun -p /sbin/ldconfig
75
76 %files
77 %defattr(644,root,root,755)
78 %attr(755,root,root) %{_bindir}/qedje_viewer
79 %attr(755,root,root) %{_libdir}/libqedje.so.*.*.*
80 %attr(755,root,root) %ghost %{_libdir}/libqedje.so.?
81
82 %files devel
83 %defattr(644,root,root,755)
84 %attr(755,root,root) %{_libdir}/libqedje.so
85 %{_includedir}/*.h
86 %{_pkgconfigdir}/qedje.pc
This page took 0.740934 seconds and 3 git commands to generate.