]> git.pld-linux.org Git - SPECS.git/blob - qca1.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / qca1.spec
1 %define rname   qca
2 Summary:        Qt Cryptographic Architecture (QCA) Library
3 Summary(pl.UTF-8):      Biblioteka Qt Cryptographic Architecture (QCA)
4 Name:           qca1
5 Version:        1.0
6 Release:        1
7 License:        LGPL v2.1
8 Group:          Libraries
9 Source0:        http://delta.affinix.com/qca/%{rname}-%{version}.tar.bz2
10 # Source0-md5:  ee44022eb0e5b8b5df64c62630f6e6b6
11 Patch0:         %{rname}-libs.patch
12 URL:            http://delta.affinix.com/qca/
13 BuildRequires:  libstdc++-devel
14 BuildRequires:  openssl-devel >= 0.9.7d
15 BuildRequires:  qmake
16 BuildRequires:  qt-devel >= 6:3.1.2
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Qt Cryptographic Architecture (QCA) Library.
21
22 %description -l pl.UTF-8
23 Biblioteka Qt Cryptographic Architecture (QCA).
24
25 %package devel
26 Summary:        Qt Cryptographic Architecture (QCA) Library - development files
27 Summary(pl.UTF-8):      Biblioteka Qt Cryptographic Architecture (QCA) - pliki dla programistów
28 Group:          Development/Libraries
29 Requires:       %{name} = %{version}-%{release}
30 Requires:       qt-devel >= 6:3.1.2
31
32 %description devel
33 Qt Cryptographic Architecture (QCA) Library - development files.
34
35 %description devel -l pl.UTF-8
36 Biblioteka Qt Cryptographic Architecture (QCA) - pliki dla programistów.
37
38 %prep
39 %setup -q -n %{rname}-%{version}
40 %patch0 -p1
41
42 %build
43 export QTDIR=%{_prefix}
44 export LIBDIR=%{_libdir}
45
46 ./configure \
47         --prefix=%{_prefix} \
48 # probably could be done but breaks the build now:
49 #
50 #qmake %{name}.pro \
51 #       QMAKE_CXX="%{__cxx}" \
52 #       QMAKE_LINK="%{__cxx}" \
53 #       QMAKE_CXXFLAGS_RELEASE="%{rpmcflags}" \
54 #       QMAKE_RPATH=
55
56 %{__make}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         INSTALL_ROOT=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post   -p /sbin/ldconfig
68 %postun -p /sbin/ldconfig
69
70 %files
71 %defattr(644,root,root,755)
72 %doc README
73 %attr(755,root,root) %{_libdir}/*.so.*.*.*
74
75 %files devel
76 %defattr(644,root,root,755)
77 %attr(755,root,root) %{_libdir}/*.so
78 %{_includedir}/qca.h
This page took 0.349277 seconds and 3 git commands to generate.