]> git.pld-linux.org Git - SPECS.git/blob - qbittorrent.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / qbittorrent.spec
1 #
2 # Conditional build:
3 %bcond_with     qsa             # system QtSingleApplication
4
5 %define         qtver   5.15.2
6 %define         rasterbar_ver   2:2.0.9
7 Summary:        qbittorrent - Qt-based torrent client
8 Summary(hu.UTF-8):      qbittorrent - Qt-alapĂș torrent kliens
9 Summary(pl.UTF-8):      qbittorrent - graficzny klient torrenta oparty na Qt
10 Name:           qbittorrent
11 Version:        4.6.4
12 Release:        1
13 License:        GPL v2+
14 Group:          X11/Applications
15 Source0:        http://downloads.sourceforge.net/qbittorrent/%{name}-%{version}.tar.xz
16 # Source0-md5:  ffc528cbdf1ab4ff40a51753e5e9b030
17 URL:            http://qbittorrent.sourceforge.net/
18 BuildRequires:  GeoIP-devel
19 BuildRequires:  Qt5Concurrent-devel >= %{qtver}
20 BuildRequires:  Qt5Core-devel >= %{qtver}
21 BuildRequires:  Qt5DBus-devel >= %{qtver}
22 BuildRequires:  Qt5Gui-devel >= %{qtver}
23 BuildRequires:  Qt5Network-devel >= %{qtver}
24 %{?with_qsa:BuildRequires:      Qt5SingleApplication-devel >= 2.6.1-4}
25 BuildRequires:  Qt5Sql-devel >= %{qtver}
26 BuildRequires:  Qt5Svg-devel >= %{qtver}
27 BuildRequires:  Qt5Xml-devel >= %{qtver}
28 BuildRequires:  boost-devel >= 1.71
29 BuildRequires:  libnotify-devel >= 0.4.2
30 BuildRequires:  libstdc++-devel >= 6:5
31 BuildRequires:  libtorrent-rasterbar-devel >= %{rasterbar_ver}
32 BuildRequires:  openssl-devel >= 1.1.1
33 BuildRequires:  pkgconfig >= 1:0.23
34 BuildRequires:  qt5-build >= %{qtver}
35 BuildRequires:  qt5-linguist >= %{qtver}
36 BuildRequires:  qt5-qmake >= %{qtver}
37 BuildRequires:  rpmbuild(macros) >= 1.129
38 BuildRequires:  which
39 BuildRequires:  zlib >= 1.2.11
40 Requires:       desktop-file-utils
41 Requires:       gtk-update-icon-cache
42 Requires:       hicolor-icon-theme
43 Requires:       libtorrent-rasterbar >= %{rasterbar_ver}
44 Requires:       python3 >= 1:3.7
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 qTorrent - Qt-based torrent client.
49
50 %description -l hu.UTF-8
51 qBittorrent - Qt-alapĂș torrent kliens
52
53 %description -l pl.UTF-8
54 qTorrent - graficzny klient torrenta oparty na Qt.
55
56 %prep
57 %setup -q
58
59 %if %{with qsa}
60 %{__rm} -r src/app/qtsingleapplication
61 %endif
62
63 %build
64 %{__aclocal}
65 %{__autoconf}
66 %configure \
67         --verbose \
68         --prefix=%{_prefix} \
69         --with-boost-libdir=%{_libdir} \
70         %{?with_qsa:--with-qtsingleapplication=system}
71
72 %{__make} \
73         CXX="%{__cxx}"
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 %{__make} install \
78         INSTALL_ROOT=$RPM_BUILD_ROOT
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post
84 %update_desktop_database
85 %update_icon_cache hicolor
86
87 %postun
88 %update_desktop_database
89 %update_icon_cache hicolor
90
91 %files
92 %defattr(644,root,root,755)
93 %doc AUTHORS Changelog
94 %attr(755,root,root) %{_bindir}/qbittorrent
95 %{_datadir}/metainfo/org.qbittorrent.qBittorrent.appdata.xml
96 %{_mandir}/man1/qbittorrent.1*
97 %{_desktopdir}/org.qbittorrent.qBittorrent.desktop
98 %{_iconsdir}/hicolor/*x*/apps/qbittorrent.png
99 %{_iconsdir}/hicolor/*x*/status/qbittorrent-tray.png
100 %{_iconsdir}/hicolor/scalable/apps/qbittorrent.svg
101 %{_iconsdir}/hicolor/scalable/status/qbittorrent-tray*.svg
This page took 0.084341 seconds and 3 git commands to generate.