]> git.pld-linux.org Git - packages/python3.git/blob - python3.spec
- install section fixes for python 3.2
[packages/python3.git] / python3.spec
1 #
2 # TODO:
3 # - fix tests
4 # - check unpackaged files
5
6 # Conditional build:
7 %bcond_with     info                    # info pages (requires emacs)
8 %bcond_without  tkinter                 # disables tkinter module building
9 %bcond_without  tests                   # disables Python testing
10 %bcond_with     verbose_tests           # runs tests in verbose mode
11 #
12 # tests which will not work on 64-bit platforms
13 %define         no64bit_tests   test_audioop test_rgbimg test_imageop
14 # tests which may fail because of builder environment limitations (no /proc or /dev/pts)
15 %define         nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
16 # tests which fail because of some unknown/unresolved reason (this list should be empty)
17 %define         broken_tests test_httpservers test_distutils test_cmd_line test_pydoc test_telnetlib test_zlib
18
19 %define beta            %{nil}
20
21 %define py_ver          3.2
22 %define py_prefix       %{_prefix}
23 %define py_libdir       %{py_prefix}/%{_lib}/python%{py_ver}
24 %define py_incdir       %{_includedir}/python%{py_ver}
25 %define py_sitedir      %{py_libdir}/site-packages
26 %define py_dyndir       %{py_libdir}/lib-dynload
27
28 Summary:        Very high level scripting language with X interface
29 Summary(es.UTF-8):      Lenguaje script de alto nivel con interfaz X
30 Summary(fr.UTF-8):      Langage de script de très haut niveau avec interface X
31 Summary(pl.UTF-8):      Python - język obiektowy wysokiego poziomu
32 Summary(pt_BR.UTF-8):   Linguagem de programação interpretada de alto nível
33 Summary(ru.UTF-8):      Язык программирования очень высокого уровня с X-интерфейсом
34 Summary(tr.UTF-8):      X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
35 Summary(uk.UTF-8):      Мова програмування дуже високого рівня з X-інтерфейсом
36 Name:           python3
37 Version:        %{py_ver}
38 #Release:       0.%{beta}.1
39 Release:        0.1
40 Epoch:          1
41 License:        PSF
42 Group:          Applications
43 Source0:        http://www.python.org/ftp/python/%{version}/Python-%{version}%{beta}.tar.bz2
44 # Source0-md5:  92e94b5b6652b96349d6362b8337811d
45 Patch0:         %{name}-pythonpath.patch
46 Patch1:         %{name}-ac_fixes.patch
47 Patch2:         %{name}-lib64.patch
48 Patch3:         %{name}-noarch_to_datadir.patch
49 Patch4:         %{name}-cast-fix.patch
50 URL:            http://www.python.org/
51 BuildRequires:  autoconf
52 BuildRequires:  bluez-libs-devel
53 BuildRequires:  bzip2-devel
54 BuildRequires:  db-devel >= 4
55 %{?with_info:BuildRequires:     emacs >= 21}
56 BuildRequires:  expat-devel >= 1:1.95.7
57 BuildRequires:  file
58 BuildRequires:  gdbm-devel >= 1.8.3
59 BuildRequires:  gmp-devel >= 4.0
60 BuildRequires:  libffi-devel
61 BuildRequires:  libstdc++-devel
62 BuildRequires:  ncurses-ext-devel >= 5.2
63 BuildRequires:  openssl-devel >= 0.9.8
64 BuildRequires:  readline-devel >= 5.0
65 BuildRequires:  rpm-pythonprov
66 BuildRequires:  sed >= 4.0
67 BuildRequires:  sqlite3-devel >= 3.3.5
68 %{?with_info:BuildRequires:     tetex-makeindex}
69 %{?with_tkinter:BuildRequires:  tix-devel >= 1:8.1.4-4}
70 %{?with_tkinter:BuildRequires:  tk-devel >= 8.4.3}
71 BuildRequires:  zlib-devel
72 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %define         specflags_ppc   -D__ppc__=1
76 %define         specflags_ppc64 -D__ppc64__=1
77
78 %if %{with verbose_tests}
79 %define test_flags -v -l -x
80 %else
81 %define test_flags -w -l -x
82 %endif
83
84 %ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
85 %define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
86 %else
87 %define test_list %{nobuilder_tests} %{broken_tests}
88 %endif
89
90 %ifarch sparc
91 %define test_list %{nobuilder_tests} %{broken_tests} test_fcntl test_ioctl
92 %endif
93
94 %description
95 Python is an interpreted, interactive, object-oriented programming
96 language. It incorporates modules, exceptions, dynamic typing, very
97 high level dynamic data types, and classes. Python combines remarkable
98 power with very clear syntax. It has interfaces to many system calls
99 and libraries, as well as to various window systems, and is extensible
100 in C or C++. It is also usable as an extension language for
101 applications that need a programmable interface. Finally, Python is
102 portable: it runs on many brands of UNIX, on the Mac, and on PCs under
103 MS-DOS, Windows, Windows NT, and OS/2.
104
105 This package contains the Python binary.
106
107 %description -l de.UTF-8
108 Python ist eine interpretierte, interaktive, objektorientierte
109 Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
110 Python enthält Module, Klassen, Exceptions, High-Level dynamische
111 Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
112 zu vielen Systemaufrufen und Libraries, sowie verschiedene
113 Fenstersysteme (X11, Motif, Tk, Mac und MFC)
114
115 Programmierer können neue built-in-Module für Python in C oder C++
116 schreiben. Python kann auch als Erweiterungssprache für Applikationen
117 benutzt werden, die ein programmierbares Interface brauchen. Dieses
118 Paket enthält die meisten Standard-Python-Module, und Module zum
119 Ansprechen von Tix (Tk-widget set) und RPM.
120
121 %description -l es.UTF-8
122 Python es un lenguaje de scripts interpretado orientado a objetos.
123 Contiene soporte para carga dinámica de objetos, clases, módulos y
124 excepciones.
125
126 Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
127 través de código C, tornando Python fácil de usar en ambientes
128 particulares/personalizados. Este paquete Python incluye la mayoría de
129 los módulos padrón Python, junto con módulos para crear interfaces
130 para el conjunto de componentes Tix para Tk y RPM.
131
132 %description -l fr.UTF-8
133 Python est un langage de script interprété et orienté objet. Il gère
134 le chargement dynamique des objets, les classes, les modules et les
135 exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
136 avec du code C est simple, ce qui rend Python facile à utiliser dans
137 des configs personnalisées.
138
139 Ce paquetage Python contient la plupart des modules Python standards,
140 ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
141 et RPM.
142
143 %description -l pl.UTF-8
144 Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
145 językiem programowania. Jest modularny, obsługuje wyjątki, dynamiczne
146 typy, zaawansowane dynamiczne struktury danych i klasy. Python łączy w
147 sobie duże możliwości i przejrzystą składnię. Posiada interfejsy do
148 wielu wywołań systemowych i bibliotek, w tym również do różnych
149 bibliotek okienkowych. Możliwości jego można jeszcze rozszerzać
150 poprzez odpowiednie moduły pisane w C lub C++. Python może być również
151 użyty jako element aplikacji, którym potrzebny jest interpreter do
152 skryptów. I wreszcie, Python jest wieloplatformowy, działa na wielu
153 odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
154 OS/2.
155
156 Ten pakiet zawiera binarkę Pythona.
157
158 %description -l pt_BR.UTF-8
159 Python é uma linguagem de scripts interpretada orientada a objetos.
160 Contém suporte para carga dinâmica de objetos, classes, módulos e
161 exceções. Adicionar interfaces para novos sistemas de biblioteca
162 através de código C é simples, tornando Python fácil de usar em
163 ambientes particulares/personalizados.
164
165 Este pacote Python inclui a maioria do módulos padrão Python, junto
166 com módulos para interfaceamento para o conjunto de componentes Tix
167 para Tk e RPM.
168
169 %description -l ru.UTF-8
170 Python - это интерпретируемый, объектно-ориентированный язык
171 программирования. Он поддерживает динамическую загрузку объектов,
172 классы, модули и обработку исключительных ситуаций (exceptions).
173 Простота добавления интерфейсов к новым системным библиотекам через
174 код на языке C делает Python хорошим выбором для использования в
175 специальных конфигурациях.
176
177 %description -l tr.UTF-8
178 Python, nesneye yönelik bir kabuk yorumlayıcıdır. Nesnelerin,
179 sınıfların, modüllerin ve aykırı durumların dinamik yüklenmelerine
180 destek verir. C koduyla birlikte kullanımı son derece kolaydır. Bu
181 paket, standart Python birimlerinin çoğunun yanısıra Tk ve RPM için
182 arayüz birimlerini de içerir.
183
184 %description -l uk.UTF-8
185 Python - це інтерпретована, об'єктно-орієнтована мова програмування.
186 Він підтримує динамічну загрузку об'єктів, класи, модулі та обробку
187 виключних ситуацій (exceptions). Простота додавання інтерфейсів для
188 нових системних бібліотек через код на мові C робить Python добрим
189 вибором для використання в спеціальних конфігураціях.
190
191 %package libs
192 Summary:        Python library
193 Summary(pl.UTF-8):      Biblioteka języka Python
194 Group:          Libraries/Python
195 # broken detection in rpm/pythondeps.sh
196 Provides:       python(abi) = %{py_ver}
197 # for compatibility with existing Ac packages
198 Provides:       python(bytecode) = %{py_ver}
199 %{!?with_info:Obsoletes:        python3-doc-info}
200
201 %description libs
202 Python shared library and very essental modules for Python binary.
203
204 %description libs -l pl.UTF-8
205 Biblioteka współdzielona języka Python oraz bardzo podstawowe moduły
206 dla Pythona.
207
208 %package modules
209 Summary:        Python modules
210 Summary(pl.UTF-8):      Moduły języka Python
211 Group:          Libraries/Python
212 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
213 Obsoletes:      python3-modules-sqlite
214
215 %description modules
216 Python officially distributed modules.
217
218 %description modules -l pl.UTF-8
219 Oficjalnie rozprowadzane moduły języka Python.
220
221 %package -n pydoc3
222 Summary:        Python interactive module documentation access support
223 Summary(pl.UTF-8):      Interaktywne korzystanie z dokumentacji modułów języka Python
224 Group:          Applications
225 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
226
227 %description -n pydoc3
228 Python interactive module documentation access support.
229
230 %description -n pydoc3 -l pl.UTF-8
231 Interaktywne korzystanie z dokumentacji modułów języka Python.
232
233 %package -n idle3
234 Summary:        IDE for Python language
235 Summary(pl.UTF-8):      IDE dla języka Python
236 Group:          Applications
237 Requires:       %{name}-tkinter = %{epoch}:%{version}-%{release}
238
239 %description -n idle3
240 IDE for Python language.
241
242 %description -n idle3 -l pl.UTF-8
243 IDE dla języka Python.
244
245 %package devel
246 Summary:        Libraries and header files for building python code
247 Summary(de.UTF-8):      Libraries und Header-Dateien zum Erstellen von Python-Code
248 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para construir programas en python
249 Summary(fr.UTF-8):      Bibliothèques et en-têtes pour construire du code python
250 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki Pythona
251 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para o Python
252 Summary(ru.UTF-8):      Библиотеки и хедеры для построения кода на языке Python
253 Summary(tr.UTF-8):      Python ile geliştirme yapmak için gerekli dosyalar
254 Summary(uk.UTF-8):      Бібліотеки та хедери для програмування на мові Python
255 Group:          Development/Languages/Python
256 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
257
258 %description devel
259 The Python interpreter is relatively easy to extend with dynamically
260 loaded extensions and to embed in other programs. This package
261 contains the header files and libraries which are needed to do both of
262 these tasks.
263
264 %description devel -l de.UTF-8
265 Der Python-Interpretierer ist relativ einfach anhand von dynamisch
266 ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
267 integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
268 die für beide Aufgaben erforderlich sind.
269
270 %description devel -l es.UTF-8
271 El interpretador Python permite incluir con facilidad extensiones
272 cargadas dinámicamente. Python es también fácil de ser empotrado en
273 otros programas. Este paquete contiene los archivos de inclusión y
274 bibliotecas necesarios para estas dos tareas.
275
276 %description devel -l fr.UTF-8
277 L'interpréteur Python est relativement facile à étendre avec des
278 extensions chargées dynamiquement et à insérer dans d'autres
279 programmes. Ce paquetage contient les en-têtes et les bibliothèques
280 nécessaires à ces deux tâches.
281
282 %description devel -l pl.UTF-8
283 Interpreter Pythona jest w miarę łatwy do rozszerzania przy pomocy
284 dynamicznie ładowanych rozszerzeń napisanych w C lub C++ oraz
285 osadzania w innych programach. Ten pakiet zawiera pliki nagłówkowe i
286 wszystko inne co potrzebne do tych celów.
287
288 %description devel -l pt_BR.UTF-8
289 O interpretador Python permite incluir com facilidade extensões
290 carregadas dinamicamente. Python é também fácil de ser embutido em
291 outros programas. Este pacote contém os arquivos de inclusão e
292 bibliotecas necessários para estas duas tarefas.
293
294 %description devel -l ru.UTF-8
295 Интерпретатор Python относительно легко расширяется при помощи
296 динамически загружаемых расширений и встраивается в другие программы.
297 Этот пакет содержит хедеры и библиотеки, необходимые для обеих этих
298 задач.
299
300 %description devel -l tr.UTF-8
301 Bu paket, Python ile geliştirme yapılabilmesi için gerekli başlık
302 dosyalarını ve kitaplıkları içerir.
303
304 %description devel -l uk.UTF-8
305 Інтерпретатор Python відносно легко розширюється за допомогою
306 розширень з динамічною загрузкою та вбудовується в інші програми. Цей
307 пакет містить хедери та бібліотеки, необхідні для обох цих задач.
308
309 %package devel-src
310 Summary:        Python module sources
311 Summary(pl.UTF-8):      Pliki źródłowe modułów Pythona
312 Group:          Development/Languages/Python
313 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
314
315 %description devel-src
316 Python module sources.
317
318 %description devel-src -l pl.UTF-8
319 Pliki źródłowe modułów Pythona.
320
321 %package devel-tools
322 Summary:        Python development tools
323 Summary(pl.UTF-8):      Narzędzia programistyczne języka Python
324 Group:          Development/Languages/Python
325 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
326
327 %description devel-tools
328 Python development tools such as profilers and debugger.
329
330 %description devel-tools -l pl.UTF-8
331 Narzędzia programistyczne języka Python takie jak profiler oraz
332 debugger.
333
334 %package 2to3
335 Summary:        Automated Python 2 to 3 code translation
336 Summary(pl.UTF-8):      Automatyczne tłumaczenie kody Pythona 2 do 3
337 Group:          Development/Languages/Pythona
338
339 %description 2to3
340 2to3 is a Python program that reads Python 2.x source code and applies a series
341 of fixers to transform it into valid Python 3.x code. The standard library
342 contains a rich set of fixers that will handle almost all code. 2to3 supporting
343 library lib2to3 is, however, a flexible and generic library, so it is possible
344 to write your own fixers for 2to3. lib2to3 could also be adapted to custom
345 applications in which Python code needs to be edited automatically.
346
347 %package static
348 Summary:        Static python library
349 Summary(pl.UTF-8):      Statyczna biblioteka Pythona
350 Group:          Development/Languages/Python
351 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
352
353 %description static
354 Static python library.
355
356 %description static -l pl.UTF-8
357 Statyczna biblioteka Pythona.
358
359 %package doc-info
360 Summary:        Documentation on Python in texinfo format
361 Summary(pl.UTF-8):      Dokumentacja do Pythona w formacie texinfo
362 Group:          Documentation
363
364 %description doc-info
365 Documentation on Python in texinfo format.
366
367 %description doc-info -l pl.UTF-8
368 Dokumentacja do Pythona w formacie texinfo.
369
370 %package tkinter
371 Summary:        Standard Python interface to the Tk GUI toolkit
372 Summary(de.UTF-8):      Grafische Tk-Schnittstelle für Python
373 Summary(es.UTF-8):      Interfaz de GUI Tk para Python
374 Summary(fr.UTF-8):      Interface graphique Tk pour Python
375 Summary(pl.UTF-8):      Standardowy interfejs Pythona do biblioteki Tk
376 Summary(pt_BR.UTF-8):   Interface GUI Tk para Phyton
377 Summary(tr.UTF-8):      Python için grafik kullanıcı arayüzü
378 Group:          Libraries/Python
379 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
380 Requires:       tcl >= 8.4.3
381 Requires:       tix >= 1:8.1.4-4
382 Requires:       tk >= 8.4.3
383
384 %description tkinter
385 Standard Python interface to the Tk GUI toolkit.
386
387 %description tkinter -l de.UTF-8
388 Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
389 vielen Konfigurations-Tools genutzt.
390
391 %description tkinter -l es.UTF-8
392 Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por muchas
393 herramientas de configuración.
394
395 %description tkinter -l fr.UTF-8
396 Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
397 beaucoup des outils de configuration.
398
399 %description tkinter -l pl.UTF-8
400 Standardowy interfejs Pythona do biblioteki Tk.
401
402 %description tkinter -l pt_BR.UTF-8
403 Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
404 muitas ferramentas de configuração.
405
406 %description tkinter -l ru.UTF-8
407 Графический интерфейс (GUI) для Python, построенный на Tcl/Tk.
408
409 %description tkinter -l tr.UTF-8
410 Python için Tcl/Tk'ye dayalı ve pek çok ayarlama aracı tarafından
411 kullanılan grafik bir arayüzdür.
412
413 %description tkinter -l uk.UTF-8
414 Графічний інтерфейс (GUI) для Python, побудований на Tcl/Tk.
415
416 %package examples
417 Summary:        Example programs in Python
418 Summary(pl.UTF-8):      Przykładowe programy w Pythonie
419 Group:          Development/Languages/Python
420
421 %description examples
422 Example programs in Python.
423
424 These are for Python 2.3.4, not %{version}.
425
426 %description examples -l pl.UTF-8
427 Przykładowe programy w Pythonie.
428
429 Przykłady te są dla Pythona 2.3.4, nie %{version}.
430
431 %prep
432 %setup -q -n Python-%{version}%{beta}
433 %patch0 -p1
434 %patch1 -p1
435 #%patch2 -p1
436 #%patch3 -p1
437 #%patch4 -p1
438
439 %build
440 sed -i -e 's#-ltermcap#-ltinfo#g' configure*
441 %{__autoconf}
442 CPPFLAGS="-I/usr/include/ncursesw %{rpmcppflags}"; export CPPFLAGS
443 %configure \
444         --with-cxx-main="%{__cxx}" \
445         --enable-shared \
446         --enable-ipv6 \
447         --with-dbmliborder=gdbm:bdb \
448         --with-wide-unicode \
449         --with-signal-module \
450         --with-tsc \
451         --with-threads \
452         --with-doc-strings \
453         --with-fpectl \
454         --with-system-ffi \
455         --with-computed-gotos \
456         LINKCC='$(PURIFY) $(CXX)' \
457         LDSHARED='$(CC) $(CFLAGS) -shared' \
458         BLDSHARED='$(CC) $(CFLAGS) -shared' \
459         LDFLAGS="%{rpmcflags} %{rpmldflags}"
460
461 %{__make} \
462         OPT="%{rpmcflags} -fno-caller-saves" 2>&1 | awk '
463 BEGIN { fail = 0; logmsg = ""; }
464 {
465         if ($0 ~ /\*\*\* WARNING:/) {
466                 fail = 1;
467                 logmsg = logmsg $0;
468         }
469         print $0;
470 }
471 END { if (fail) { print "\nPROBLEMS FOUND:"; print logmsg; exit(1); } }'
472
473 LC_ALL=C
474 export LC_ALL
475 %if %{with tests}
476 binlibdir=`echo build/lib.*`
477 %{__make} test \
478         TESTOPTS="%{test_flags} %{test_list}" \
479         TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:$binlibdir ./python -tt"
480 %endif
481
482 %install
483 rm -rf $RPM_BUILD_ROOT
484 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
485         $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1} \
486         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
487         $RPM_BUILD_ROOT%{_infodir} \
488         $RPM_BUILD_ROOT/etc/shrc.d
489
490 %{__make} install \
491         DESTDIR=$RPM_BUILD_ROOT
492
493 %if %{with info}
494 %{__make} -C Doc/info
495 install Doc/info/python*info* $RPM_BUILD_ROOT%{_infodir}
496 %endif
497
498 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
499 cp -a Tools $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
500
501 #
502 # create several useful aliases, such as timeit.py, profile.py, pdb.py, smtpd.py
503 #
504
505 # for python devel tools
506 for script in timeit profile pdb pstats; do
507     echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
508 done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
509
510 echo alias pygettext%{py_ver}.py='"pygettext%{py_ver}"' \
511         >> $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
512
513 sed 's/=/ /' \
514         < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh \
515         > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.csh
516
517 # for python modules
518 for script in smtpd webbrowser; do
519     echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
520 done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh
521
522 sed 's/=/ /' \
523         < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh \
524         > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.csh
525
526 # xgettext specific for Python code
527 #
528 # we will have two commands: pygettext.py (an alias) and pygettext;
529 # this way there are no import (which is impossible now) conflicts and
530 # pygettext.py is provided for compatibility
531 install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext%{py_ver}
532
533 # just to cut the noise, as they are not packaged (now)
534 # first tests
535 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/test
536 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/bsddb/test
537 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/test
538 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/distutils/tests
539 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/email/test
540 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/sqlite3/test
541 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/json/tests
542 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/lib2to3/tests
543 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/importlib/test
544 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/tkinter/test
545
546 # other files
547 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/plat-*/regen
548 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/macholib/fetch_macholib*
549 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/site-packages/README
550 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/distutils/command/wininst*.exe
551 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.bat
552 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.pyw
553 rm -rf $RPM_BUILD_ROOT%{_bindir}/smtpd.py
554 # already in %%doc
555 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/pdb.doc
556 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/LICENSE.txt
557
558 %clean
559 rm -rf $RPM_BUILD_ROOT
560
561 %post   libs -p /sbin/ldconfig
562 %postun libs -p /sbin/ldconfig
563
564 %post doc-info  -p      /sbin/postshell
565 -/usr/sbin/fix-info-dir -c %{_infodir}
566
567 %postun doc-info        -p      /sbin/postshell
568 -/usr/sbin/fix-info-dir -c %{_infodir}
569
570 %files
571 %defattr(644,root,root,755)
572 %attr(755,root,root) %{_bindir}/python%{py_ver}
573 %attr(755,root,root) %{_bindir}/python3
574 %{_mandir}/man1/python*.1*
575
576 %files modules
577 %defattr(644,root,root,755)
578 /etc/shrc.d/python*-modules*
579 %exclude %{py_scriptdir}/_abcoll.py[co]
580 %exclude %{py_scriptdir}/_weakrefset.py[co]
581 %exclude %{py_scriptdir}/abc.py[co]
582 %exclude %{py_scriptdir}/codecs.py[co]
583 %exclude %{py_scriptdir}/copyreg.py[co]
584 %exclude %{py_scriptdir}/genericpath.py[co]
585 %exclude %{py_scriptdir}/io.py[co]
586 %exclude %{py_scriptdir}/locale.py[co]
587 %exclude %{py_scriptdir}/posixpath.py[co]
588 %exclude %{py_scriptdir}/pdb.py[co]
589 %exclude %{py_scriptdir}/profile.py[co]
590 %exclude %{py_scriptdir}/pstats.py[co]
591 %exclude %{py_scriptdir}/pydoc.py[co]
592 %exclude %{py_scriptdir}/site.py[co]
593 %exclude %{py_scriptdir}/stat.py[co]
594 %exclude %{py_scriptdir}/timeit.py[co]
595 %exclude %{py_scriptdir}/os.py[co]
596 %exclude %{py_scriptdir}/encodings/*.py[co]
597 %exclude %{py_scriptdir}/types.py[co]
598
599 %{py_scriptdir}/*.py[co]
600
601 %{py_dyndir}/*.egg-info
602
603 #
604 # list .so modules to be sure that all of them are built
605 #
606
607 # modules below do not work on 64-bit architectures
608 # see Python README file for explanation
609 %ifnarch alpha ia64 ppc64 sparc64 %{x8664}
610 %attr(755,root,root) %{py_dyndir}/audioop.so
611 %endif
612
613 %attr(755,root,root) %{py_dyndir}/array.so
614 %attr(755,root,root) %{py_dyndir}/atexit.so
615 %attr(755,root,root) %{py_dyndir}/audioop.so
616 %attr(755,root,root) %{py_dyndir}/binascii.so
617 %attr(755,root,root) %{py_dyndir}/_bisect.so
618 %attr(755,root,root) %{py_dyndir}/bz2.so
619 %attr(755,root,root) %{py_dyndir}/cmath.so
620 %attr(755,root,root) %{py_dyndir}/_codecs_cn.so
621 %attr(755,root,root) %{py_dyndir}/_codecs_hk.so
622 %attr(755,root,root) %{py_dyndir}/_codecs_iso2022.so
623 %attr(755,root,root) %{py_dyndir}/_codecs_jp.so
624 %attr(755,root,root) %{py_dyndir}/_codecs_kr.so
625 %attr(755,root,root) %{py_dyndir}/_codecs_tw.so
626 %attr(755,root,root) %{py_dyndir}/_collections.so
627 %attr(755,root,root) %{py_dyndir}/crypt.so
628 %attr(755,root,root) %{py_dyndir}/_csv.so
629 %attr(755,root,root) %{py_dyndir}/_ctypes*.so
630 %attr(755,root,root) %{py_dyndir}/_curses_panel.so
631 %attr(755,root,root) %{py_dyndir}/_curses.so
632 %attr(755,root,root) %{py_dyndir}/datetime.so
633 %attr(755,root,root) %{py_dyndir}/_elementtree.so
634 #%attr(755,root,root) %{py_dyndir}/_functools.so
635 %attr(755,root,root) %{py_dyndir}/_hashlib.so
636 %attr(755,root,root) %{py_dyndir}/_heapq.so
637 %attr(755,root,root) %{py_dyndir}/_json.so
638 #%attr(755,root,root) %{py_dyndir}/_locale.so
639 %attr(755,root,root) %{py_dyndir}/_lsprof.so
640 %attr(755,root,root) %{py_dyndir}/_multibytecodec.so
641 %attr(755,root,root) %{py_dyndir}/_multiprocessing.so
642 %attr(755,root,root) %{py_dyndir}/_pickle.so
643 %attr(755,root,root) %{py_dyndir}/_random.so
644 %attr(755,root,root) %{py_dyndir}/_socket.so
645 %attr(755,root,root) %{py_dyndir}/_ssl.so
646 %attr(755,root,root) %{py_dyndir}/_testcapi.so
647 %ifnarch sparc64
648 %attr(755,root,root) %{py_dyndir}/_dbm.so
649 %endif
650 %attr(755,root,root) %{py_dyndir}/fcntl.so
651 %attr(755,root,root) %{py_dyndir}/_gdbm.so
652 %attr(755,root,root) %{py_dyndir}/grp.so
653 %attr(755,root,root) %{py_dyndir}/itertools.so
654 %attr(755,root,root) %{py_dyndir}/math.so
655 %attr(755,root,root) %{py_dyndir}/mmap.so
656 %attr(755,root,root) %{py_dyndir}/nis.so
657 %attr(755,root,root) %{py_dyndir}/operator.so
658 %attr(755,root,root) %{py_dyndir}/ossaudiodev.so
659 %attr(755,root,root) %{py_dyndir}/parser.so
660 %attr(755,root,root) %{py_dyndir}/pyexpat.so
661 %attr(755,root,root) %{py_dyndir}/readline.so
662 %attr(755,root,root) %{py_dyndir}/resource.so
663 %attr(755,root,root) %{py_dyndir}/select.so
664 %attr(755,root,root) %{py_dyndir}/syslog.so
665 %attr(755,root,root) %{py_dyndir}/termios.so
666 %attr(755,root,root) %{py_dyndir}/time.so
667 %attr(755,root,root) %{py_dyndir}/spwd.so
668 %attr(755,root,root) %{py_dyndir}/unicodedata.so
669 %attr(755,root,root) %{py_dyndir}/zlib.so
670
671 %dir %{py_scriptdir}/plat-*
672 %{py_scriptdir}/plat-*/*.py[co]
673
674 %dir %{py_scriptdir}/ctypes
675 %dir %{py_scriptdir}/ctypes/macholib
676
677 %{py_scriptdir}/ctypes/*.py[co]
678 %{py_scriptdir}/ctypes/macholib/*.py[co]
679 %doc %{py_scriptdir}/ctypes/macholib/README.ctypes
680
681 %dir %{py_scriptdir}/curses
682 %{py_scriptdir}/curses/*.py[co]
683
684 %dir %{py_scriptdir}/dbm
685 %{py_scriptdir}/dbm/*.py[co]
686
687 %dir %{py_scriptdir}/distutils
688 %dir %{py_scriptdir}/distutils/command
689 %doc %{py_scriptdir}/distutils/README
690 %{py_scriptdir}/distutils/*.py[co]
691 %{py_scriptdir}/distutils/command/*.py[co]
692 %{py_scriptdir}/distutils/command/command_template
693
694 %dir %{py_scriptdir}/email
695 %dir %{py_scriptdir}/email/mime
696 %{py_scriptdir}/email/*.py[co]
697 %{py_scriptdir}/email/mime/*.py[co]
698
699 %dir %{py_scriptdir}/html
700 %{py_scriptdir}/html/*.py[co]
701
702 %dir %{py_scriptdir}/http
703 %{py_scriptdir}/http/*.py[co]
704
705 %dir %{py_scriptdir}/importlib
706 %{py_scriptdir}/importlib/*.py[co]
707
708 %dir %{py_scriptdir}/json
709 %{py_scriptdir}/json/*.py[co]
710
711 %dir %{py_scriptdir}/logging
712 %{py_scriptdir}/logging/*.py[co]
713
714 %dir %{py_scriptdir}/multiprocessing
715 %{py_scriptdir}/multiprocessing/*.py[co]
716 %dir %{py_scriptdir}/multiprocessing/dummy
717 %{py_scriptdir}/multiprocessing/dummy/*.py[co]
718
719 %dir %{py_scriptdir}/urllib
720 %{py_scriptdir}/urllib/*.py[co]
721
722 %dir %{py_scriptdir}/wsgiref
723 %{py_scriptdir}/wsgiref/*.py[co]
724 %{py_scriptdir}/wsgiref.egg-info
725
726 %dir %{py_scriptdir}/xml
727 %dir %{py_scriptdir}/xml/dom
728 %dir %{py_scriptdir}/xml/etree
729 %dir %{py_scriptdir}/xml/parsers
730 %dir %{py_scriptdir}/xml/sax
731 %{py_scriptdir}/xml/*.py[co]
732 %{py_scriptdir}/xml/dom/*.py[co]
733 %{py_scriptdir}/xml/etree/*.py[co]
734 %{py_scriptdir}/xml/parsers/*.py[co]
735 %{py_scriptdir}/xml/sax/*.py[co]
736
737 %dir %{py_scriptdir}/xmlrpc
738 %{py_scriptdir}/xmlrpc/*.py[co]
739
740 %attr(755,root,root) %{py_dyndir}/_sqlite3.so
741 %dir %{py_scriptdir}/sqlite3
742 %{py_scriptdir}/sqlite3/*.py[co]
743
744 %files libs
745 %defattr(644,root,root,755)
746 %doc LICENSE
747 %attr(755,root,root) %{_libdir}/libpython*.so.*
748
749 %dir %{py_dyndir}
750 %dir %{py_scriptdir}
751 %dir %{py_libdir}
752 %dir %{py_sitescriptdir}
753 %dir %{py_sitedir}
754
755 # shared modules required by python library
756 %attr(755,root,root) %{py_dyndir}/_struct.so
757
758 # modules required by python library
759 %{py_scriptdir}/_abcoll.py[co]
760 %{py_scriptdir}/_weakrefset.py[co]
761 %{py_scriptdir}/abc.py[co]
762 %{py_scriptdir}/codecs.py[co]
763 %{py_scriptdir}/copyreg.py[co]
764 %{py_scriptdir}/genericpath.py[co]
765 %{py_scriptdir}/locale.py[co]
766 %{py_scriptdir}/io.py[co]
767 %{py_scriptdir}/posixpath.py[co]
768 %{py_scriptdir}/site.py[co]
769 %{py_scriptdir}/stat.py[co]
770 %{py_scriptdir}/os.py[co]
771 # needed by the dynamic sys.lib patch
772 %{py_scriptdir}/types.py[co]
773
774 # encodings required by python library
775 %dir %{py_scriptdir}/encodings
776 %{py_scriptdir}/encodings/*.py[co]
777
778 %files -n pydoc3
779 %defattr(644,root,root,755)
780 %attr(755,root,root) %{_bindir}/pydoc3
781 %{py_scriptdir}/pydoc.py[co]
782 %dir %{py_scriptdir}/pydoc_data
783 %{py_scriptdir}/pydoc_data/*.py[co]
784
785 %files -n idle3
786 %defattr(644,root,root,755)
787 %attr(755,root,root) %{_bindir}/idle3
788 %dir %{py_scriptdir}/idlelib
789 %dir %{py_scriptdir}/idlelib/Icons
790 %{py_scriptdir}/idlelib/*.py[co]
791 %doc %{py_scriptdir}/idlelib/*.txt
792 %doc %{py_scriptdir}/idlelib/ChangeLog
793 %{py_scriptdir}/idlelib/Icons/*
794 %{py_scriptdir}/idlelib/*.def
795
796 %files devel
797 %defattr(644,root,root,755)
798 %doc Misc/{ACKS,NEWS,README,README.valgrind,valgrind-python.supp}
799 %attr(755,root,root) %{_bindir}/python*-config
800 %attr(755,root,root) %{_libdir}/lib*.so
801 %dir %{py_incdir}
802 %{py_incdir}/*.h
803 %{_pkgconfigdir}/python*.pc
804
805 %dir %{py_libdir}/config
806 %attr(755,root,root) %{py_libdir}/config/makesetup
807 %attr(755,root,root) %{py_libdir}/config/install-sh
808 %{py_libdir}/config/Makefile
809 %{py_libdir}/config/Makefile.pre.in
810 %{py_libdir}/config/Setup
811 %{py_libdir}/config/Setup.config
812 %{py_libdir}/config/Setup.local
813 %{py_libdir}/config/config.c
814 %{py_libdir}/config/config.c.in
815 %{py_libdir}/config/python.o
816
817 %files devel-src
818 %defattr(644,root,root,755)
819 %attr(-,root,root) %{py_scriptdir}/*.py
820 %{py_scriptdir}/plat-*/*.py
821 %{py_scriptdir}/ctypes/*.py
822 %{py_scriptdir}/ctypes/macholib/*.py
823 %{py_scriptdir}/curses/*.py
824 %{py_scriptdir}/dbm/*.py
825 %{py_scriptdir}/distutils/*.py
826 %{py_scriptdir}/distutils/command/*.py
827 %{py_scriptdir}/email/*.py
828 %{py_scriptdir}/email/mime/*.py
829 %{py_scriptdir}/encodings/*.py
830 %{py_scriptdir}/html/*.py
831 %{py_scriptdir}/http/*.py
832 %{py_scriptdir}/idlelib/*.py
833 %{py_scriptdir}/importlib/*.py
834 %{py_scriptdir}/json/*.py
835 %{py_scriptdir}/lib2to3/*.py
836 %{py_scriptdir}/lib2to3/pgen2/*.py
837 %{py_scriptdir}/logging/*.py
838 %{py_scriptdir}/multiprocessing/*.py
839 %{py_scriptdir}/multiprocessing/dummy/*.py
840 %{py_scriptdir}/pydoc_data/*.py
841 %{py_scriptdir}/sqlite3/*.py
842 %{py_scriptdir}/tkinter/*.py
843 %{py_scriptdir}/urllib/*.py
844 %{py_scriptdir}/wsgiref/*.py
845 %{py_scriptdir}/xml/*.py
846 %{py_scriptdir}/xml/dom/*.py
847 %{py_scriptdir}/xml/etree/*.py
848 %{py_scriptdir}/xml/parsers/*.py
849 %{py_scriptdir}/xml/sax/*.py
850 %{py_scriptdir}/xmlrpc/*.py
851
852 %files devel-tools
853 %defattr(644,root,root,755)
854 %doc Lib/pdb.doc
855 /etc/shrc.d/python*-devel*
856
857 %attr(755,root,root) %{_bindir}/pygettext%{py_ver}
858
859 %{py_scriptdir}/pdb.py[co]
860 %{py_scriptdir}/profile.py[co]
861 %{py_scriptdir}/pstats.py[co]
862 %{py_scriptdir}/timeit.py[co]
863
864 %files 2to3
865 %attr(755,root,root) %{_bindir}/2to3-%{py_ver}
866 %dir %{py_scriptdir}/lib2to3
867 %{py_scriptdir}/lib2to3/*.txt
868 %{py_scriptdir}/lib2to3/*.pickle
869 %{py_scriptdir}/lib2to3/*.py[co]
870 %dir %{py_scriptdir}/lib2to3/fixes
871 %{py_scriptdir}/lib2to3/fixes/*.py
872 %{py_scriptdir}/lib2to3/fixes/*.py[co]
873 %dir %{py_scriptdir}/lib2to3/pgen2
874 %{py_scriptdir}/lib2to3/pgen2/*.py[co]
875
876 %files static
877 %defattr(644,root,root,755)
878 %{_libdir}/lib*.a
879
880 %files examples
881 %defattr(644,root,root,755)
882 %{_examplesdir}/%{name}-%{version}
883
884 %if %{with info}
885 %files doc-info
886 %defattr(644,root,root,755)
887 %{_infodir}/*.info*
888 %endif
889
890 %if %{with tkinter}
891 %files tkinter
892 %defattr(644,root,root,755)
893 %dir %{py_scriptdir}/tkinter
894 %{py_scriptdir}/tkinter/*.py[co]
895 %attr(755,root,root) %{py_dyndir}/_tkinter.so
896 %endif
This page took 0.103437 seconds and 4 git commands to generate.