]> git.pld-linux.org Git - SPECS.git/blob - python3-zstandard.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / python3-zstandard.spec
1 # Conditional build:
2 %bcond_without  tests   # unit tests
3
4 %define         module  zstandard
5 Summary:        Zstandard bindings for Python
6 Name:           python3-%{module}
7 Version:        0.21.0
8 Release:        1
9 License:        BSD
10 Group:          Libraries/Python
11 Source0:        https://pypi.debian.net/%{module}/%{module}-%{version}.tar.gz
12 # Source0-md5:  7baafeb332651d70881ce692edf912b3
13 URL:            https://github.com/indygreg/python-zstandard
14 BuildRequires:  python3-devel >= 1:3.2
15 BuildRequires:  python3-setuptools
16 %if %{with tests}
17 #BuildRequires: python3-
18 %endif
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  rpmbuild(macros) >= 1.714
21 Requires:       python3-modules >= 1:3.2
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This project provides Python bindings for interfacing with the
26 Zstandard compression library. A C extension and CFFI interface are
27 provided.
28
29 %prep
30 %setup -q -n %{module}-%{version}
31
32 %build
33
34 %py3_build %{?with_tests:test}
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38
39 %py3_install
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %doc README.rst
47 %dir %{py3_sitedir}/%{module}
48 %{py3_sitedir}/%{module}/*.py
49 %{py3_sitedir}/%{module}/*.pyi
50 %{py3_sitedir}/%{module}/py.typed
51 %attr(755,root,root) %{py3_sitedir}/%{module}/*.so
52 %{py3_sitedir}/%{module}/__pycache__
53 %{py3_sitedir}/%{module}-%{version}-py*.egg-info
This page took 0.118072 seconds and 3 git commands to generate.