]> git.pld-linux.org Git - packages/python3-setuptools.git/blob - python3-setuptools.spec
- up to 62.0.0
[packages/python3-setuptools.git] / python3-setuptools.spec
1 #
2 # Conditional build:
3 %bcond_with     apidocs         # Sphinx based documentation
4 %bcond_with     system_libs     # use system modules (appdirs, packaging, pyparsing) # TODO
5 %bcond_with     tests           # py.test tests (few failures)
6 %bcond_with     bootstrap       # convenience alias for without: apidocs,system_libs,tests
7
8 %if %{with bootstrap}
9 %undefine       with_apidocs
10 %undefine       with_system_libs
11 %undefine       with_tests
12 %endif
13
14 %define         module          setuptools
15 %define         pypi_name       setuptools
16 Summary:        A collection of enhancements to the Python distutils
17 Summary(pl.UTF-8):      Zestaw rozszerzeń dla pythonowych distutils
18 Name:           python3-setuptools
19 Version:        62.0.0
20 Release:        0.1
21 Epoch:          1
22 License:        MIT
23 Group:          Development/Languages/Python
24 #Source0Download: https://pypi.org/simple/setuptools/
25 Source0:        https://github.com/pypa/setuptools/archive/v%{version}/%{pypi_name}-%{version}.tar.gz
26 # Source0-md5:  7f932b83c8c74751a2f1e60cd569189b
27 Patch0:         setuptools-missing.patch
28 URL:            https://github.com/pypa/setuptools
29 %if %(locale -a | grep -q '^C\.utf8$'; echo $?)
30 BuildRequires:  glibc-localedb-all
31 %endif
32 BuildRequires:  python3-modules >= 1:3.6
33 %if %{with system_libs}
34 # versions from pkg_resources/_vendor/vendored.txt
35 BuildRequires:  python3-appdirs >= 1.4.3
36 BuildRequires:  python3-packaging >= 20.4
37 BuildRequires:  python3-pyparsing >= 2.2.1
38 %endif
39 BuildConflicts: python3-distribute < 0.7
40 %if %{with tests}
41 BuildRequires:  python3-Sphinx
42 BuildRequires:  python3-coverage >= 4.5.1
43 BuildRequires:  python3-flake8-2020
44 BuildRequires:  python3-jaraco.envs
45 BuildRequires:  python3-jaraco.path >= 3.2.0
46 # FIXME: patch to use unittest.mock
47 #BuildRequires: python3-mock
48 BuildRequires:  python3-paver
49 BuildRequires:  python3-pip >= 19.1
50 BuildRequires:  python3-pytest >= 4.6
51 BuildRequires:  python3-pytest-black >= 0.3.7
52 BuildRequires:  python3-pytest-checkdocs >= 2.4
53 BuildRequires:  python3-pytest-cov >= 2.5.1
54 BuildRequires:  python3-pytest-enabler >= 1.0.1
55 BuildRequires:  python3-pytest-flake8
56 BuildRequires:  python3-pytest-mypy
57 BuildRequires:  python3-pytest-virtualenv >= 1.2.7
58 BuildRequires:  python3-pytest-xdist
59 BuildRequires:  python3-virtualenv >= 13.0.0
60 BuildRequires:  python3-wheel
61 %endif
62 %if %{with apidocs}
63 BuildRequires:  python3-Sphinx
64 BuildRequires:  python3-furo
65 BuildRequires:  python3-jaraco
66 BuildRequires:  python3-jaraco.packaging >= 8.2
67 BuildRequires:  python3-jaraco.tidelift
68 BuildRequires:  python3-rst.linker >= 1.9
69 # specified but not required(?)
70 #BuildRequires: python3-pygments-github-lexers >= 0.0.5
71 BuildRequires:  python3-setuptools >= 1:34
72 BuildRequires:  python3-sphinx_favicon
73 BuildRequires:  python3-sphinx_inline_tabs
74 BuildRequires:  python3-sphinxcontrib-towncrier
75 BuildRequires:  python3-toml
76 BuildRequires:  python3-wheel
77 %endif
78 %{!?with_bootstrap:BuildRequires:       rpm-pythonprov}
79 BuildRequires:  rpmbuild(macros) >= 1.714
80 BuildRequires:  unzip
81 Requires:       python3-modules >= 1:3.6
82 %if %{with system_libs}
83 # versions from pkg_resources/_vendor/vendored.txt
84 Requires:       python3-appdirs >= 1.4.3
85 Requires:       python3-packaging >= 20.4
86 Requires:       python3-pyparsing >= 2.2.1
87 %endif
88 BuildArch:      noarch
89 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
90
91 %description
92 setuptools is a collection of enhancements to the Python distutils
93 that allow you to more easily build and distribute Python 2.x
94 packages, especially ones that have dependencies on other packages.
95
96 %description -l pl.UTF-8
97 setuptools to zestaw rozszerzeń do pythonowych distutils umożliwiający
98 łatwiejsze budowanie i rozprowadzanie pakietów Pythona 2.x,
99 szczególnie tych mających zależności od innych pakietów.
100
101 Ten pakiet zawiera składniki uruchomieniowe setuptools, potrzebne do
102 uruchamiania kodu wymagającego pkg_resources.py, przeznaczone dla
103 Pythona 2.x.
104
105 %package apidocs
106 Summary:        %{module} API documentation
107 Summary(pl.UTF-8):      Dokumentacja API %{module}
108 Group:          Documentation
109
110 %description apidocs
111 API documentation for %{module}.
112
113 %description apidocs -l pl.UTF-8
114 Dokumentacja API %{module}.
115
116 %prep
117 %setup -q -n %{module}-%{version}
118 %patch0 -p1
119
120 %if %{with system_libs}
121 exit 1 # TODO: unvendor modules from pkg_resources/_vendor
122 %endif
123
124 %build
125 LC_ALL=C.UTF-8 \
126 %py3_build
127
128 %{?with_tests:%{__python3} -m pytest pkg_resources/tests setuptools/tests tests}
129
130 %if %{with apidocs}
131 cd docs
132 %{__python3} -m sphinx -W . build/html
133 %endif
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 %py3_install
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %files
144 %defattr(644,root,root,755)
145 %doc CHANGES.rst LICENSE README.rst
146 %{py3_sitescriptdir}/_distutils_hack
147 %{py3_sitescriptdir}/distutils-precedence.pth
148 %{py3_sitescriptdir}/pkg_resources
149 %{py3_sitescriptdir}/setuptools
150 %{py3_sitescriptdir}/%{module}-%{version}*py*.egg-info
151
152 %if %{with apidocs}
153 %files apidocs
154 %defattr(644,root,root,755)
155 %doc docs/build/html/{_static,deprecated,development,references,userguide,*.html,*.js}
156 %endif
This page took 0.063003 seconds and 3 git commands to generate.