]> git.pld-linux.org Git - packages/python3-setuptools.git/blob - python3-setuptools.spec
- apidocs need network fro sphinx build, disabled, rel 3
[packages/python3-setuptools.git] / python3-setuptools.spec
1 #
2 # Conditional build:
3 %bcond_with     apidocs         # Sphinx based documentation
4 %bcond_with     system_libs     # use system modules (appdirs, packaging, pyparsing) # TODO
5 %bcond_with     tests           # py.test tests (few failures)
6 %bcond_with     bootstrap       # convenience alias for without: apidocs,system_libs,tests
7
8 %if %{with bootstrap}
9 %undefine       with_apidocs
10 %undefine       with_system_libs
11 %undefine       with_tests
12 %endif
13
14 %define         module          setuptools
15 %define         pypi_name       setuptools
16 Summary:        A collection of enhancements to the Python distutils
17 Summary(pl.UTF-8):      Zestaw rozszerzeń dla pythonowych distutils
18 Name:           python3-setuptools
19 Version:        54.2.0
20 Release:        3
21 Epoch:          1
22 License:        MIT
23 Group:          Development/Languages/Python
24 #Source0Download: https://pypi.org/simple/setuptools/
25 Source0:        https://files.pythonhosted.org/packages/source/s/setuptools/%{pypi_name}-%{version}.tar.gz
26 # Source0-md5:  09f693b5d5ca8bf4fdb1da82f8110a9c
27 Patch0:         setuptools-missing.patch
28 URL:            https://github.com/pypa/setuptools
29 %if %(locale -a | grep -q '^C\.utf8$'; echo $?)
30 BuildRequires:  glibc-localedb-all
31 %endif
32 BuildRequires:  python3-modules >= 1:3.6
33 %if %{with system_libs}
34 # versions from pkg_resources/_vendor/vendored.txt
35 BuildRequires:  python3-appdirs >= 1.4.3
36 BuildRequires:  python3-packaging >= 20.4
37 BuildRequires:  python3-pyparsing >= 2.2.1
38 %endif
39 BuildConflicts: python3-distribute < 0.7
40 %if %{with tests}
41 BuildRequires:  python3-Sphinx
42 BuildRequires:  python3-coverage >= 4.5.1
43 BuildRequires:  python3-flake8-2020
44 BuildRequires:  python3-jaraco.envs
45 BuildRequires:  python3-jaraco.path >= 3.2.0
46 # FIXME: patch to use unittest.mock
47 #BuildRequires: python3-mock
48 BuildRequires:  python3-paver
49 BuildRequires:  python3-pip >= 19.1
50 BuildRequires:  python3-pytest >= 4.6
51 BuildRequires:  python3-pytest-black >= 0.3.7
52 BuildRequires:  python3-pytest-checkdocs >= 2.4
53 BuildRequires:  python3-pytest-cov >= 2.5.1
54 BuildRequires:  python3-pytest-enabler >= 1.0.1
55 BuildRequires:  python3-pytest-flake8
56 BuildRequires:  python3-pytest-mypy
57 BuildRequires:  python3-pytest-virtualenv >= 1.2.7
58 BuildRequires:  python3-pytest-xdist
59 BuildRequires:  python3-virtualenv >= 13.0.0
60 BuildRequires:  python3-wheel
61 %endif
62 %if %{with apidocs}
63 BuildRequires:  python3-Sphinx
64 BuildRequires:  python3-jaraco
65 BuildRequires:  python3-jaraco.packaging >= 8.2
66 BuildRequires:  python3-rst.linker >= 1.9
67 # specified but not required(?)
68 #BuildRequires: python3-pygments-github-lexers >= 0.0.5
69 BuildRequires:  python3-setuptools >= 1:34
70 BuildRequires:  python3-sphinx_inline_tabs
71 BuildRequires:  python3-wheel
72 %endif
73 %{!?with_bootstrap:BuildRequires:       rpm-pythonprov}
74 BuildRequires:  rpmbuild(macros) >= 1.714
75 BuildRequires:  unzip
76 Requires:       python3-modules >= 1:3.6
77 %if %{with system_libs}
78 # versions from pkg_resources/_vendor/vendored.txt
79 Requires:       python3-appdirs >= 1.4.3
80 Requires:       python3-packaging >= 20.4
81 Requires:       python3-pyparsing >= 2.2.1
82 %endif
83 BuildArch:      noarch
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 %description
87 setuptools is a collection of enhancements to the Python distutils
88 that allow you to more easily build and distribute Python 2.x
89 packages, especially ones that have dependencies on other packages.
90
91 %description -l pl.UTF-8
92 setuptools to zestaw rozszerzeń do pythonowych distutils umożliwiający
93 łatwiejsze budowanie i rozprowadzanie pakietów Pythona 2.x,
94 szczególnie tych mających zależności od innych pakietów.
95
96 Ten pakiet zawiera składniki uruchomieniowe setuptools, potrzebne do
97 uruchamiania kodu wymagającego pkg_resources.py, przeznaczone dla
98 Pythona 2.x.
99
100 %package apidocs
101 Summary:        %{module} API documentation
102 Summary(pl.UTF-8):      Dokumentacja API %{module}
103 Group:          Documentation
104
105 %description apidocs
106 API documentation for %{module}.
107
108 %description apidocs -l pl.UTF-8
109 Dokumentacja API %{module}.
110
111 %prep
112 %setup -q -n %{module}-%{version}
113 %patch0 -p1
114
115 %if %{with system_libs}
116 exit 1 # TODO: unvendor modules from pkg_resources/_vendor
117 %endif
118
119 %build
120 LC_ALL=C.UTF-8 \
121 %py3_build
122
123 %{?with_tests:%{__python3} -m pytest pkg_resources/tests setuptools/tests tests}
124
125 %if %{with apidocs}
126 cd docs
127 %{__python3} -m sphinx -W . build/html
128 %endif
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 %py3_install
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %files
139 %defattr(644,root,root,755)
140 %doc CHANGES.rst LICENSE README.rst
141 %{py3_sitescriptdir}/_distutils_hack
142 %{py3_sitescriptdir}/distutils-precedence.pth
143 %{py3_sitescriptdir}/pkg_resources
144 %{py3_sitescriptdir}/setuptools
145 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
146
147 %if %{with apidocs}
148 %files apidocs
149 %defattr(644,root,root,755)
150 %doc docs/build/html/{_static,deprecated,development,references,userguide,*.html,*.js}
151 %endif
This page took 0.04022 seconds and 3 git commands to generate.