]> git.pld-linux.org Git - SPECS.git/blob - python3-jwt.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / python3-jwt.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # unit tests (not included in dist)
4
5 Summary:        JSON Web Token library for Python 3
6 Summary(pl.UTF-8):      Biblioteka JSON Web Token dla Pythona 3
7 Name:           python3-jwt
8 Version:        1.1.0
9 Release:        1
10 License:        MIT
11 Group:          Libraries/Python
12 #Source0Download: https://pypi.org/simple/jwt/
13 Source0:        https://files.pythonhosted.org/packages/source/j/jwt/jwt-%{version}.tar.gz
14 # Source0-md5:  d430b0a659660e43e0bd4ec92ad323d9
15 Patch0:         %{name}-requirements.patch
16 URL:            https://pypi.org/project/jwt/
17 BuildRequires:  python3-modules >= 1:3.6
18 BuildRequires:  python3-setuptools
19 %if %{with tests}
20 BuildRequires:  python3-cryptography >= 2.9.3
21 %endif
22 BuildRequires:  rpm-pythonprov
23 BuildRequires:  rpmbuild(macros) >= 1.714
24 Requires:       python3-modules >= 1:3.6
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This is a JSON Web Token library for Python developed at Gehirn Inc.
30
31 %description -l pl.UTF-8
32 Ten pakiet zawiera bibliotekÄ™ JSON Web Token dla Pythona, rozwijanÄ… w
33 Gehirn Inc.
34
35 %prep
36 %setup -q -n jwt-%{version}
37 %patch0 -p1
38
39 %build
40 %py3_build
41
42 %if %{with tests}
43 %{__python3} -m unittest discover -s jwt/tests
44 %endif
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %py3_install
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc README.rst
57 %{py3_sitescriptdir}/jwt
58 %{py3_sitescriptdir}/jwt-%{version}-py*.egg-info
This page took 1.238342 seconds and 3 git commands to generate.