]> git.pld-linux.org Git - projects/template-specs.git/blob - python.spec
- polish desc
[projects/template-specs.git] / python.spec
1 %define         module  template
2 Summary:        -
3 Summary(pl.UTF-8):      -
4 Name:           python-%{module}
5 Version:        _
6 Release:        0.1
7 License:        - (enter GPL/GPL v2/GPL v3/LGPL/BSD/BSD-like/other license name here)
8 Group:          Development/Languages/Python
9 Source0:        %{name}-%{version}.tar.gz
10 # Source0-md5:  -
11 URL:            -
12 BuildRequires:  python-devel
13 BuildRequires:  rpm-pythonprov
14 # if py_postclean is used
15 BuildRequires:  rpmbuild(macros) >= 1.219
16 #Requires:              python-libs
17 Requires:               python-modules
18 #BuildArch:     noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22
23 %description -l pl.UTF-8
24
25 %prep
26 %setup -q -n %{module}-%{version}
27
28 %build
29 export CFLAGS="%{rpmcflags}"
30 %{__python} setup.py build
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34 %{__python} setup.py install \
35         --optimize=2 \
36         --root=$RPM_BUILD_ROOT
37
38 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
39 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
40 %py_postclean
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(644,root,root,755)
47 %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
48 %{py_sitedir}/*.py[co]
49 %attr(755,root,root) %{py_sitedir}/*.so
50 %if "%{pld_release}" != "ac"
51 %{py_sitedir}/TEMPLATE-*.egg-info
52 %endif
This page took 0.036934 seconds and 4 git commands to generate.