]> git.pld-linux.org Git - projects/template-specs.git/blob - python.spec
- python 2.4 is only in AC line, let's use (kinda) agreed pld release bcond
[projects/template-specs.git] / python.spec
1 %define         module  template
2 Summary:        -
3 Summary(pl.UTF-8):      -
4 Name:           python-%{module}
5 Version:        _
6 Release:        0.1
7 License:        - (enter GPL/GPL v2/GPL v3/LGPL/BSD/BSD-like/other license name here)
8 Group:          Development/Languages/Python
9 Source0:        %{name}-%{version}.tar.gz
10 # Source0-md5:  -
11 URL:            -
12 BuildRequires:  python-devel
13 BuildRequires:  rpm-pythonprov
14 # if py_postclean is used
15 BuildRequires:  rpmbuild(macros) >= 1.219
16 #%pyrequires_eq python-libs
17 %pyrequires_eq  python-modules
18 #BuildArch:     noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22
23 %prep
24 %setup -q -n %{module}-%{version}
25
26 %build
27 export CFLAGS="%{rpmcflags}"
28 %{__python} setup.py build
29
30 %install
31 rm -rf $RPM_BUILD_ROOT
32 %{__python} setup.py install \
33         --optimize=2 \
34         --root=$RPM_BUILD_ROOT
35
36 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
37 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
38 %py_postclean
39
40 %clean
41 rm -rf $RPM_BUILD_ROOT
42
43 %files
44 %defattr(644,root,root,755)
45 %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
46 %{py_sitedir}/*.py[co]
47 %attr(755,root,root) %{py_sitedir}/*.so
48 %if "%{pld_release}" == "ac"
49 %{py_sitedir}/TEMPLATE-*.egg-info
50 %endif
This page took 0.053249 seconds and 4 git commands to generate.