]> git.pld-linux.org Git - packages/python-webunit.git/blob - python-webunit.spec
- noarch
[packages/python-webunit.git] / python-webunit.spec
1
2 %include        /usr/lib/rpm/macros.python
3 %define         module webunit
4
5 Summary:        Website unit/regression testing tool
6 Summary(pl):    Narzêdzie do testowania modu³ów sieci Web
7 Name:           python-%{module}
8 Version:        1.3.8
9 Release:        1
10 License:        BSD-like
11 Group:          Libraries/Python
12 Source0:        http://www.mechanicalcat.net/tech/webunit/%{module}-%{version}.tar.gz
13 # Source0-md5:  97b9e6b5149dadce48b86adbf2db3b0a
14 URL:            http://www.mechanicalcat.net/tech/webunit/
15 BuildRequires:  python-devel >= 2.3
16 Requires:       python >= 2.3
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 webunit test your websites with code that acts like a web browser.
22
23 Features in a nutshell:
24
25 1. Browser-like page fetching including fetching the images and
26    stylesheets needed for a page and following redirects
27 2. Cookies stored and trackable (all automatically handled)
28 3. HTTP, HTTPS, GET, POST, basic auth all handled, control over
29    expected status codes, ...
30 4. DOM parsing of pages to retrieve and analyse structure, including
31    simple form re-posting
32 5. Two-line page-fetch followed by form-submit possible, with error
33    checking
34 6. Ability to register error page content across multiple tests
35 7. Uses python's standard unittest module as the underlying framework
36
37 %description -l pl
38 webunit u¿ywany jest do testowania stron WWW przy pomocy kodu
39 symuluj±cego dzia³anie przegl±darki internetowej.
40
41 Cechy webunit:
42
43 1. Pobieranie stron WWW symuluj±ce dzia³anie przegl±darki
44    internetowej, pobieranie obrazków i styli, pod±¿anie za
45    przekierowaniami.
46 2. Automatyczna obs³uga ciasteczek (cookies).
47 3. Obs³uga protoko³ów HTTP, HTTPS, metod GET, POST, uwierzytelniania,
48    kontrola oczekiwanych kodów statusu.
49 4. Parsowanie struktury DOM stron w celu pobrania i analizy strony,
50    tak¿e w celu ³atwego odsy³ania formularzy.
51 5. Dwutorowe pobieranie strony koñczone wysy³k± formularza wraz ze
52    sprawdzaniem b³êdów.
53 6. Mo¿liwo¶æ okre¶lenia zawarto¶ci strony z b³êdem przy przechodzeniu
54    przez kolejne testy.
55 7. U¿ycie standardowego modu³u pythona unittest jako zasadniczego
56    szkieletu testu.
57
58 %prep
59 %setup -q -n %{module}-%{version}
60
61 %build
62 python setup.py build_ext
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT%{py_sitescriptdir}
67
68 python setup.py install \
69         --root=$RPM_BUILD_ROOT \
70         --install-lib=%{py_sitescriptdir} \
71         --optimize=2
72
73 find $RPM_BUILD_ROOT%{py_sitescriptdir} -name \*.py -exec rm {} \;
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc CHANGES.txt demo README.txt run_tests
81 %{py_sitescriptdir}/webunit
This page took 0.049546 seconds and 4 git commands to generate.