]> git.pld-linux.org Git - packages/python-webunit.git/blob - python-webunit.spec
f06c125c4c84dfc82f9539983da32ec81d84f33f
[packages/python-webunit.git] / python-webunit.spec
1
2 %define         module  webunit
3
4 Summary:        Website unit/regression testing tool
5 Summary(pl.UTF-8):      Narzędzie do testowania modułów sieci Web
6 Name:           python-%{module}
7 Version:        1.3.8
8 Release:        4
9 License:        BSD-like
10 Group:          Libraries/Python
11 Source0:        http://www.mechanicalcat.net/tech/webunit/%{module}-%{version}.tar.gz
12 # Source0-md5:  97b9e6b5149dadce48b86adbf2db3b0a
13 URL:            http://www.mechanicalcat.net/tech/webunit/
14 BuildRequires:  rpmbuild(macros) >= 1.710
15 BuildRequires:  python-devel >= 1:2.3
16 BuildRequires:  python-modules
17 BuildRequires:  rpm-pythonprov
18 Requires:       python >= 2.3
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 webunit test your websites with code that acts like a web browser.
24
25 Features in a nutshell:
26
27 1. Browser-like page fetching including fetching the images and
28    stylesheets needed for a page and following redirects
29 2. Cookies stored and trackable (all automatically handled)
30 3. HTTP, HTTPS, GET, POST, basic auth all handled, control over
31    expected status codes, ...
32 4. DOM parsing of pages to retrieve and analyse structure, including
33    simple form re-posting
34 5. Two-line page-fetch followed by form-submit possible, with error
35    checking
36 6. Ability to register error page content across multiple tests
37 7. Uses python's standard unittest module as the underlying framework
38
39 %description -l pl.UTF-8
40 webunit używany jest do testowania stron WWW przy pomocy kodu
41 symulującego działanie przeglądarki internetowej.
42
43 Cechy webunit:
44
45 1. Pobieranie stron WWW symulujące działanie przeglądarki
46    internetowej, pobieranie obrazków i styli, podążanie za
47    przekierowaniami.
48 2. Automatyczna obsługa ciasteczek (cookies).
49 3. Obsługa protokołów HTTP, HTTPS, metod GET, POST, uwierzytelniania,
50    kontrola oczekiwanych kodów statusu.
51 4. Parsowanie struktury DOM stron w celu pobrania i analizy strony,
52    także w celu łatwego odsyłania formularzy.
53 5. Dwutorowe pobieranie strony kończone wysyłką formularza wraz ze
54    sprawdzaniem błędów.
55 6. Możliwość określenia zawartości strony z błędem przy przechodzeniu
56    przez kolejne testy.
57 7. Użycie standardowego modułu pythona unittest jako zasadniczego
58    szkieletu testu.
59
60 %prep
61 %setup -q -n %{module}-%{version}
62
63 %build
64 python setup.py build_ext
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT%{py_sitescriptdir}
69
70 %py_install \
71         --install-lib=%{py_sitescriptdir} \
72         --optimize=2
73
74 find $RPM_BUILD_ROOT%{py_sitescriptdir} -name \*.py -exec rm {} \;
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc CHANGES.txt demo README.txt run_tests
82 %{py_sitescriptdir}/webunit
This page took 0.044103 seconds and 3 git commands to generate.