]> git.pld-linux.org Git - SPECS.git/blob - python-vcversioner.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / python-vcversioner.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Use version control tags to discover version numbers
7 Summary(pl.UTF-8):      Użycie znaczników kontroli wersji do wykrywania numerów wersji
8 Name:           python-vcversioner
9 Version:        2.16.0.0
10 Release:        6
11 License:        ISC
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/vcversioner/
14 Source0:        https://files.pythonhosted.org/packages/source/v/vcversioner/vcversioner-%{version}.tar.gz
15 # Source0-md5:  aab6ef5e0cf8614a1b1140ed5b7f107d
16 URL:            https://github.com/habnabit/vcversioner
17 BuildRequires:  rpm-pythonprov
18 # for the py_build, py_install macros
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with python2}
21 BuildRequires:  python-modules >= 1:2.6
22 BuildRequires:  python-setuptools
23 %endif
24 %if %{with python3}
25 BuildRequires:  python3-modules >= 1:3.3
26 BuildRequires:  python3-setuptools
27 %endif
28 Requires:       python-modules >= 1:2.6
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This module allows you to write a setup.py with no version information
34 specified, and vcversioner will find a recent, properly-formatted VCS
35 tag and extract a version from it.
36
37 %description -l pl.UTF-8
38 Ten moduł pozwala na tworzenie plików setup.py nie zawierających
39 informacji o wersji; vcversioner znajdzie najnowszy, właściwie
40 sformatowany znacznik VCS i wydobędzie z niego numer wersji.
41
42 %package -n python3-vcversioner
43 Summary:        Use version control tags to discover version numbers
44 Summary(pl.UTF-8):      Użycie znaczników kontroli wersji do wykrywania numerów wersji
45 Group:          Libraries/Python
46 Requires:       python3-modules >= 1:3.3
47
48 %description -n python3-vcversioner
49 This module allows you to write a setup.py with no version information
50 specified, and vcversioner will find a recent, properly-formatted VCS
51 tag and extract a version from it.
52
53 %description -n python3-vcversioner -l pl.UTF-8
54 Ten moduł pozwala na tworzenie plików setup.py nie zawierających
55 informacji o wersji; vcversioner znajdzie najnowszy, właściwie
56 sformatowany znacznik VCS i wydobędzie z niego numer wersji.
57
58 %prep
59 %setup -q -n vcversioner-%{version}
60
61 %build
62 %if %{with python2}
63 %py_build
64 %endif
65
66 %if %{with python3}
67 %py3_build
68 %endif
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %if %{with python2}
74 %py_install
75
76 %py_postclean
77 %endif
78
79 %if %{with python3}
80 %py3_install
81 %endif
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %if %{with python2}
87 %files
88 %defattr(644,root,root,755)
89 %doc README.rst
90 %{py_sitescriptdir}/vcversioner.py[co]
91 %{py_sitescriptdir}/vcversioner-%{version}-py*.egg-info
92 %endif
93
94 %if %{with python3}
95 %files -n python3-vcversioner
96 %defattr(644,root,root,755)
97 %doc README.rst
98 %{py3_sitescriptdir}/vcversioner.py
99 %{py3_sitescriptdir}/__pycache__/vcversioner.cpython-*.py[co]
100 %{py3_sitescriptdir}/vcversioner-%{version}-py*.egg-info
101 %endif
This page took 1.749805 seconds and 3 git commands to generate.