]> git.pld-linux.org Git - packages/python-urllib3.git/blob - python-urllib3.spec
2b7d2c6e6ebc89472d58ce931b811dc1173bbdcf
[packages/python-urllib3.git] / python-urllib3.spec
1 # TODO: use system six, [backports.]ssl_match_hostname
2 #
3 # Conditional build:
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6 %bcond_without  doc     # Sphinx documentation
7 %bcond_with     tests   # test target (uses network etc.)
8
9 %define         module          urllib3
10 Summary:        HTTP library with thread-safe connection pooling, file post, and more
11 Summary(pl.UTF-8):      Biblioteka HTTP z bezpieczną wątkowo pulą połączeń, wysyłaniem plików itd.
12 Name:           python-%{module}
13 Version:        1.23
14 Release:        1
15 License:        MIT
16 Group:          Development/Languages/Python
17 Source0:        https://files.pythonhosted.org/packages/source/u/urllib3/%{module}-%{version}.tar.gz
18 # Source0-md5:  1ad43e4b5ab7a0794c89dc057e1d7179
19 URL:            http://urllib3.readthedocs.org/
20 %if %{with python2}
21 BuildRequires:  python-modules >= 1:2.7
22 %if %{with tests}
23 BuildRequires:  python-PySocks >= 1.5.6
24 BuildRequires:  python-PySocks < 2.0
25 BuildRequires:  python-mock
26 BuildRequires:  python-nose
27 BuildRequires:  python-tornado
28 # SO_REUSEPORT option
29 BuildRequires:  uname(release) >= 3.9
30 %endif
31 %endif
32 %if %{with python3}
33 BuildRequires:  python3-modules >= 1:3.4
34 %if %{with tests}
35 BuildRequires:  python3-PySocks >= 1.5.6
36 BuildRequires:  python3-PySocks < 2.0
37 BuildRequires:  python3-nose
38 BuildRequires:  python3-tornado
39 # SO_REUSEPORT option
40 BuildRequires:  uname(release) >= 3.9
41 %endif
42 %endif
43 BuildRequires:  rpm-pythonprov
44 BuildRequires:  rpmbuild(macros) >= 1.714
45 %if %{with doc}
46 BuildRequires:  sphinx-pdg
47 %endif
48 Requires:       python-modules >= 1:2.7
49 BuildArch:      noarch
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Python 2 HTTP module with connection pooling and file POST abilities.
54 Features are:
55 - Re-use the same socket connection for multiple requests (with
56   optional client-side certificate verification).
57 - File posting (encode_multipart_formdata).
58 - Built-in redirection and retries (optional).
59 - Supports gzip and deflate decoding.
60 - Thread-safe and sanity-safe.
61
62 %description -l pl.UTF-8
63 Moduł HTTP dla Pythona 2 z pulą połączeń i możliwością wysyłania
64 plików metodą POST. Możliwości:
65 - używanie tego samego połączenia dla wielu żądań (z opcjonalną
66   weryfikacją certyfikatu po stronie klienta)
67 - wysyłanie plików (encode_multipart_formdata)
68 - wbudowane przekierowania i ponawianie prób (opcjonalne)
69 - obsługa kodowań gzip i deflate
70 - bezpieczeństwo względem wątków.
71
72 %package -n python3-urllib3
73 Summary:        HTTP library with thread-safe connection pooling, file post, and more
74 Summary(pl.UTF-8):      Biblioteka HTTP z bezpieczną wątkowo pulą połączeń, wysyłaniem plików itd.
75 Group:          Development/Languages/Python
76 Requires:       python3-modules >= 1:3.4
77
78 %description -n python3-urllib3
79 Python 3 HTTP module with connection pooling and file POST abilities.
80 Features are:
81 - Re-use the same socket connection for multiple requests (with
82   optional client-side certificate verification).
83 - File posting (encode_multipart_formdata).
84 - Built-in redirection and retries (optional).
85 - Supports gzip and deflate decoding.
86 - Thread-safe and sanity-safe.
87
88 %description -n python3-urllib3 -l pl.UTF-8
89 Moduł HTTP dla Pythona 3 z pulą połączeń i możliwością wysyłania
90 plików metodą POST. Możliwości:
91 - używanie tego samego połączenia dla wielu żądań (z opcjonalną
92   weryfikacją certyfikatu po stronie klienta)
93 - wysyłanie plików (encode_multipart_formdata)
94 - wbudowane przekierowania i ponawianie prób (opcjonalne)
95 - obsługa kodowań gzip i deflate
96 - bezpieczeństwo względem wątków.
97
98 %package apidocs
99 Summary:        API documentation for Python urllib3 module
100 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona urllib3
101 Group:          Documentation
102
103 %description apidocs
104 API documentation for Python urllib3 module.
105
106 %description apidocs -l pl.UTF-8
107 Dokumentacja API modułu Pythona urllib3.
108
109 %prep
110 %setup -q -n %{module}-%{version}
111
112 %build
113 %if %{with python2}
114 %py_build %{?with_tests:test}
115 %endif
116
117 %if %{with python3}
118 %py3_build %{?with_tests:test}
119 %endif
120
121 %if %{with doc}
122 %{__make} -C docs html
123 %endif
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 %if %{with python2}
129 %py_install
130 %py_postclean
131 %endif
132
133 %if %{with python3}
134 %py3_install
135 %endif
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %if %{with python2}
141 %files
142 %defattr(644,root,root,755)
143 %doc CHANGES.rst CONTRIBUTORS.txt LICENSE.txt README.rst
144 %{py_sitescriptdir}/%{module}
145 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
146 %endif
147
148 %if %{with python3}
149 %files -n python3-urllib3
150 %defattr(644,root,root,755)
151 %doc CHANGES.rst CONTRIBUTORS.txt LICENSE.txt README.rst
152 %{py3_sitescriptdir}/%{module}
153 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
154 %endif
155
156 %if %{with doc}
157 %files apidocs
158 %defattr(644,root,root,755)
159 %doc docs/_build/html/{_static,reference,*.html,*.js}
160 %endif
This page took 0.102066 seconds and 3 git commands to generate.