]> git.pld-linux.org Git - packages/python-uncompyle6.git/blob - python-uncompyle6.spec
1c4cfc4ee29bf97e6a168cdad626b53535fd50c9
[packages/python-uncompyle6.git] / python-uncompyle6.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         module          uncompyle6
6 %define         egg_name        uncompyle6
7 %define         pypi_name       uncompyle6
8 Summary:        A Python decompiler, disassembler and cross-version bytecode library
9 Name:           python-%{pypi_name}
10 Version:        2.6.0
11 Release:        1
12 License:        MIT
13 Group:          Applications
14 Source0:        https://github.com/rocky/python-uncompyle6/archive/release-%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  bfa928d524c800d4c61ff46e3c119e6e
16 URL:            https://github.com/rocky/python-uncompyle6/
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.219
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 uncompyle6 translates Python bytecode back into equivalent Python
24 source code. It accepts bytecodes from Python version 2.5 to 3.4 or so
25 and has been tested on Python running versions 2.6, 2.7, 3.3, 3.4 and
26 3.5.
27
28 %prep
29 %setup -qn %{name}-release-%{version}
30
31 %build
32 %py_build
33
34 %if %{with tests}
35 %{__make} PYTHONPATH=$(pwd) check
36 %endif
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 %py_install
41 %py_postclean
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %attr(755,root,root) %{_bindir}/pydisassemble
49 %attr(755,root,root) %{_bindir}/uncompyle6
50 %{py_sitescriptdir}/%{module}
51 %{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
This page took 0.035826 seconds and 2 git commands to generate.