]> git.pld-linux.org Git - SPECS.git/blob - python-tabulate.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / python-tabulate.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         module          tabulate
7 Summary:        Pretty-print tabular data
8 Summary(pl.UTF-8):      Ładne wypisywanie danych tabelarycznych
9 Name:           python-%{module}
10 # keep 0.8.x here for python2 support
11 Version:        0.8.10
12 Release:        1
13 License:        MIT
14 Group:          Libraries/Python
15 #Source0Download: https://pypi.org/simple/tabulate/
16 Source0:        https://files.pythonhosted.org/packages/source/t/tabulate/%{module}-%{version}.tar.gz
17 # Source0-md5:  70cc6906675fc840e2675ecd022641bc
18 URL:            https://github.com/astanin/python-tabulate
19 %if %{with python2}
20 BuildRequires:  python-modules >= 1:2.7
21 BuildRequires:  python-setuptools
22 %endif
23 %if %{with python3}
24 BuildRequires:  python3-modules >= 1:3.5
25 BuildRequires:  python3-setuptools
26 %endif
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  rpmbuild(macros) >= 1.714
29 Requires:       python-modules >= 1:2.7
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Pretty-print tabular data in Python.
35
36 The main use cases of the library are:
37 - printing small tables without hassle: just one function call,
38   formatting is guided by the data itself
39 - authoring tabular data for lightweight plain-text markup: multiple
40   output formats suitable for further editing or transformation
41 - readable presentation of mixed textual and numeric data: smart
42   column alignment, configurable number formatting, alignment by a
43   decimal point
44
45 %description -l pl.UTF-8
46 Ładne wypisywanie danych tabelarycznych w Pythonie.
47
48 Główne przypadki użycia tej biblioteki to:
49 - proste wypisywanie małych tabelek - tylko jedno wywołanie funkcji,
50   formatowanie sugerowane przez same dane
51 - tworzenie danych tabelarycznych do lekkich znaczników tekstowych -
52   wiele formatów wyjściowych, odpowiednich do dalszej edycji lub
53   przekształceń
54 - czytelna prezentacja mieszanych danych tekstowych i liczbowych -
55   inteligentne wyrównywanie kolumn, konfigurowalne formatowanie liczb,
56   wyrównywanie do kropki/przecinka dziesiętnego
57
58 %package -n python3-%{module}
59 Summary:        Pretty-print tabular data
60 Summary(pl.UTF-8):      Ładne wypisywanie danych tabelarycznych
61 Group:          Libraries/Python
62 Requires:       python3-modules >= 1:3.5
63
64 %description -n python3-%{module}
65 Pretty-print tabular data in Python.
66
67 The main use cases of the library are:
68 - printing small tables without hassle: just one function call,
69   formatting is guided by the data itself
70 - authoring tabular data for lightweight plain-text markup: multiple
71   output formats suitable for further editing or transformation
72 - readable presentation of mixed textual and numeric data: smart
73   column alignment, configurable number formatting, alignment by a
74   decimal point
75
76 %description -n python3-%{module} -l pl.UTF-8
77 Ładne wypisywanie danych tabelarycznych w Pythonie.
78
79 Główne przypadki użycia tej biblioteki to:
80 - proste wypisywanie małych tabelek - tylko jedno wywołanie funkcji,
81   formatowanie sugerowane przez same dane
82 - tworzenie danych tabelarycznych do lekkich znaczników tekstowych -
83   wiele formatów wyjściowych, odpowiednich do dalszej edycji lub
84   przekształceń
85 - czytelna prezentacja mieszanych danych tekstowych i liczbowych -
86   inteligentne wyrównywanie kolumn, konfigurowalne formatowanie liczb,
87   wyrównywanie do kropki/przecinka dziesiętnego
88
89 %prep
90 %setup -q -n %{module}-%{version}
91
92 %build
93 %if %{with python2}
94 %py_build
95 %endif
96
97 %if %{with python3}
98 %py3_build
99 %endif
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %if %{with python2}
105 %py_install
106
107 %py_postclean
108 %endif
109
110 %if %{with python3}
111 %py3_install
112 %endif
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %if %{with python2}
118 %files
119 %defattr(644,root,root,755)
120 %doc CHANGELOG README.md
121 %if %{without python3}
122 %attr(755,root,root) %{_bindir}/tabulate
123 %endif
124 %{py_sitescriptdir}/%{module}.py[co]
125 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
126 %endif
127
128 %if %{with python3}
129 %files -n python3-%{module}
130 %defattr(644,root,root,755)
131 %doc CHANGELOG README.md
132 %attr(755,root,root) %{_bindir}/tabulate
133 %{py3_sitescriptdir}/__pycache__/%{module}.cpython-*.py[co]
134 %{py3_sitescriptdir}/%{module}.py
135 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
136 %endif
This page took 0.081645 seconds and 3 git commands to generate.