]> git.pld-linux.org Git - SPECS.git/blob - python-tables.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / python-tables.spec
1
2 %define         module  tables
3
4 Summary:        Dealing with large datasets in Python
5 Summary(pl.UTF-8):      Obsługa dużych zbiorów danych w Pythonie
6 Name:           python-%{module}
7 Version:        2.0.4
8 Release:        1
9 License:        GNU
10 Group:          Development/Languages/Python
11 Source0:        http://dl.sourceforge.net/pytables/pytables-%{version}.tar.gz
12 # Source0-md5:  e9892962256d28c898ea0c985e60c09e
13 URL:            http://pytables.sourceforge.net/
14 BuildRequires:  rpmbuild(macros) >= 1.710
15 BuildRequires:  hdf5-devel
16 BuildRequires:  lzo-devel
17 BuildRequires:  python
18 BuildRequires:  python-devel >= 1:2.3
19 BuildRequires:  python-numarray
20 BuildRequires:  python-numarray-devel
21 BuildRequires:  ucl-devel
22 %pyrequires_eq  python-modules
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 PyTables is a hierarchical database package designed to efficiently
27 manage very large amounts of data.
28
29 PyTables is built on top of the HDF5 library and the numarray package.
30 It features an object-oriented interface that, combined with C
31 extensions for the peformance-critical parts of the code (generated
32 using Pyrex), makes it a fast, yet extremely easy to use tool for
33 interactively save and retrieve very large amounts of data. One
34 important feature of PyTables is that it optimizes memory and disk
35 resources so that data take much less space (between a factor 3 to 5,
36 and more if the data is compressible) than other solutions, like for
37 example, relational or object oriented databases.
38
39 Besides, it provides a flexible, direct access on disk to anywhere in
40 the data you want to go, using a combination of natural naming and
41 extended slicing features.
42
43 %description -l pl.UTF-8
44 PyTables jest hierarchiczną bazą danych zaprojektowaną aby wydajnie
45 zarządzać bardzo dużymi ilościami danych.
46
47 PyTables jest zbudowany w oparciu o bibliotekę HDF5 i pakiet numarray.
48 Zapewnia zorientowany obiektowo interfejs, dzięki któremu, w
49 połączeniu z przepisanymi do C krytycznymi częściami kodu, pozwala na
50 bardzo szybkie i łatwe używanie tego narzędzia do interaktywnego
51 zapisu lub odczytu dużych ilości danych. Jedną z ważniejszych zalet
52 PyTables jest optymalizacja zużycia pamięci i przestrzeni dyskowej.
53
54 %prep
55 %setup -q -n pytables-%{version}
56
57 %build
58 CFLAGS="%{rpmcflags}"
59 export CFLAGS
60 python setup.py build_ext --inplace
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
66
67 %py_install
68
69 mv examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
70
71 find $RPM_BUILD_ROOT%{py_sitedir} -name '*.py' | xargs rm
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc ANNOUNCE.txt LICENSE.txt MIGRATING_TO_2.x.txt README.txt RELEASE_NOTES.txt THANKS TODO.txt VERSION doc/
79 %attr(755,root,root) %{_bindir}/*
80 %dir %{py_sitedir}/%{module}
81 %{py_sitedir}/%{module}/*
82 %dir %{_examplesdir}/%{name}-%{version}
83 %{_examplesdir}/%{name}-%{version}/*
This page took 0.329781 seconds and 3 git commands to generate.