]> git.pld-linux.org Git - SPECS.git/blob - python-stomper.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / python-stomper.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 %define commit 9b9fddf
8 Summary:        A python client implementation of the STOMP protocol
9 Name:           python-stomper
10 Version:        0.2.9
11 Release:        2
12 License:        Apache v2.0
13 Group:          Development/Languages
14 # Latest releases didn't appear on pypi.
15 # https://github.com/oisinmulvihill/stomper/issues/8
16 #Source0:        https://pypi.python.org/packages/source/s/stomper/stomper-%{version}.tar.gz
17 Source0:        https://github.com/oisinmulvihill/stomper/archive/%{commit}/stomper-%{commit}.tar.gz
18 # Source0-md5:  9a86b59224aa322a46598cd0b1d72177
19 URL:            https://pypi.python.org/pypi/stomper
20 BuildRequires:  python-modules
21 BuildRequires:  python-setuptools
22 BuildRequires:  rpm-pythonprov
23 BuildRequires:  rpmbuild(macros) >= 1.710
24 %if %{with tests}
25 BuildRequires:  python-nose
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This is a python client implementation of the STOMP protocol. The
32 client is attempting to be transport layer neutral. This module
33 provides functions to create and parse STOMP messages in a programatic
34 fashion.
35
36 %prep
37 %setup -qc
38 mv stomper-%{commit}*/* .
39
40 %build
41 %py_build
42
43 %if %{with tests}
44 PYTHONPATH=. nosetests-%{py_ver} -q
45 %endif
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 %py_install
50
51 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/stomper/tests
52
53 %py_postclean
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc README.rst
61 %{py_sitescriptdir}/stomper
62 %{py_sitescriptdir}/stomper-%{version}-py*.egg-info
This page took 0.313511 seconds and 3 git commands to generate.