]> git.pld-linux.org Git - packages/python-sqlite.git/blob - python-sqlite.spec
- Up to 2.0.7, BR: updated accordingly, STBR
[packages/python-sqlite.git] / python-sqlite.spec
1
2 %define         module  sqlite
3
4 Summary:        A DB API v2.0 compatible interface to SQLite
5 Summary(pl):    Interfejs do SQLite kompatybilny z DB API v2.0
6 Name:           python-%{module}
7 Version:        2.0.7
8 Release:        1
9 License:        zlib/libpng
10 Group:          Development/Languages/Python
11 Source0:        http://initd.org/pub/software/pysqlite/releases/2.0/%{version}/pysqlite-%{version}.tar.gz
12 # Source0-md5:  15ab26f859f8a0fd21659d4d105056a5
13 URL:            http://www.pysqlite.org/
14 %pyrequires_eq  python-modules
15 BuildRequires:  python-devel >= 1:2.3
16 BuildRequires:  python-setuptools >= 0.6a6
17 BuildRequires:  sqlite3-devel
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 This is an extension module for the SQLite embedded relational
22 database. It tries to conform to the Python DB-API Spec v2 as far as
23 possible. One problem is that SQLite returns everything as text. This
24 is a result of SQLite's internal representation of data, however it
25 still may be possible to return data in the type specified by the
26 table definitions.
27
28 %description -l pl
29 Ten pakiet zawiera modu³ rozszerzenia dla osadzalnej relacyjnej bazy
30 danych SQLite. Próbuje on byæ w zgodzie ze specyfikacj± Python DB-API
31 v2 na tyle, na ile to mo¿liwe. Jednym problemem jest to, ¿e SQLite
32 zwraca wszystko jako tekst. Jest to wynik wewnêtrznej reprezentacji
33 danych przez SQLite; mimo to nadal jest mo¿liwe zwracanie danych typu
34 podanego w definicji tabeli.
35
36 %prep
37 %setup -q -n pysqlite-%{version}
38
39 %build
40 CFLAGS="%{rpmcflags}"
41 export CFLAGS
42 python setup.py build
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_examplesdir}/%{name}-%{version}}
47
48 PYTHONPATH=$RPM_BUILD_ROOT%{py_sitedir} \
49         python setup.py install \
50         --root=$RPM_BUILD_ROOT --optimize=2 \
51         --single-version-externally-managed
52
53 rm -rf $RPM_BUILD_ROOT%{py_sitedir}/pysqlite2/{,test/}*.py \
54         $RPM_BUILD_ROOT%{_prefix}/pysqlite2-doc
55 cp -aR doc/code/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc doc/*.txt
63 %dir %{py_sitedir}/pysqlite2
64 %{py_sitedir}/pysqlite2/*.py[co]
65 %attr(755,root,root) %{py_sitedir}/pysqlite2/_%{module}.so
66 %dir %{py_sitedir}/pysqlite2/test
67 %{py_sitedir}/pysqlite2/test/*.py[co]
68 %dir %{py_sitedir}/*.egg-info
69 %{py_sitedir}/*.egg-info/*
70 %dir %{_examplesdir}/%{name}-%{version}
71 %{_examplesdir}/%{name}-%{version}/*
This page took 0.072766 seconds and 4 git commands to generate.